TTLG|Thief|Bioshock|System Shock|Deus Ex|Mobile
Results 1 to 6 of 6

Thread: No sound (original)

  1. #1
    New Member
    Registered: Mar 2009

    No sound (original)

    Hello there guys!

    I registered here after literally crawling the web for hours and hours. I am desperately trying to play System Shock 2 on windows XP, but cannot find the solution. Here it goes:

    I installed System Shock 2 multiple times. I patched it, I left it untouched, set compatibility modes... the whole program. At first the cutscenes would not let me even start the game without renaming the responsible data. After finding the appropriate Indeo pack, System Shock 2 would at least play back the cinematics in-game. Huh. Well.

    Now the main problem: I, for the life of it, can't find a reason for why I don't have any in-game sound. I have the familiar humming in the menu. I do not have it when switching to the audio options tab. I don't have any audio in-game. I can't change "Hardware Acceleration" from off to on. Same goes for EAX.

    I have both the English as well as the German version on disc next to me, neither of them changes anything.

    So, I am desperately trying to get it to run decently. Please, if someone was able to help me I would be willing to grant eternal life plus expenses caused. I have to play this game, one way or another.

    Thank you, whoever it is who will help me, in advance.

    Edit: Seeing as apparently I made some poor person move this thread: Sorry for not posting it in the right section.
    Last edited by skillphiliac; 19th Mar 2009 at 21:23.

  2. #2
    Member
    Registered: Aug 2006
    Location: Stuttgart
    please post which mods and so on you have used

    here is a way to install it
    setup -lgntforce
    install indeo(from cd)
    install multiplayerpatch 2.3(from sshock2.com)
    install blutpatch(from QBi)
    install languagepatch(from Stranger)
    install shockcfg(from sourceforge.net)
    set to win98
    use xpfix(see FAQ)
    enjoy!

  3. #3
    Member
    Registered: Mar 2001
    Location: Ireland
    No, don't use compatibility modes, they just make the game crash.

  4. #4
    New Member
    Registered: Mar 2009
    Thank you for trying, but I covered it all before.

    I haven't tried any mods, all I did was installing the game, setting compatibility modes (necessary for me in order to play!) and optionally installing the patch.

    Still, I am really desperate, so, again I will try your procedure, Ir0NiXdark, seeing as it would lead to the original version (which I prefer, although I remember the synchronisation and localization to be quite good ).

    I'll keep you posted.

  5. #5
    Member
    Registered: Aug 2006
    Location: Stuttgart
    nameless voice: sure! didnt see this! -lgntforce makes this a remainer hehe

    skillphiliac: after applaying the patch 2.3 some texts are not in german

  6. #6
    New Member
    Registered: Mar 2009
    Sorry for doubleposting, I am doing this in order to be able to help others as stupid, stupid as I am. Oh my god.

    Well, I have found a solution. I have a rather new ACER laptop with a Realtek HD Audio device. I didn't want all that hassle with Vista, so I figured I'd install XP. I did, but it turned out to be rather difficult to get all the drivers for XP. So, what I found out was, that from time to time the Realtek Audio Manager changes the output from two speakers to five (which are normally supported, I just don't have the needed drivers ready) rendering in-game sound specifically useless.

    In short: If you don't have any sound besides the humming or other static noises, go with changing from five to two speakers. It did the job for me.

    Thank you for your help, this problem is solved!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •