TTLG|Thief|Bioshock|System Shock|Deus Ex|Mobile
Results 1 to 5 of 5

Thread: Thief 3 Control Issues, Intermittant Delayed Crouching, Backstabbing

  1. #1

    Thief 3 Control Issues, Intermittant Delayed Crouching, Backstabbing

    Freshly installed GOG version of Thief 3. Garret occasionally needs to think for about 5 seconds before he'll crouch after I press the button. Same thing happens with backstabbing-- Garret and his victim will be frozen in place for several seconds before the animations will 'unfreeze' and perform the deed.

    My crouch toggle is mapped to the 'c' key. (The only semi-related thread I found mentioned problems using Ctrl; I'm not using Ctrl)

    I tried to search for this issue, but you'll have to forgive me if I missed any obvious posts, as this forum tends to load very slowly for me.

    Any tips would be much appreciated.


    Edit: Seems to be something to do with vsync when it's off. But even though I've tried forcing it on in Catalyst, windowed mode still suffers the problem. It seems to be impossible to have windowed mode with vsync enabled.
    Last edited by Moogie; 6th May 2012 at 16:51.

  2. #2
    Member
    Registered: Feb 2003
    Location: Sweden
    I would try changing vsync in one of the ini files, that's how most tweaking is done in Thief 3. There are a few tweak guides around that should be able to tell you how. I'd provide a link but i'm at work.

  3. #3
    Thanks, I had a look for vsync in the files but couldn't find it. I assumed the ingame option would basically do this itself.

    Besides this, the biggest issue I'm currently facing is massive juddery, jittery lag when moving about near lightsources. The game runs fine in dark areas, but as soon as I approach a bright lightsource, the shuddering is enough to give me a headache.

    I'm using the SneakyThief upgrade and T3Tweaks. I haven't modified my FOV, and I'm using one of the resolution settings from the ingame slider (1280x800). I've tried lowering all graphical settings: shadows to 0, light cutoff to maximum, Bloom off, AA off. This seems to make very little to no impact on performance.

    My specs are as follows:

    Intel Quad-Core i5 2400 (2.3GHz)
    8GB RAM
    Radeon 6850HB

    I've also tried setting the core affinity for the game but this didn't help.

  4. #4
    Sneaky Upgrader
    Registered: May 2007
    A couple of suggestions, but don't get your hopes up...

    - In the display driver settings, force vsync on and limit the frame rate to 60 Hz if you're currently running higher
    - Disable 'Catalyst AI' (or the equivalent, I think they've renamed it?)

  5. #5
    Quote Originally Posted by snobel View Post
    A couple of suggestions, but don't get your hopes up...

    - In the display driver settings, force vsync on and limit the frame rate to 60 Hz if you're currently running higher
    - Disable 'Catalyst AI' (or the equivalent, I think they've renamed it?)
    Hiya, thanks for the suggestions. These didn't work by themselves, but I think I found some combination that solves all my problems!

    Unfortunately I don't have it narrowed down and I'm scared to go reverting the changes I made. But essentially, these were the last few tweaks I tried, in addition to the ones you posted. Any combination of these could have been the magic formula:

    In Catalyst Control Center:
    - Vsync forced 'on'
    - Unticking 'AMD Optimized' Tesselation
    - 'Use application settings' for Anistropic, Anti-Aliasing, and Tesselation

    In Default.ini:
    - Setting PlayerControllerFPSrate to 30 (from default 60)

    In-game settings:
    - Max graphical settings (Shadows, Anti-Aliasing, LoD)
    - No Bloom
    - Minimum Light Cutoff


    I tested the same area I had tested for the past 10-15 attempts: a bright lightsource in the Tutorial mission, at the top of the road where you're taught to hide from a patrolling guard. This area has been the best example of the shuddering behaviour I was experiencing. Circle-strafing around this lightsource felt like sitting atop a washing machine.

    Post-tweaks, the shuddering is gone, and I'm not noticing the crouch-freezing issue either! I daresay the problem is solved, or at least, reduced to a very playable degree.

    Thanks for the input!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •