TTLG|Thief|Bioshock|System Shock|Deus Ex|Mobile
Results 1 to 9 of 9

Thread: [Thief Gold/Thief II] Movies will NOT play.. tried nearly everything

  1. #1
    New Member
    Registered: Mar 2012

    [Thief Gold/Thief II] Movies will NOT play.. tried nearly everything

    I'm currently in the same situation as this guy http://www.ttlg.com/forums/showthread.php?t=138901

    The game itself runs fine. However clicking on Credits or Intro the screen flashes black for a second and does nothing.

    However my movies play in WMP. I've been trying to get this to work on and off for about 3 months now and it's really starting to get to me.

    My specs:

    Windows 7 Home 64-bit
    Radeon HD 5870m
    6GB of RAM

    Things ive tried:

    Everything in the FAQ
    - register ir50_32.dll
    - register LGVID.AX
    tried as a bat file too and ran as admin

    - multiple ddfix versions
    - Running Thief.exe as admin
    - Turned off Windows UAC
    - downloaded re-encoded movies, however they still dont play in game (from here and also from here)
    - added thief executables in ffdshow decoder
    - downloaded k-lite codec pack
    - uninstalled DivX

    Heres a few graph edits when rendering the original videos

    32bit graphedit



    64bit graphedit

    I get a pop up saying "Some of the streams in this movie are in an unsupported format"



    I would really appreciate any help towards a solution. I really would love to play these games with the movies. Thanks in advance!
    Last edited by kokoro1280; 26th May 2012 at 02:56.

  2. #2
    Moderator
    Registered: Apr 2003
    Location: UK
    Hopefully someone will be able to help you. In the meantime, please resize your images - 800 px wide is the maximum width allowed.

  3. #3
    New Member
    Registered: Mar 2012
    ah sorry about that, fixed now.

  4. #4
    Moderator
    Registered: Sep 2000
    Location: Australia
    Are you running the exe in Admin mode? If not, right click Thief 2 and change it to run in administrator mode (under compatibility settings).
    Last edited by twisty; 30th May 2012 at 04:56.

  5. #5
    New Member
    Registered: Mar 2012
    yeah i have them running as admin. My UAC is also turned off (tried with it on too with the same result). And thanks for the reply i appreciate it . I'm close to giving up but something always has me coming back trying to get them working.

  6. #6
    Administrator
    Registered: Oct 2000
    Location: Athens of the North
    It would be useful if you can download and run Filmerit. If you're not running Thief it will probably find a problem with the "LG Video Renderer" - but that should at least exist as an entry in the list. If not, that could be a problem.

    If you then start Thief (in administrator mode) and alt-tab back to Filmerit when you get to the menu you should be able to refresh the list (File / Analyze the register or press ctrl+W). This time, the "LG Video Renderer" shouldn't show an error and if you expand its details the "Server File" property should point to the lgvid.ax file in your Thief installation. Exiting Thief normally (i.e. without it crashing) should de-register the lgvid.ax file again.

    If you're not seeing the above behaviour then it might point to another problem.

  7. #7
    New Member
    Registered: Mar 2012
    So i downloaded Filmerit and it says "0 error among 200 filters."
    Also i dont have a "LG Video Renderer" in the list. What could this mean? On a side note i have CCCP installed currently.

  8. #8
    Administrator
    Registered: Oct 2000
    Location: Athens of the North
    Quote Originally Posted by kokoro1280 View Post
    Also i dont have a "LG Video Renderer" in the list.
    That's quite possibly the problem - it should be there as it the renderer registered through lgvid.ax.

    Which security software do you have installed? My suspicion at the moment is that something on your machine is preventing Thief from registering it's decoder which might be a valid security measure in most cases but it's possibly to blame for the problem here.

  9. #9
    New Member
    Registered: Mar 2012
    I have Comodo firewall and Avira antivir. I also thought this might be it so i added the thief executables as a trusted application in comodo, and added the thief_gold folder to avira's exclusion list. But even after then it was the same so i thought this wasnt the problem.

    I just tried it with them both disabled. Same result

    EDIT: My brother also has Comodo and Avira. Loaded up thief on his PC and videos play even without ddfix.. So i guess its not my security software. Bah

    EDIT 2: I really don't know what could be blocking LGVID.AX from registering. If it helps i will list whats installed on my system currently(aside from games and the like)

    Code:
    avast! Free Antivirus
    Bandisoft MPEG-1 Decoder
    CCleaner
    Combined Community Codec Pack 2011-11-11
    Comodo Internet Security
    Defraggler
    HandBrake 0.9.6
    VLC Media player 2.0.1
    Windows Media Player Firefox Plugin
    I don't know if any of these would remotely have an affect on the lgvid.ax from registering. Hope this helps somewhat.


    EDIT 3: I guess i give up for now, don't really know what else to try as i've exhausted everything i can think of. Probably the only thing i can do next is to re-install windows.
    Thanks for the suggestions =)
    Last edited by kokoro1280; 5th Jun 2012 at 17:54.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •