TTLG|Thief|Bioshock|System Shock|Deus Ex|Mobile
Results 1 to 8 of 8

Thread: Arx Fatalis graphical troubleshooting

  1. #1

    Arx Fatalis graphical troubleshooting

    This thread is a quick list of known fixes for certain graphical issues that can occur with recent video cards.

    (0) General Notes

    First of all, you should ensure that you are running / have patched to v1.17 of the game, or later.

    Secondly, it is generally advisable to use the latest drivers for your card, although this is not always the case with older games (or older cards, for that matter). Nevertheless, you should do this unless you know a specific reason not to.



    (1) The game is playable, but certain objects are displayed with flat white surfaces instead of their proper textures.

    This is due to a bug in the game which is only exposed by some recent video cards with more advanced texturing abilities than were available when the game was released. A user has provided a manual fix by resizing all affected textures in the game. You can read about it and obtain the download at the nVidia forums.

    Although the linked thread is nVidia-specific, the fix is such that it should solve the issue regardless of your video hardware (assuming that it is in fact the same issue).



    (2) "all interactive objects-- NPCs, the PC, stones, inventory items, creatures, etc -- are completely invisible. This also seems to effect the game in other ways; for example I cannot select an object, such as a door, that's invisible, although I do collide with it."

    This has been reported with a GeForce 5200 FX video card and DirectX 9.0c, and was fixed by using the Forceware 61.77 drivers.



    (3) The screen flickers like crazy

    Try setting forcegdi=1 in the cfg.ini text file.

    Failing that, it has been suggested by someone on the JoWood forums that turning Clear-Type off can help some flickering problems.
    Last edited by Shadowcat; 6th Dec 2008 at 18:56.

  2. #2
    BR796164
    Registered: Dec 2000
    Location: Bratislava, Slovakia
    Much thanks for that solution of white textures problem.
    First time I played Arx, it was on my old Voodoo Banshee and I had the same problem. The readme recognizes this only as a 3Dfx specific issue, suggesting the user should change value ForceMetalTwopass in CFG to "1". This doesn't work for my new 6600GT though... I'll try that solution from nVidia forums.

  3. #3
    Member
    Registered: Aug 2001
    That texture fix should be placed at a more permanent location! Thankfully, it's still around, though, and I've saved it. But I only today acquired Arx Fatalis and encountered these white textures.

    Here's a nice before and after comparison:

    Before (fresh install, 1.17 patch):


    After (just downloaded the ZIP, and unarchived it to /Arx Fatalis):

  4. #4
    Thiefmissions.com
    Moderator

    Registered: Mar 2001
    Location: Houston, Tx., USA
    A long shot that anyone's still playing this, I know, but I didn't manage to finish the game on my last rig and I'm having trouble getting things to work well on my new machine.

    The problem is basically that portions of the screen flicker terribly when the mouse cursor is visible or a few other objects (like a torch) are onscreen. The game is playable if you don't mind the flicker, but it gives me something of a headache.

    I'm running Arx fully patched (1.17) including the texture fix for the white objects.

    My rig:

    Athlon FX62, Asus M2N32SLI-deluxe, 4GB RAM, XP64
    2x EVGA 8800GTX cards, 97.44 drivers; 96.89 had the same problem
    Dell 3007WFP

    Edit: And after poking through cfg.ini I see that setting forcegdi=1 solves the problem. I honestly have no idea what that's supposed to do, but I'm not complaining because now I can finally finish this game.
    Last edited by epithumia; 9th Dec 2006 at 18:23.

  5. #5
    Moderator
    Registered: Sep 2000
    Location: Australia
    My Gawd. That's one hell of a system you got there.

    As far as screen flickering is concerned, it has been suggested by someone on the JoWood forums to try turning Clear-Type off.

  6. #6
    Thiefmissions.com
    Moderator

    Registered: Mar 2001
    Location: Houston, Tx., USA
    Quote Originally Posted by twisty View Post
    My Gawd. That's one hell of a system you got there.
    Sorry, I usually don't go on about my system, but I figured details were kind of necessary.

    Quote Originally Posted by twisty View Post
    As far as screen flickering is concerned, it has been suggested by someone on the JoWood forums to try turning Clear-Type off.
    Cleartype was off and just to verify, turning it on made no difference. Still, the forcegdi=1 setting seems to have made everything better.

  7. #7
    New Member
    Registered: May 2007
    Quote Originally Posted by poroshin View Post
    After (just downloaded the ZIP, and unarchived it to /Arx Fatalis):

    thanks guys it worked for me too
    someone said he tryed a lot of links and it didnt work... the first time i tryed download that if failed after 20% or so but i tryed again in the same place and it worked

    it would sux if i couldnt finish arx fatalis in my new computer because i was near the end

  8. #8
    New Member
    Registered: Jan 2009
    Location: Galati Romania
    I have a problem with Arx.My screen make funny when I enter miguel and lots of the zones in arx.Screen interuption. ill make a movie right now and ill post it .Maybe you can help me? i really wana play arx

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •