TTLG|Thief|Bioshock|System Shock|Deus Ex|Mobile
Results 1 to 12 of 12

Thread: Thief Deadly Shadows mouse cursor missing fix

  1. #1
    Member
    Registered: Aug 2006

    Thief Deadly Shadows mouse cursor missing fix

    If you use Windows DPI scaling on a high-resolution screen, your mouse cursor may be stuck / missing in the game.

    Edit the game's DEFAULT.INI (system directory)
    Go to [MouseCursor] section
    Comment out the "ImageFile=MouseCursor.dds" line. A semicolon at the front of the line works.

    Now you will have a default Windows mouse cursor that works.

  2. #2
    Member
    Registered: Oct 2013
    I only had to lower DPI by 1% to free the cursor, but thought I would give this a go.

    Didn't seem to work for me. Maybe it is a mod I use.

  3. #3
    Sneaky Upgrader
    Registered: May 2007
    Quote Originally Posted by swaaye View Post
    Comment out the "ImageFile=MouseCursor.dds" line. A semicolon at the front of the line works.
    Now you will have a default Windows mouse cursor that works.
    Nice find! Out of the box it would work only in the menu, not the game itself. But it was a good starting point for a bit of patching...

    Would both of you mind giving the pre-release a spin? I'm not sure at this point what the default limit for activation should be, so feedback would be appreciated.

  4. #4
    Member
    Registered: Oct 2013
    I said above that semi-coloning out the setting did not work for me, and nor did installing the PR SU, but it occurs to me that my expectations of what I will see may be incorrect.

    Am I wrong in expecting to see the Windows white cursor after doing either? I still see the dark T3 cursor but maybe that is how it should be?

  5. #5
    Sneaky Upgrader
    Registered: May 2007
    Commenting out the texture should give you a white Windows cursor in the menu and an invisible one in the game's pause screen and readables. At least it did for me.

    The PR SU replaces the Windows cursor with the T3 one, that's why you see no difference. Does it work for you if you revert your 1% change?

  6. #6
    Member
    Registered: Oct 2013
    As I say, commenting out the line made no difference, but I only had a ; in front rather than having the ; and then a space before the start of the line. No idea if that would make a difference.

    Anyway, I restored to 150 DPI and the PR SU results are as follows.
    Setting the fallback limit in STweaker to =<143 gave me a moveable cursor in the menu and in the guest logbook in the Inn mission.
    Setting the limit to 144 or higher gave the familiar frozen cursor.

    No idea why this should be the case. Since the system is at 150 shouldn't the fallback kick in for any limit set before this? But no, 143 is the working cutoff point, for my system at least.

    HTH and good work.

  7. #7
    Sneaky Upgrader
    Registered: May 2007
    Quote Originally Posted by Cigam View Post
    As I say, commenting out the line made no difference, but I only had a ; in front rather than having the ; and then a space before the start of the line. No idea if that would make a difference.
    Did you try it while the Minimalist Project was activated? The MP has its own Default.ini file, which has higher priority. The space is not important, btw.

    Anyway, I restored to 150 DPI and the PR SU results are as follows.
    Setting the fallback limit in STweaker to =<143 gave me a moveable cursor in the menu and in the guest logbook in the Inn mission.
    Setting the limit to 144 or higher gave the familiar frozen cursor.
    Windows shows font sizes as a percentage relative to Normal size (100%), which is 96 DPI. So 150% = 144 DPI. The fix is activated when screen DPI > tweaker value, so all is well...

    Thanks for testing.

  8. #8
    Great to finally have a fix for this! Just tried the prerelease on my machine running Windows 7 and 150% font size and the cursor is present.

  9. #9
    Member
    Registered: Oct 2013
    Good to know all is well.

    On the white mouse pointer thing, disabling MP did the trick. Doing this and setting fallback value higher than system dpi gave the windows cursor both in menus and the Inn guestbook.

    Much easier to see as well, than the dark one.

  10. #10
    Sneaky Upgrader
    Registered: May 2007
    Quote Originally Posted by mensch View Post
    Great to finally have a fix for this! Just tried the prerelease on my machine running Windows 7 and 150% font size and the cursor is present.
    Thanks for trying that out.

    Quote Originally Posted by Cigam View Post
    On the white mouse pointer thing, disabling MP did the trick. Doing this and setting fallback value higher than system dpi gave the windows cursor both in menus and the Inn guestbook.
    Yes, setting the value higher will disable the SU fix, hiding the texture will then make the game use the old fallback code. And there's an additional fix in the SU pre-release to make sure the cursor is shown in-game as well as in the menu.

    Much easier to see as well, than the dark one.
    You prefer the Windows cursor? It's definitely easier to see, but also a bit immersion breaking...

  11. #11
    Member
    Registered: Oct 2013
    Just tried the same ini tweak for DE:IW, but unfortunately the game no longer loads and crashes back to the desktop after the intro movies. Guess DE:IW players are out of luck.

  12. #12
    New Member
    Registered: Nov 2017
    You guys can try disabling "software mouse cursor" in f.lux (if you use it), worked for me.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •