TTLG|Thief|Bioshock|System Shock|Deus Ex|Mobile
Page 109 of 110 FirstFirst ... 9596469747984899499104105106107108109110 LastLast
Results 2,701 to 2,725 of 2728

Thread: TFix: unofficial patch for Thief1/Gold

  1. #2701
    Member
    Registered: Oct 2013
    OK thanks, won't bother with a 1gb+ download of latest GoG installer then.

  2. #2702
    Member
    Registered: Dec 2011
    Location: Ferrol - Spain
    Great!
    Door texture in Assassins mission is now in its correct shape and position.
    Another door to be corrected in Bafford´s.
    Uploaded to bug list.

  3. #2703
    Zombified
    Registered: Sep 2004
    note that this looks bad only because you are using an unsupported texture pack which exaggerates the issue, the door looks fine in vanilla or with EP2, even though its V offset technically is somewhat off. but FIX, because it looks better aligned properly.

    unsupported:


    EP2:

  4. #2704
    Zombified
    Registered: Sep 2004
    this has always been the default (auto_equip is a user.bnd variable and no version of TFix or GOG package modifies that file, so whatever is set in the install you are currently patching will still be there after the update is done. if the file is missing, the game will generate it upon first run with auto_equip set to 0, so default off), and I'm pretty sure I'd get complaints if I were to suddenly change it now, so it's better left alone. whoever wants it, can simply enable it.

    //I can affect what is generated by default however. hmm.. maybe I'll change it. //ok, why not - the not yet deployed 1.26 GOG build has been updated, so once it's in, whoever will freshly install the game from GOG, will get auto-equip enabled by default. no change for those who already have their own user.bnd - they will get whatever is already set there. complaints will be redirected to MasterFlaw's pm box.
    Last edited by voodoo47; 24th Jun 2018 at 11:15.

  5. #2705
    Zombified
    Registered: Sep 2004
    ah, you are talking about steam/oldDark behavior - I'm not supporting that, whoever wants to use it today is on their own.


    Lite now also has the fix.
    Last edited by voodoo47; 25th Jun 2018 at 09:30.

  6. #2706
    New Member
    Registered: Jun 2016
    What are some good settings to apply in the NecroMod? When playing, Garrett's hand looks a little funny when drawing a sword or blackjack.

  7. #2707
    Zombified
    Registered: Sep 2004
    there are no settings, it's either the mod loaded or not. no idea what do you mean by little funny - post a screenshot.

    //I think the proper motions might be missing or not getting loaded in certain situations - if that's the case, then repatching with TFix and leaving the default mod loadout alone should fix it.
    Last edited by voodoo47; 19th Jul 2018 at 09:52.

  8. #2708
    New Member
    Registered: Jun 2016
    Toyed around a bit and got it all figured out now. Only thing how do I get the sky mods to work for the T1 fan missons? When starting a fan mission, all I see is a space-like black sky with small dotted stars.

  9. #2709
    Zombified
    Registered: Sep 2004
    you need to pick the sky of your preference (missXX.mis.dml in the \MODS\t2skies folder), create a copy of the dml, and rename it into whatever the fan mission mis name is (example if the FM has thievery.mis, the dml would be thievery.mis.dml). you also need to delete the following from the dml:
    Code:
    FINGERPRINT
    {
       QVAR "origmis" == 1
    }
    then start a new game with the FM to see the changes.

  10. #2710
    Member
    Registered: Apr 2016
    Location: Strawberry Fields
    Hi. My FPS has tanked when playing the game with the HD mod 1.2 on TFix 1.26. Doesn't matter whether I'm playing at 4K with 16x anti-aliasing or at 1080p with none, when standing still not touching the controls at the beginning of Cragscleft, the game goes from 60fps to 47fps up and down. It feels horrible and very stuttery to control. I've turned off vsync in the HD mod configuration program, I've removed and added the semi-colon from the rgb10_buf thing in cam_ext, I've tried playing to see if it goes away, I've restarted the level from the restart button etc. nothing works.
    Didn't have this problem before. Solid 60fps always, even at 4K. I believe that was on 1.25d, though I'm not certain. Anyone know what's causing this?

    EDIT: Actually restarting the level drops the FPS down to 30 and below. Loading from a save played on a non-HD mod version does the above. Reinstalling TFix which got rid of the HD textures has the game running perfectly again. Reinstalling TFix then HDMod still has the same issue. I've tried Bafford's, Cragscleft and Assassins. Only Bafford runs flawlessly judging from a few minutes of gameplay. Assassins runs at 4fps right from the get go.
    Last edited by IAmTheWalrus; 29th Jul 2018 at 03:25.

  11. #2711
    Member
    Registered: Apr 2016
    Location: Strawberry Fields
    Also there's a glitch or, something, where whenever you click with the mouse it drops the FPS to 30.

  12. #2712
    Zombified
    Registered: Sep 2004
    well, if things work ok with just TFix, then the problem is probably not TFix related - but anyway, quickly checked hdmod Assassins with 1.26 on my more than a decade old computer, and no issues whatsoever (not quite hitting 60FPS when looking at Farkus, but 55 is still way more than 4, also no issues with the mouse). did this start to happen suddenly, or after updating to 1.26?

    anyway, (sudden) performance issues can be caused by a lot of things - windows update, driver update, antivirus, hw changes, conflicting settings.. try to pinpoint the problem - start by getting the 1.25 exe from the previous ND package and run the game through that, maybe make sure nothing is forced in the nv control panel, don't run the game from program files, check/post the log, you know, the usual stuff.

  13. #2713
    Member
    Registered: Apr 2016
    Location: Strawberry Fields
    It's just it was working fine with 1.25, and not 1.26, so wasn't sure what else that'd chalk up to. This all happened after updating to 1.26, but obviously it's just me so I'll just leave it as it is for now. I can live with it.

    Thanks for the help anyways.

  14. #2714
    Member
    Registered: Apr 2016
    Location: Strawberry Fields
    Also, on 1.26 with no graphical mods of any kind after a mission restart, right at the beginning of Bonehoard at the top left up the hill with the tomb thing and the purple and gold piece of loot the tomb is floating.
    Hope this isn't just me again. I'd post a screenshot but my Steam overlay isn't working.

  15. #2715
    Zombified
    Registered: Sep 2004
    what I mean to say, did this start to happen exactly after updating to 1.26, or some time after updating to 1.26, because those two things are very different.

    anyway, if it's something 1.26 is doing, then going back to 1.25 should fix it instantly - would be interesting to know, and provide a point from which troubleshooting can start.


    yeah that loot is floating a bit, will floor it next time.

  16. #2716
    Member
    Registered: Apr 2016
    Location: Strawberry Fields
    Ah, right, gotcha. It happened exactly after updating to 1.26, right after a fresh install. I'd help but downloading the game takes an hour on my garbage internet, and I'm actually suspecting my HD mod download is maybe corrupt, so I'd have to download that which would take longer, which would slow down the internet for everyone else in the house. Sorry.

  17. #2717
    Zombified
    Registered: Sep 2004
    grabbing the 1.25 exe from the 1.25 ND package should be easy, and light on bandwidth.

  18. #2718
    Member
    Registered: Apr 2016
    Location: Strawberry Fields
    I can't find 1.25 for Thief Gold there.

  19. #2719
    Zombified
    Registered: Sep 2004
    using the T2 exe is ok (they are the same thing).

  20. #2720
    Member
    Registered: Apr 2016
    Location: Strawberry Fields
    I haven't tried downloading HD mod with it because I actually want to use the original textures now but the clicking causing FPS drop thing is still happening with the T2 1.25 exe. It's starting to drive me nuts.

  21. #2721
    Member
    Registered: Apr 2016
    Location: Strawberry Fields
    Would it be possible for you to upload 1.25d for Thief Gold again or would that be too much of a hassle?
    EDIT: Nevermind. No need. Found 1.25c and that has the same click issue. Thief 2 on the latest version of Tafferpatcher doesn't have this issue.
    Okay, so I've done a fresh install (haven't touched a single thing, not controls, not files, nothing) with 1.25c and the click issue still happens. Done the same with 1.26 and it happens. I've restored NVIDIA control panel stuff to default. I've done the _buf thing in cam_ext. I've tried with all the optional graphics things enabled in TFix and without (besides Linux of course). Still happens. I don't have any idea any more.
    Also the game has frustrating micro-stutters, whether I click or not.
    Last edited by IAmTheWalrus; 31st Jul 2018 at 05:40.

  22. #2722
    Zombified
    Registered: Sep 2004
    so it's pretty safe to say this isn't related to the NewDark version. is LAA (EnableLAA.exe) enabled? try renaming the exe (to tg.exe for example), this should get rid of any windows compatibility settings that may be silently applied. try a clean TG install and use just TFix Lite.

    if nothing will help, I guess the only thing you can do now is to start messing with installed windows updates and gpu driver versions, a tedious, annoying process which can actually break things even more. I would start by popping a spare drive in and make a new clean windows install, see whether that makes things better, and start from there.
    Last edited by voodoo47; 31st Jul 2018 at 12:10.

  23. #2723
    Member
    Registered: Apr 2016
    Location: Strawberry Fields
    Oh thank you so much. Renaming the .exe worked. Fixed the micro-stuttering and the stuttering when I click. Phew! For some reason compatibility mode was turned on, so I renamed it back and turned that off so I could still launch from Steam. Appreciate the help mate, cheers.

  24. #2724
    Zombified
    Registered: Sep 2004
    sure thing.

  25. #2725
    Member
    Registered: Apr 2016
    Location: Strawberry Fields

Page 109 of 110 FirstFirst ... 9596469747984899499104105106107108109110 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •