TTLG|Thief|Bioshock|System Shock|Deus Ex|Mobile
Page 44 of 45 FirstFirst ... 49141924293439404142434445 LastLast
Results 1,076 to 1,100 of 1112

Thread: Tafferpatcher: unofficial complete patch for Thief 2

  1. #1076
    Registered: Jul 2016

    Game not working

    So, I'm having a bit of trouble here.

    I applied the patch. Thief2 worked, but I noticed it didn't apply the EP2 textures. So I went in and played with the mod path a little, and now missions won't even LOAD ;_; Games starts up, I select New Game, first cutscene plays, I click past the objectives screen....

    And boom, crash.

    Even if I comment out the entire mod line, it does this! Any idea what's up?

    EDIT: Ok, even worse: Dromed refuses to work! It loads very slowly, and will no longer Portalize! =O Might have to start fresh here...

    EDIT 2: Made a completely new, fresh install. Everything works good, except some of these new Enhancement pack textures are either ugly or don't do a good job replicating the originals (You know those giant brown bricks you sometimes see? Replaced by a bunch of small gray and blue stones. And windows made for the green brick texture now have YELLOW bricks. Whaaaa?). I may have to pick and choose from the older EP and replace, because man, some of these really fouled up my FM and a few of the OMs.
    Last edited by Steele; 8th Aug 2016 at 12:54.

  2. #1077
    Registered: Apr 2005
    Location: Heart of Darkness
    Hello, long time no see. I suppose it isn't a surprise for one who does not wish to be seen...

    I'm having trouble with Thief 2 and NewDark. It seems that the update has confused poor Brother Cavador and he now spends most of his time trying to walk through a wall next to a door instead of through the door. It makes his inspection runs rather difficult since he's literally incapable of leaving his bedroom. This has now happened 5/5 times I've tried and retried the mission.

    Here's 27096g for anyone who can solve my problem OOPS nevermind. Only had to replay 7 times until I got Cavador out of his house. So, nothing to do with NewDark. Untlike the lightmaps in Ramirez' counting room.
    Last edited by Platinumoxicity; 2nd Sep 2016 at 13:16.

  3. #1078
    New Member
    Registered: Apr 2014
    Having an issue with TafferPatcher on Windows 10 similar to some users a few pages back.

    I had been playing Thief II fan missions a lot on this computer but took a long (~6 months) break. Decided to get back into it again today but found Thief II immediately crashed to desktop. This happened whether I tried to run the original game or a fan mission through TP's built in selector. I then reinstalled the game and patched it with the latest TafferPatcher several times, but no luck. The game still immediately crashed to desktop. It runs unpatched, however. I suspect a Windows 10 update broke compatibility or something.

    I tried another user's suggestion of dropping files from NewDark 1.24 into the patched Thief II folder but the game still crashed.

    Crash log and thief.log here:

    Edit: I think it's not recognizing the correct version of my OS. Windows 7 compatibility mode got it working again, though. Since this seems to be an issue with multiple Windows 10 users, will this be fixed in a future update?
    Last edited by lpowell; 6th Sep 2016 at 00:17.

  4. #1079
    So I installed Tafferpatcher, ran the game and everything looks good.
    Installed HD Mod by Bentraxx and everything looks good, except the sky isn't as nice, I like the clouds better in Tafferpatchers version.

    I can't figure out how to change just the sky to the version that Tafferpatcher uses.

    Any help?

  5. #1080
    Also with HDMod, when I put out the first torch in the first mission, the guards don't have their conversation.

    "Damn torches, always sputtering out!"

  6. #1081
    Registered: Feb 2009
    Location: some ancient Cycladian island

    black screen on starting missions

    Please, help!!!
    I upgraded some time ago to win.10 and now that I have the time, I reinstalled all 3 games, used TafferPatcher_TMA_217_beta for Thief2 .I "think" I did everything the faq says but the result is this black screen as I start any new mission. Weapons and items are there but I can not see the environments,just black!...
    f I try to start any of the already played missions (which I have kept and copied from the win.7 to win.10), all is fine. Can someone point me to the right direction please?

    Tannar tried to help me with this :

    [----Two possibilities spring to mind. In your Thief folder, you will have a file called cam_ext.cfg. Open that in any text reader, such as notepad. Scroll down to "display mode" and look for the following:

    ; ------------
    ; display mode
    ; ------------

    ; enable Direct3D 9 based display system (instead of the legacy DirectX 6 one)

    ; use a single resolution for both menu system and in-game, with normal double buffering (in fullscreen)
    single_display_mode 2

    ; same as above but with triple buffering
    ;single_display_mode 3
    ; alternative buffering mode that uses blitting instead of buffer flipping in fullscreen, the same method
    ; as windowed mode uses (vsync may sporadically miss frame starts on some systems)

    ; scale menu system to fit screen (in "single_display_mode") using 3D HW for best quality
    ; (if you're having trouble like a black screen when starting the game try mode 0 or 1)
    ; when "use_d3d_display" is enabled, 3D HW is always used, this only sets the scale mode to fit screen
    ui_scale_mode 2

    If that isn't the problem, find the entry for "D3D9 render options" and make sure "multisampletype 8" has a semi-colon in front of it:

    ; -------------------
    ; D3D9 render options
    ; -------------------

    ; NOTE: these options can only have any effect when "use_d3d_display" is enabled

    ; by default it will try to use an enhanced 32-bit precision display mode, if the driver supports it, but
    ; there may be instances (like with integrated intel GPUs) where the driver does support it but it may not
    ; work correctly (such as gamma not working), this option will disable the use of enhanced precision

    ; multisampling (anti-aliasing) level
    ; IMPORTANT: some integrated graphics HW may not work correctly with multisampling and you will be left with a
    ; black screen, if that happens disable this option again
    ; multisampletype 8 -----]

    but none helped me solve it.

    My game folder is not inside Programs files

    win.10 pro
    Intel Core i7 -3610QM CPU @2.30 GH
    RAM 8G
    Intel Core HD Graphics 4000
    NVIDIA GeForce 640M

    What am I doing wrong?

  7. #1082
    Registered: Sep 2004
    find use_d3d_display, d3d_disp_no_rgb10_buf and multisampletype 8 in cam_ext.cfg, and make sure they look like this;
    ;multisampletype 8
    forcing the game to run on the nvidia card would be a good idea too (gpu control panel, look for profiles or similar).
    Last edited by voodoo47; 9th Oct 2016 at 12:36.

  8. #1083
    Registered: Feb 2009
    Location: some ancient Cycladian island
    voodoo47 thank you for your response ... the first solution didn't work

    if by "(gpu control panel, look for profiles or similar)" you mean the NVIDIA control panel, I have these options:

    under "manage 3d settings" > program settings
    a. Integrated graphics
    b. High performance NVIDIA possessor
    c. use global setting

    under "global settings"
    a. Integrated graphics
    b. High performance NVIDIA possessor
    c. auto-select

    under "set PhysX Configuration"
    a.GeForce GT640M
    c. auto-select

    is this where I should look? because, I tried some variations without success

  9. #1084
    Old FMs work (examples?), new ones don't? Which one? Do original missions work?
    Did you install NewDark at all? Check the T2.exe
    -->Properties-->Product Version. It should be "1.24"

  10. #1085
    Registered: Feb 2009
    Location: some ancient Cycladian island
    Unna Oertdottir you wrote the magic words!!!
    I have used tafferpacher and followed the steps ... but nothing.
    Now, going to check the version of the .exe I came across the newdark zip inside my folder and unzipped it there...
    Well, I guess that was that! !!!
    Thank you SO VERY MUCH !!!!! :-)

    (But, for some reason I had the impression that Newdark is included into tafferpatcher and is extracted automatically through it.)

  11. #1086
    NewDark is just an option in TP, you need to check it.
    Glad you made it.

  12. #1087
    New Member
    Registered: Dec 2005
    Windows 7, Intel HD Graphics.
    TafferPatcher 217
    After loading level there is black screen. Mission is loaded (hearing sounds and voices).

    What happening?
    Thanks for help.

  13. #1088
    Install TP again, make sure to install Newdark.

  14. #1089
    Registered: Sep 2004
    Quote Originally Posted by voodoo47 View Post
    find use_d3d_display, d3d_disp_no_rgb10_buf and multisampletype 8 in cam_ext.cfg, and make sure they look like this;
    ;multisampletype 8

  15. #1090
    Registered: Dec 2015
    Location: Germany
    Quote Originally Posted by lpowell View Post

    Edit: I think it's not recognizing the correct version of my OS. Windows 7 compatibility mode got it working again, though. Since this seems to be an issue with multiple Windows 10 users, will this be fixed in a future update?
    I have Windows 10, too. Running Thief under compatibility mode (Windows 7) also works for me.

  16. #1091
    Registered: Apr 2013
    I played mission "First City Bank and Trust" with current Tafferpatcher (NewDark 1.24) and I noticed that there is one strange combat bot. This combat bot infinitely long analyzes the situation by waving his arms. I saved this situation. Is this a bug?

  17. #1092
    Registered: Sep 2004
    if you are using the overhauled gamesys and maps, you should ask am16 to have a look.

  18. #1093
    Registered: Apr 2013
    As first I installed Thief 2 1.18, as second I installed Tafferpatcher 2.0.17 as full installation, as third I copied file thief2v118.exe (version 1.18) to game. I created obsolete savegame by running thief2v118.exe, with version 1.24 I loaded this 1.18 savegame and at one time I had this result with bot. I deleted this obsolete 1.18 savegame but 1.24 savegame was not deleted. This savegame may be useful because I suspect that combat bot stands on the stairs in wrong way.

    Link to download this savegame is -
    Last edited by Xmodule999; 18th Jan 2017 at 08:53.

  19. #1094
    Registered: Sep 2002
    Location: College Place, WA
    Compatibility of saves between versions of Newdark and Newdark is probably questionable at best, let alone between versions of Olddark and Newdark. If you upgrade the game executable, do the sensible thing and just restart the mission. We can't do anything about it anyway.

    I just loaded your savegame, and there doesn't appear to be anything wrong with the combat bots around the player. One is disabled, the other is in search mode, and after a bit keeps searching?

  20. #1095
    Registered: Apr 2013
    It's not fully compatibility between 1.18 and 1.24 saves as I saw. Today I saw the same situation with bot in Sabotage at Soulforge at the start (I started with version 1.18 then I continued my game with version 1.24, game was not saved by me).

    I decided to douse one torch and after dousing this torch while bot's bomb exploded near this torch (bomb on the ground) I saw torch with fire, little strange but nothing to fix.
    Last edited by Xmodule999; 19th Jan 2017 at 05:22.

  21. #1096
    Don't load the old savegame. C'mon

  22. #1097
    Registered: Apr 2013
    Quote Originally Posted by Unna Oertdottir View Post
    Don't load the old savegame. C'mon
    Sometimes it's a necessity.

  23. #1098
    Registered: Sep 2004
    "NewDark doesn't work when I disable my soundcard" => "don't do it then"

  24. #1099
    Registered: Dec 2004
    Location: Germany
    Quote Originally Posted by Xmodule999 View Post
    Sometimes it's a necessity.
    Just because it is a necessity, it doesn't necessarily work.

    I have seen compatibility issues with saved games between NewDark 1.23 and 1.24 myself. There's no way around it, as far as I know. Maybe there could be some obscure way of editing a saved game in order to transfer it between different versions of Thief and/or NewDark, but I doubt that anyone would be interested in spending time looking for this obscure way.

    I think you better try to find another solution for your problem.

  25. #1100
    I need help. I want to install the latest version of TafferPatcher so I can play the newer FMs that are coming out now, but there's so many different types of installation under the "how to" section of this thread I don't know which I need to use. I've got Thief 2 already installed along with an older version of TP. How do I update it? It seemed like this set of instructions might be the one to follow, but they're confusing:

    1. Install a fresh copy of Thief 2. Or make sure it doesn't have any fan-missions or mods installed.
    2. If you're not installing Thief 2 via TP, select the folder where Thief 2 is installed.
    3. On the page with the list of available patches, There's a preset listbox. Note that it affects only the default set of selected patches, you may as well ignore it and select them on your own. Patch 1.18 is always on and grayed out on purpose.
    4. Click Next all the way to finish the installation. On the first run, TP will check for old versions of files and install Patch 1.18 if needed. In addition, all .CRF files in the root folder will be repacked into ones in .\RES subfolder to make it compatible with fan-missions.
    5. On the Finish page you can run additional configuration utilities and Thief 2 itself to test it.

    I don't understand how one gets from step 2 to 3. What page? What is a listbox? In my Thief2 folder there's another folder labeled TafferPatcher, but inside it is only a folder labeled Backup and a Tafferpatcher configuration settings file. It's been a VERY long time since I installed my current version of Tafferpatcher (and I don't even remember what version that is) that I've completely forgotten how these processes go. Any help would be greatly appreciated. Thank you!

Page 44 of 45 FirstFirst ... 49141924293439404142434445 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts