TTLG|Thief|Bioshock|System Shock|Deus Ex|Mobile
Results 1 to 3 of 3

Thread: Thief 1 &2 not working with windows 7

  1. #1
    New Member
    Registered: Mar 2010

    Thief 1 &2 not working with windows 7

    I have Thief 3 playing without issue on my windows 7 but the other two will not install at all any suggestions to how to fix this issue


    thanks

    Rene

  2. #2
    Member
    Registered: Jul 2007
    Location: free koki
    For Thief I, have a look through the FAQ listing here if you haven't already. As for Thief II, I installed it just yesterday on W7 64bit with this utility by DJ Riff, worked right off the bat. Try that, it's a WIP but seems to be working flawlessly, and allows you to configure the different packages applied. If any of the options in the patcher seem confusing, again, refer to the FAQ, it should clear everything up.

  3. #3

    It worked! And thank you sooooo much!!

    I wanted to take a moment to post to this thread. I’ve been doing a lot of digging around on the net to try and find a way to get any of the Thief games to work. Not sure exactly how or what made this work, I’m going to assume it was the tafferpatcher program that was linked from this thread. Thank you so much! Here’s what worked for me and the system specs:

    Asus Laptop G73jh
    I7 Quad-Core
    6 Gigs of Ram
    Windows 7 – 64bit
    ATI Radion HD 5870

    1) Standard install via CD’s (Thief2)
    2) Applied patch 1.07 to 1.18
    3) Copied CD1 on to desktop (folder: T2CD01)
    4) Copied CD2 on to desktop (folder: T2CD02)
    5) Ran tafferpatcher.exe and when promoted for the CD source I browsed to the applicable folder on my desktop
    6) Restarted my laptop & was able to play the game!!!!!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •