TTLG|Thief|Bioshock|System Shock|Deus Ex|Mobile
Results 1 to 18 of 18

Thread: Thief 2 Incredibly dark

  1. #1

    Thief 2 Incredibly dark

    Hey all, just got Thief 2 to work today, and I was exhilarated. Slightly less so when I realized that the game is impossibly dark. So dark that I can't even make out doors in the shadow. It isn't the game either, as standing in the darkness isn't giving me cover. I've turned up the gamma all the way but it is still difficult to see anything. It also makes it tough to identify good hiding spots.

    I'm using an LCD, but I've played Thief on other LCDs and not had this problem. Any ideas on this would be appreciated.

  2. #2
    This is just what Thief is like. Go play Halo if you don't like your leetbix with awesome sauce

    I'm kidding. Have you tried setting gamma via the cam.cfg file in the Thief folder?

  3. #3
    Member
    Registered: Feb 2008
    Location: ...retired.
    I've had this happen to me very intermittently when playing FMs--it's so dark that it's nearly impossible to make my way around, even though there are plenty of light sources. Shutting down and restarting seems to take care of the problem.

  4. #4
    Quote Originally Posted by Vernon View Post
    This is just what Thief is like. Go play Halo if you don't like your leetbix with awesome sauce

    I'm kidding. Have you tried setting gamma via the cam.cfg file in the Thief folder?
    What should I set the gamma to? Right now it's at 0.5. I need to know what that means before I mess with it.

  5. #5
    Member
    Registered: Mar 2001
    Location: Ireland
    Are there any light sources in your room? Windows that can be blackout-blinded, lights than can be turned off?

  6. #6
    Quote Originally Posted by Nameless Voice View Post
    Are there any light sources in your room? Windows that can be blackout-blinded, lights than can be turned off?
    It's not an ambient light problem, all my lights are off and the curtains drawn.

    I tried changing the gamma value in cam.cfg from 0.5 to 2.0, but it changes back when I load the game.

    Also, changing the gamma in the game menu has no effect. The menu will even be darkened, but the options menu is bright as if the gamma were turned to max. When I check the gamma setting again, it has reset to the center. It's like the changes I make are constantly un-doing themselves.

  7. #7
    Quote Originally Posted by Peanuckle View Post
    It's not an ambient light problem, all my lights are off and the curtains drawn.

    I tried changing the gamma value in cam.cfg from 0.5 to 2.0, but it changes back when I load the game.

    Also, changing the gamma in the game menu has no effect. The menu will even be darkened, but the options menu is bright as if the gamma were turned to max. When I check the gamma setting again, it has reset to the center. It's like the changes I make are constantly un-doing themselves.
    Tried stuff again. It appears that there are 2 different gamma settings my game is working on somehow. These aren't actual settings, just switches in lighting that I've noticed. One is the "game" setting. When I'm in game, even having gamma turned to max doesn't help. The + key does nothing, but the - key does make it darker. When I go to the menu from the game, the menu is very very dark. When I go to another menu, say "menu > options", the menu turns bright again. But it immediately goes back to dark once I exit the menu and go back into the game.

  8. #8
    Member
    Registered: Mar 2001
    Location: Ireland
    Gamma goes the other way.
    1.0 = default. 0.0 = Fully white. Higher numbers are darker.

    Oh, and Thief won't show values outside its normal range on the in-game slider, and if you access the in-game slider it will reset it back to a value that's in range.

  9. #9
    Quote Originally Posted by Nameless Voice View Post
    Gamma goes the other way.
    1.0 = default. 0.0 = Fully white. Higher numbers are darker.

    Oh, and Thief won't show values outside its normal range on the in-game slider, and if you access the in-game slider it will reset it back to a value that's in range.
    Testing this now.

    Still curious why normal gamma changes don't affect anything.

  10. #10
    Changing the cam.cfg does nothing for the problem. I changed it to .1 and WHOAH LSD. It was nuts.

    I took a bunch of screenshots. Where is the screenshot folder and how do I upload multiple pictures?

    This is seriously weird. Also game-breaking.

  11. #11
    Member
    Registered: Mar 2001
    Location: Ireland
    You can change gamma in-game via the console.
    Type "gamma 1.0", etc.

  12. #12
    Changing the gamma outside the normal limits results in some pretty wonky coloration. Dark spots become grey while bright spots turn fluorescent green.

    Has anyone else had problems like this? Could it be a hardware issue? My videocard is an Nvidia Geforce 9600 GT, if that makes any kind of difference.

  13. #13
    Heh, feel kind of dumb now. I applied the DDfix and everything is good.

    So if you've got this problem, DDfix it.

  14. #14
    Member
    Registered: Jan 2002
    Location: Yes / No / Other
    DDFix aside, it might also be worth checking the monitor driver.

    For normal use, using a generic windows driver will work fine, but I recently came in possession of a monitor that was impossible to setup right in the dark ranges using hardware or software settings. That is, until I installed the correct driver.

  15. #15
    Quote Originally Posted by Peanuckle View Post
    Changing the gamma outside the normal limits results in some pretty wonky coloration. Dark spots become grey while bright spots turn fluorescent green.

    Has anyone else had problems like this? Could it be a hardware issue? My videocard is an Nvidia Geforce 9600 GT, if that makes any kind of difference.
    actually i have this damned problem.

    and i wondering how in the hell to solve it.

    the worst of the thing is that the briefing and cutscene clips are totally dark, if i try to ctrl+tab and change the gamma values with the catalyst control center once back in the game the clips is skipped. So i can never see clips during the game.

    and every time i read something in game i am forced to switch to the CCC and set the correct gamma, everytime.

    -_-

  16. #16
    Stop putting out all the torches...


    ...okay, I'll show myself out.

  17. #17
    If you have the latest ddfix:

    open the file "cam_ext.cfg" in notepad, search for this section:

    "; by default it will try to use an enhanced 32-bit precision display mode, if the driver supports it, but
    ; there may be instances (like with integrated intel GPUs) where the driver does support it but it may not
    ; work correctly (such as gamma not working), this option will disable the use of enhanced precision
    ;d3d_disp_no_rgb10_buf"

    remove the ";" infront of "d3d_disp_no_rgb10_buf" and then save the file, that ought to enable the gamma to be changed in the Thief 2 settings menu.

  18. #18
    you are replying to a three year old topic, therefore recommending a fix that did not exist at that time, and mistaking NewDark for DDfix.

    this is almost worth of a price of some sort.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •