TTLG|Thief|Bioshock|System Shock|Deus Ex|Mobile
Results 1 to 8 of 8

Thread: Windows 7 64bit - Problem with movies

  1. #1
    Member
    Registered: Feb 2008
    Location: http://thief-forum.pl/

    Windows 7 64bit - Problem with movies

    I can play T2 with movies, everything works fine.
    I can play T2X without movies, because frequently movies are not played. I see only the black window.

    My configuration is:
    - Windows 7 64bit v6.1.7601 SP1
    - K-Lite Codec Pack 64bit v5.9.0
    - VP3 v3.2
    - "vp31vfw.dll" in the C:\Windows\SysWOW64
    - ffdshow video decoder configuration:
    Code:
    Codec: VP3
    Decoder: disabled
    - Script RegIndeo.bat
    Code:
    regsvr32.exe /s LGVID.AX
    regsvr32 "%windir%\sysWOW64\ir50_32.dll"
    - Darkinst.cfg
    Code:
    install_path D:\Program Files\Games\Thief\TMA\
    language english
    resname_base D:\Program Files\Games\Thief\TMA\\t2x+D:\Program Files\Games\Thief\TMA\res
    load_path D:\Program Files\Games\Thief\TMA\\t2x+D:\Program Files\Games\Thief\TMA\
    script_module_path D:\Program Files\Games\Thief\TMA\\t2x+D:\Program Files\Games\Thief\TMA\
    movie_path D:\Program Files\Games\Thief\TMA\\t2x\movies

    Sometimes I must wait ca. 30sec to view the movie in the game. But often I see nothing. What am I missing?
    Last edited by Mixthoor; 26th Feb 2012 at 02:19. Reason: Correct last sensences

  2. #2
    Member
    Registered: Feb 2008
    Location: http://thief-forum.pl/
    I installed 2 codecs:
    - DirectVobSub v2.40.4151 x64
    - On2 VP3 Video For Windows Codec v3.2.5.0

    ...and sometimes I can see the movies direct in the game, but often they have horrible quality. The last solution is to see the AVIs not in the game, but in the f.e. Home Cinema Player.

  3. #3
    Member
    Registered: May 2009
    Location: Germany
    I might be totally off, but a few advices for you :

    Make sure that the command in the .bat file do NOT have the /s parameter - as in your sample.
    /s means that NO message will be shown to you and you won't recognize a failure.

    On Win7, regsrv32 behaves a bit different.
    a) You must specifiy the FULL path to the file
    b) You must rightclick on the RegIndeo.bat file and select 'Run as Administrator'

    So, something like this should do it:
    Code:
    regsvr32.exe C:\Games\Thief2\LGVID.AX
    regsvr32 "%windir%\sysWOW64\ir50_32.dll"

    From SystemShock2 I learned that the 'Thief'-engine ALSO may require to be run in 'Admin' privileges.
    After you have installed a FM, rightclick on the Thief2.exe (or t2x.exe ??) and select 'Run as Administrator'.
    If this fixes your problem, then you might want to do this for a permanent change:
    Right-click on the Thief2.exe/t2x.exe , select 'Properties' and then 'Compatibility' and check the 'Run as Administrator' option.


    Here is my Darkinst.cfg. I pointed out one entry which seems to be missing in yours.

    Code:
    install_path D:\Games\Thief2
    language english
    resname_base D:\Games\Thief2\t2x+D:\Games\Thief2\res+D:\Games\Thief2
    load_path D:\Games\Thief2\t2x+D:\Games\Thief2
    script_module_path D:\Games\Thief2\t2x+D:\Games\Thief2
    movie_path D:\Games\Thief2\t2x\movies+D:\Games\Thief2\movies

    I am not sure if the double \\ should be removed or not (like in 'D:\Program Files\Games\Thief\TMA\\t2x').
    And while you are at it, you could also replace all 'D:\Program Files\Games\Thief\TMA' with '.'
    Maybe T2X has a problem blanks in the pathnames. Don't know.

    So, try this:

    Code:
    install_path .
    language english
    resname_base .\t2x+.\res+.
    load_path .\t2x+.
    script_module_path .\t2x+.
    movie_path .\t2x\movies+.\movies
    Last edited by gnartsch; 19th Mar 2012 at 18:47.

  4. #4
    Member
    Registered: Jan 2002
    Location: Yes / No / Other
    Relative paths do work, but for Thief2x they'll need to be relative to the t2x folder.

    Code:
    install_path ..\
    language english
    resname_base +..\res
    load_path 
    script_module_path +..
    movie_path movies
    should do.

  5. #5
    Member
    Registered: May 2009
    Location: Germany
    Quote Originally Posted by addink View Post
    Relative paths do work, but for Thief2x they'll need to be relative to the t2x folder.
    addink, you are probably right

    I just had a look into my own install of T2X, which I have moved from my old XP system to Win7 a couple of months ago without having played or tested T2X.
    It crashed rightaway when selecting 'Intro' or 'New Game'
    First I found this thread.
    It did not help for me. Mixthoor, you say you have K-Lite installed or ffdshow ?
    Then you should look into it anyway - since K-Lite does not seem to work with T2X.

    For myself I figured out that I had to rerun the T2X-codec registration program
    (found in t2x\codec). You will have to right-click on VP3_codec.exe and select 'Run as Administrator'

  6. #6
    Member
    Registered: Feb 2008
    Location: http://thief-forum.pl/
    On Windows 7 64 bit GERMAN it wokrs with the newest codecs:
    - DirectVobSub v2.40.4151 x64.exe
    - On2 VP3 Video For Windows Codec v3.2.5.0.exe

    On Windows 7 64 bit POLISH it wokrs with the horrible quality right now. I have the same codecs:
    - DirectVobSub v2.40.4151 x64.exe
    - On2 VP3 Video For Windows Codec v3.2.5.0.exe

    PS.
    Yep, I use the user account, but I install the codecs and play the game (DarkLoader) with admin previleges. Without these I can not even to play the movies in the original TMA!

  7. #7
    Member
    Registered: Feb 2008
    Location: http://thief-forum.pl/
    JFYI:

    Windows 7 64 bit and T2X. You don't need to install VP3 or DirectVobSub. Movies work without any additional codecs. Checked on 3 different computers.

    And my darkinst.cfg looks like:
    Code:
    cd_path ..\
    install_path ..\
    language english
    resname_base ..\CRFs\EP+..\res
    load_path ..\t2x+..\
    script_module_path ..\t2x+..\
    movie_path ..\t2x\movies

  8. #8
    Member
    Registered: Mar 2009
    Location: 22 Jump Street: Jump Harder
    Well, depends on if you've got codec packs. Most of the time, for when this game was first released, the VP3 codec was not so widespread yet. Nowadays it's pretty big now, thanks to ogg veoh.

    But I tend to have most of the former issue, so I use the CCCP.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •