TTLG|Thief|Bioshock|System Shock|Deus Ex|Mobile
Results 1 to 3 of 3

Thread: Cursor is not bound to game window when sneaky upgrade is installed

  1. #1
    New Member
    Registered: Apr 2017

    Cursor is not bound to game window when sneaky upgrade is installed

    As in the title, I'm having a weird issue with Deadly Shadows.

    I tried every setting I could think of yesterday to try and resolve the problem, with no luck.

    Specs:

    i7 6700K @4.7GHz
    GTX 1070
    16GB RAM
    Windows 10

    The game functions correctly before the mod is installed, but when sneaky upgrade is installed (Even if I run the install with no checkboxes ticked), the mouse cursor is no longer prevented from leaving the main game window. This means if I need to turn around to the right and then click on something, I end up clicking somewhere on my second monitor and swapping applications.

    I'd ordinarily just disable my second monitor while playing, but I'm hoping to stream the game soon and it would be a bummer to not have a second monitor for chat, etc.

    Has anyone encountered this before, and how did they fix it? (Additionally, using the 3rd party program "cursor lock" didn't help)

  2. #2
    New Member
    Registered: Jul 2010
    Did you ever work out a fix for this? I was having the same problem with the Sneaky Upgrade so I gave up on it. This issue wasn't present in vanilla TDS on my multi-monitor setup.

  3. #3
    Sneaky Upgrader
    Registered: May 2007
    Please see if it's fixed in this version. If things have not improved out of the box, try also disabling the 'frozen mouse cursor' fix in the Troubleshooting page.

    For the record, you'll likely get a faster reply posting Sneaky Upgrade questions in this thread.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •