TTLG|Thief|Bioshock|System Shock|Deus Ex|Mobile
Results 1 to 23 of 23

Thread: FM installed via darkloader, not working help!

  1. #1
    New Member
    Registered: Jul 2012

    FM installed via darkloader, not working help!

    i downloaded fan missions for T2 1.18 and installed via darkloader 4.3.1, when try to play just black screen except the brightness icon is shown but everything is black. game isnt frozen as i can esc and exit mission.

    am i doing something wrong? the FM i downloaded is here "https://drive.google.com/file/d/0By0GziqOqSb6b2ZRT29ZYm05dlk/view" and it is definitely for T2 metal age.

    pls help!

  2. #2
    Member
    Registered: Aug 2007
    Location: LosAngeles: Between Amusements
    Stop using Darkloader! It is depreciated. Next thing you'll be telling us is that you are using version 1.18. Stop that! Get the latest NewDark. Period. And either use FMSel, which comes with NewDark or download NewDarkLoader .

    Sorry, but if you insist on using outdated tools, you'll get no help here.

    And by the way, TTLG does have a Technical and Troubleshooting forum. This ain't it. You should really have posted there.

  3. #3
    New Member
    Registered: Jul 2012
    Quote Originally Posted by LarryG View Post
    Stop using Darkloader! It is depreciated. Next thing you'll be telling us is that you are using version 1.18. Stop that! Get the latest NewDark. Period. And either use FMSel, which comes with NewDark or download NewDarkLoader .

    Sorry, but if you insist on using outdated tools, you'll get no help here.

    And by the way, TTLG does have a Technical and Troubleshooting forum. This ain't it. You should really have posted there.
    thanks for the info, i didn't know darkloader is out dated.

    btw, i have 1.18 is reason because thief multiplayer, would this new darkloder work?

  4. #4
    Member
    Registered: Aug 2004
    Location: netherlands
    i agree with Larry here, stop using darkloader and old dark.
    if you want to still use 1.18 because of " multiplayer" I would suggest making a new install for playing all those wonderfull new fm's ( and ofcourse old ones ) and keep the old install for your multiuplayer

    but about your problem: I had that when I was trying to play a mission with not the right .fam file

  5. #5
    New Member
    Registered: Jul 2012
    Quote Originally Posted by nightshifter View Post
    i agree with Larry here, stop using darkloader and old dark.
    if you want to still use 1.18 because of " multiplayer" I would suggest making a new install for playing all those wonderfull new fm's ( and ofcourse old ones ) and keep the old install for your multiuplayer

    but about your problem: I had that when I was trying to play a mission with not the right .fam file
    thanks for help. it really is a shame multiplayer stuck on 1.18, it makes it very interesting to be able to play together especially on some new FM i saw they are extremely well made. like blackfrog campaign, or mystic heart i saw on youtube.

    about the .fam file i did browse through the .zip file and i think i saw it there. but i thought if i click install with darkloader it'll install everything. anyway i'll try the new darkloader tonight and hope it works on 1.18.

  6. #6
    New Member
    Registered: Jul 2012
    Quote Originally Posted by nightshifter View Post
    i agree with Larry here, stop using darkloader and old dark.
    if you want to still use 1.18 because of " multiplayer" I would suggest making a new install for playing all those wonderfull new fm's ( and ofcourse old ones ) and keep the old install for your multiuplayer

    but about your problem: I had that when I was trying to play a mission with not the right .fam file
    so i tested new dark loader couldnt get it to work for some reason. looks like im missing cam_ini file or something i tried following instruction and no luck. the file doesnt come with thief MA by default.

    however i did ask the mission maker and this is their response:
    "Darkloader expects a complete FM package, whereas what I gave you are just mis and the gamesys file. You'll need to extract all the res files from TDP and TMA into the thief folder and load the mission files through dromed. I HIGHLY recommend you create a new T2 installation folder to do this (you can just make a copy of the thief 2 folder)."

    any idea what they mean and how i should proceed?

  7. #7
    Member
    Registered: Jan 2001
    Location: Formby, NW England
    NewDarkLoader only works with 1.19 and above (1.25 is the current version of T2). As for that FM, there's no reason why the author cannot add the files needed to make it play like any other FM (strings folder etc).

  8. #8
    Southquarter.com/fms
    Registered: Apr 2000
    Location: The Akkala Highlands
    What is going on with the contents of that zip file in the OP? It has some original stuff, plus a whole bunch of files from the standard T2 install that aren't necessary in any FM archive.

    And I'm guessing nightshifter meant to say ".gam" file.

  9. #9
    Member
    Registered: Aug 2004
    Location: netherlands
    indeed, that was .gam file

  10. #10
    New Member
    Registered: Jul 2012
    Quote Originally Posted by nightshifter View Post
    indeed, that was .gam file
    it is fan made mission similar to thief dark project missions

  11. #11
    Dóttirin klęšist oft móšur möttli
    Registered: Apr 2015
    This isn't packed correctly. The files in the zip are messed up. Whatever it is, ask for a better version. Who uploaded this?

  12. #12
    New Member
    Registered: Jul 2012
    Quote Originally Posted by Unna Oertdottir View Post
    This isn't packed correctly. The files in the zip are messed up. Whatever it is, ask for a better version. Who uploaded this?
    they told me its not a complete mission zip file so have to extract them and place them separately, thats why i don't know how to proceed

  13. #13
    Member
    Registered: Aug 2007
    Location: LosAngeles: Between Amusements
    Then play a different mission. There are hundreds to choose from.

  14. #14
    New Member
    Registered: Jul 2012
    Quote Originally Posted by LarryG View Post
    Then play a different mission. There are hundreds to choose from.
    heh well i really wanted to play thief 1 missions in thief 2 multiplayer hence the 1.18 and these missions

  15. #15
    Zombified
    Registered: Sep 2004


    ok, lets try to make it simple;
    -make a T1/TG install for everything T1/TG related (no multiplayer), preferably TFixed and NOT using (old)darkloader
    -make a T2 1.18 install WITH (old)darkloader for all your T2 multiplayer endeavours
    -make a T2 1.25 install (preferably TafferPatched) with FMsel or NewDarkloder for everything else
    Last edited by voodoo47; 13th Sep 2017 at 04:47.

  16. #16
    Desperately dodgy geezer
    Registered: Nov 2001
    Location: The Wailing Keep
    And since you're probably thinking it, and voodoo didn't come right out and say it explicitly, no you CANNOT play T1/G missions in T2 OldDark (1.18/Multiplayer). That only became possible with NewDark, which doesn't support multiplayer.

  17. #17
    New Member
    Registered: Jul 2012
    Quote Originally Posted by Yandros View Post
    And since you're probably thinking it, and voodoo didn't come right out and say it explicitly, no you CANNOT play T1/G missions in T2 OldDark (1.18/Multiplayer). That only became possible with NewDark, which doesn't support multiplayer.
    sorry it seems i didn't explain clearly. the missions in the zip file is constructed from scratch, to be very similar to thief 1 missions but made for thief 2 game, using thief 2 resources etc. which is why i have problem right now after knowing its not a complete .zip but the files itself was wondering whats missing so i can get it to work.

    for example, some T2MA fan missions made for 2nd game but based on missions in the 1st game.

  18. #18
    Member
    Registered: Aug 2007
    Location: LosAngeles: Between Amusements
    And what version of Thief 2 was it made for? You can't play missions made in newer versions of Thief in the 1.18 version. They are not compatible. Period.
    Last edited by LarryG; 14th Sep 2017 at 00:26. Reason: grammar

  19. #19
    Desperately dodgy geezer
    Registered: Nov 2001
    Location: The Wailing Keep
    Quote Originally Posted by unityole View Post
    heh well i really wanted to play thief 1 missions in thief 2 multiplayer hence the 1.18 and these missions
    Quote Originally Posted by unityole View Post
    sorry it seems i didn't explain clearly.
    Most assuredly!

  20. #20
    New Member
    Registered: Jul 2012
    Quote Originally Posted by LarryG View Post
    And what version of Thief 2 was it made for? You can't play missions made in newer versions of Thief in the 1.18 version. They are not compatible. Period.
    ahh that im not sure, is there a way to find out with the files in zip?

  21. #21
    Dóttirin klęšist oft móšur möttli
    Registered: Apr 2015
    Again: Who uploaded this? Ask this person.
    Again: You can't play it, it's a mess. Too much stuff is missing (resources, osms...). Some maps aren't even compiled. It doesn't matter which T2 version your're trying.

  22. #22
    New Member
    Registered: Jul 2012
    Quote Originally Posted by Unna Oertdottir View Post
    Again: Who uploaded this? Ask this person.
    Again: You can't play it, it's a mess. Too much stuff is missing (resources, osms...). Some maps aren't even compiled. It doesn't matter which T2 version your're trying.
    no further reply from them, but they did say this

    "Darkloader expects a complete FM package, whereas what I gave you are just mis and the gamesys file. You'll need to extract all the res files from TDP and TMA into the thief folder and load the mission files through dromed. I HIGHLY recommend you create a new T2 installation folder to do this (you can just make a copy of the thief 2 folder)."

    although i registered my account here in 2012, I was only looking at patches few things, then i finally came into lurking on these forums starting last month after seeing T2 multiplayer so i have 0 knowledge of anything, any idea on how to proceed appreciated!

  23. #23
    Zombified
    Registered: Sep 2004
    the gist of it is that the FM is incomplete and cannot be played. either ask people to finish it for you, or learn Dromed, and you'll be able to do it yourself.. in a year or two.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •