TTLG|Thief|Bioshock|System Shock|Deus Ex|Mobile
Results 1 to 2 of 2

Thread: Thief 2 Cutscene Issue

  1. #1
    New Member
    Registered: Oct 2017

    Thief 2 Cutscene Issue

    For some reason the cutscenes in Thief 2 will not play for me. I've installed Tafferpatcher, as well as read the FAQ thread and tried the fixes there that were for my OS. I've also tried installing the codec, but that would freeze when it begins searching for instances of Netscape. Strangely, the cutscenes in Thief: Gold do play for me.

    I'm running Windows 7 64 bit Premium Home Edition, Radeon HD 5670
    Last edited by PNGin; 7th Oct 2017 at 18:33.

  2. #2
    Registered: Dec 2004
    Location: Germany
    By installing the codec, did you mean running the "iv5play.exe" program from the original Thief 2 discs? That one is almost twenty years old and doesn't know anything about Windows 7 or "64 bit". I never used it unter Win7 64 bit, AFAIK.

    Is your "Thief: Gold" already enhanced with TFix (a program somewhat similar to Tafferpatcher), or did you just install it with Thief's own installation program?

    Do the end movies (the skull-and-crossbones one for failing a mission, or the "success" one) work in Thief 2? They are the same as in "Thief: Gold", which might rule out one or two possible causes.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts