TTLG|Thief|Bioshock|System Shock|Deus Ex|Mobile
Results 1 to 6 of 6

Thread: Having a .cow (Object Directories / Custom Motions)

  1. #1
    Member
    Registered: Oct 2014
    Location: Asia

    Having a .cow (Object Directories / Custom Motions)

    Object Directories: For about a month I've been saving my edits as .cow files. Today, for the first time, objects (original LGS objects) are not loading. Some textures on tabletops and barstools are coming up Jorge. I keep all of my .cows and previous .mis and .gam files in folders separate from my main Thief 2 directory.

    A while ago I included a custom object. The texture was Jorge, and didn't get fixed until I moved into folder where the mission (.mis and .gam) was.

    I'm tempted to put original LGS files into my custom folders, but other FM releases don't do that. I suspect somethings have to be reloaded.

    Custom Motions I had a sitting AI playing a piano (link to an AIWatchObj). Just yesterday, the AI simply sat still. I checked the details, and they appear unchanged. I compared that to another AI, who is still moving like it should. The details are almost identical. I suspect the .cow saves. Is that true?

  2. #2
    Member
    Registered: Mar 2001
    Location: Ireland
    Sounds like your install is messed up and has the .crfs in the root of the game dir instead of inside "res" where they belong (with darkinst.cfg adjusted to point there).

    How did you install the game?

  3. #3
    Desperately dodgy geezer
    Registered: Nov 2001
    Location: The Wailing Keep
    Look at your install.cfg (T1G) or darkinst.cfg (T2) for the path you have set for resname_base. Make adjustments as necessary.

  4. #4
    Member
    Registered: Oct 2014
    Location: Asia
    Quote Originally Posted by Nameless Voice View Post
    Sounds like your install is messed up and has the .crfs in the root of the game dir instead of inside "res" where they belong (with darkinst.cfg adjusted to point there).

    How did you install the game?
    In darkinst.cfg, the .crfs originally pointed to "res", and still do. The game was installed with TafferPatcher v2.17 Beta. I proceeded to make a new install with TafferPatcher v2.18 Beta, transferring custom files over. The LGS files appear in the new install, and textures are back to normal. However, the AI that was playing piano (typing) is now sitting motionless, whereas another AI continues to move flawlessly with a different motion.

  5. #5
    Desperately dodgy geezer
    Registered: Nov 2001
    Location: The Wailing Keep
    Sounds like maybe you got the original vanilla motion database in the new install. Check the motiondb.bin file in each folder.

  6. #6
    Member
    Registered: Oct 2014
    Location: Asia
    Quote Originally Posted by Yandros View Post
    Sounds like maybe you got the original vanilla motion database in the new install. Check the motiondb.bin file in each folder.
    You're right, that was the case. What I don't understand is how the previous motion database got replaced. Between different installs and folders I had three different motion.db files. I opened them with Notepad++ and found the one that contained the typing motion, then put it in the main Thief 2 directory. Now the AI is typing again.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •