TTLG|Thief|Bioshock|System Shock|Deus Ex|Mobile
Results 1 to 5 of 5

Thread: Problem with Earth-Stim

  1. #1
    Member
    Registered: Jan 2007
    Location: Germany

    Problem with Earth-Stim

    I've run into a situation where I can't figure out what's wrong.
    I want the player to solve a simple puzzle that involves 4 elemental locks.
    After shooting one elemental arrow at each lock a particle bridge is to appear.

    Each elemental lock possesses a receptron for the respective stim and is "frobbing" a button in response to that stim.
    Each button is CD-linked to a RAT which triggers the teleportation of the bridge.

    The water, air, and fire locks work as expected, however the earth-lock is causing trouble as the Earth-receptron does not seem to work.
    I've double checked that there is an Earth-stim on the earth arrow archetype (plus I've added this stim to the mosslump) and that the button to be "frobbed" by the receptron is working too.
    Here's a screenshot of the EarthLock-object's receptrons:



    However, for some reason I can't get this to work with EarthStim (adding a FireStim-receptron to the EarthLock to frob the "EarthButton" works).
    What am I missing?

  2. #2
    Desperately Dodgy Moderator
    Registered: Nov 2001
    Location: Fields of bluegrass
    I usually set the min and max to 0.1 below and above the intensity of the source, so in this case that would be 0.9 and 1.1 for Earth. I noticed that the EarthArrow archetype's source intensity is 1 whereas the other three are 0.5, but I don't know if that's what is causing your issue. Still I would try the specific min and max values and see if it works.

  3. #3
    Member
    Registered: Jan 2007
    Location: Germany
    I tried both of your suggestions (altering the min/max values and changing the arrow's stim intensity to 0.5) but none solves the problem.
    It's like the EarthStim is somehow broken...?

  4. #4
    Dóttirin klęšist oft móšur möttli
    Registered: Apr 2015
    I did the same thing in Grimrock Reloaded and it worked fine. The receptor of the earth stim is a invisible marker, 3x3x0.25, so it's not too small.
    You might adjust the dimensions of the lock.

  5. #5
    Member
    Registered: Jan 2007
    Location: Germany
    I don't know what was messed up, but I just cloned the object, added the exact same receptron et voila: it works...

    Anyway, thanks for your help!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •