TTLG|Thief|Bioshock|System Shock|Deus Ex|Mobile
Results 1 to 9 of 9

Thread: Sound skipping problem

  1. #1
    Member
    Registered: Jan 2001
    Location: The Lion City

    Sound skipping problem

    I've installed Deus Ex on my new Dell Inspiron notebook and i notice that when the game starts, all the cutscenes where there are characters in conversation, the speech at the end of a sentence is cut off. I can read the subtitles and listen to the speeches but the ends of certain sentences are not spoken. This is very irritating because even the very first mission where JC talks to Paul, i can't even get the password from him. This does not have anything to do with any audio device or sound settings within the game. I've checked the planetdeusex forums and apparently people who play Deus Ex on a laptop also experience speech cut-offs. They also notice that JC seems to be running faster than normal.

    I've completed DX twice on my older desktop and it had none of these problems. Now i want to savour more visual quality on my notebook and these problems surface. Does anyone know what causes the speech defects? I read that you had to set audio playback acceleration to full on win XP, which my notebook is running on. However my audio acceleration is already full!

    Anyway, i've installed the SP patch, and have launched DX before and after the patch install, and the speech defects are still there.

    My notebook specs are as follows:
    P3 1.13 GHz
    256MB RAM
    GeForce 2 Go 200 32MB DDR
    Some crystalsound soundcard
    Win XP pro

    Any help would be appreciated.

  2. #2
    Member
    Registered: Mar 2001
    Location: Ottawa
    Hey moo, I was having a similar problem with WinXP earlier until I found a solution in the forums somewhere. Under the [Galaxy.GalaxyAudioSubsystem] section of DeusEx.ini, change the Latency from 40 to 60.

    hope it works!

  3. #3
    Member
    Registered: Jan 2001
    Location: The Lion City

    Yeah thanks. I'll try that as soon as i reinstall Deus Ex. I too hope it works cos that's what "forced" me to uninstall Deus Ex in the first place. I couldn't stand the skipping sounds.

  4. #4
    Member
    Registered: Jan 2001
    Location: The Lion City

    Haiz no, changing the latency doesn't help. I've tweaked with that part of the Deusex.ini and any value doesn't make a difference.

    Any other suggestions?

  5. #5
    Member
    Registered: Mar 2001
    Location: Ottawa
    The other suggested solution I read about was running it in Win98 compatibility mode; try those options, if you haven't already. Otherwise, aside from the usual drivers and updates, I don't know ...

  6. #6
    Member
    Registered: Jan 2001
    Location: The Lion City
    Yeah i searched the forums and have read that thread. Though i don't think it addresses my problem because most probably my problem has to with notebooks.

    But anyway, can you tell me how to switch compatibility modes? I'm still unfamiliar with XP.

  7. #7
    Member
    Registered: Mar 2001
    Location: Ottawa
    Right-Click on the executable file and click the tab that says "Compatibility"

  8. #8
    Member
    Registered: Jan 2001
    Location: The Lion City
    Arghh!!! It doesn't work.

    I've tried all compatibility modes, win 95, win 98/ME, win NT 4.0, win 2000. They all give me the same end result! Which is still the speech skipping problems!

    Hmm now i don't find it's Win XP's fault. Rather it's the fact that i'm playing on a laptop.

    Well anyway, i've uninstalled Deus Ex again, and not till someone comes up with a solution, shall it be installed again. Help please!

  9. #9
    Member
    Registered: Jan 2001
    Location: The Lion City
    I can't believe it, but i've gotten rid of the dialogue problems!

    Instructions:

    1) Open the deusex.ini file under deusex/system. Alternatively, one can access the Advanced Preferences menu by opening user.ini file under deusex/system, and bind any available keyboard key to "Talk". e.g. Y=Talk, y=Talk.

    2) If u've opened the deusex.ini file, scroll down to the Galaxy Audio Subsystem section. There, look for a word "latency". Change this value from "40" to "46". Leave the effects channel setting as "16". Alternatively, launch deusex and press the, e.g. y key. A small box with the word "say" should appear at the bottom. Backspace it and type "preferences". The game will minimize and a "preferences" window will appear. From there navigate to "Audio", and adjust the latency value from "40" to "46".

    3) Under Windows XP, look for the deusex.exe file that launches the game. Right click and select the "compatibility" tab. Under that, select "Windows 95 compatibility mode".

    4) Shut down ur computer and then restart.

    5) Launch deusex and play!

    Note: The aforementioned solution worked on my Dell Inspiron 4100 laptop with Win XP professional, Crystal WDM Audio sound, GeForce 2 Go 32MB and 256MB SDRAM. The dialogue skipping and increased gamespeed is due to Win XP loading sound modules first before game modules or something like that. Anyway try the solution, it worked after several tries for me, sort of out-of-the-blues!

    Anyway, there are still rare occurances where the first part of spoken dialogue is cut-off. It doesn't happen often, and mostly u'll miss about 2 secs of dialogue. However, everything else, including the sound, works perfectly and all who use Win XP should have no problems.

    In case any of u can't sort the problem out, i will post my exact deusex.ini file. BTW, remember to download and apply the deusex single player patch (4.6MB), update video and soundcard drivers and update ur Windows (i've applied win XP SP1 patch, but that doesn't affect deusex).

    Good luck!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •