TTLG|Thief|Bioshock|System Shock|Deus Ex|Mobile
Results 1 to 7 of 7

Thread: SS2 Freezing

  1. #1

    SS2 Freezing

    After a while of playing SS2, it freezes up and I have to close it by force. I have the latest patch. Can someone help?

    Computer Specs:
    OS: Windows XP
    Chip: Pentium 4 2.8 ghz
    Video: Radeon 9800
    Audio: Audigy 2
    RAM: 1024

    P.S: Forgive the bluntness.. I'm really tired. I've been up all night trying to figure this out.
    Last edited by Violet; 16th Sep 2003 at 08:49.

  2. #2
    Come on people. Show a little bit of compasion.

  3. #3

    Possible fix

    Hi Violet,

    I had the same problem with SS2 and my P4 2.4 _HT_ !
    I solved the problem by disabling hyper-threading in
    the BIOS setup before playing (needs 2 reboot)...
    Don't forget to re-enable it after playing SS2.

    The many sings to us...

  4. #4
    Member
    Registered: Jan 2003
    Location: Shock Unlimited
    If he has HT, then any of the following can be done:

    When you run SS2, hit ctrl+alt+delete, right click on its process, and "Set Affinity" to a single processor.

    Don't want to do that every time? Someone made a patch. I don't know where you can find it by itself, but if you download my SS2 Companion (www.digitalnugget.com>programs>SS2 companion CD) it contains it (along with other usefull patches and the like)

  5. #5
    Previously Important
    Registered: Nov 1999
    Location: Caer Weasel, Uelekevu
    Off to Tech where the lovely David and the fairly sexy jer will give this the attention it deserves.
    (Well, it's more likely to be David, so a reply may be a few hours coming... damned English, living in the future like that)

  6. #6
    Member
    Registered: Dec 1999
    Location: Black Squadron
    I like the future, it is very pretty.

    The guys are onto the right track here, the Hyperthreading of your fine Pentium 4 is likely to be causing the freezing as it can make the CPU appear as two to Windows, which the Dark Engine does not support.
    MOre often than not you can simply skip into the BIOS and disable it, which is nice

  7. #7
    Yep, the hyperthreading was the problem. Thanks guys.

    If anyone ever feels like playing with a newbie, I'm your gal.

    AIM: Striking Sipher

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •