TTLG|Thief|Bioshock|System Shock|Deus Ex|Mobile
Results 1 to 6 of 6

Thread: Dromed crash computing rooms

  1. #1
    Buglesoft
    Guest

    Dromed crash computing rooms

    Help.

    I have a mission that has many room brushes. Last night I portalized, optimized, and tried to compute the room database ... I'm sorry, but dromed has executed an illegal instruction... (you get the idea). I re-loaded, followed the same steps and got the same result. I deleted all of my room brushes except one, same result.

    I searched the forum for "room" and "crash" and the closest result I found was this thread: http://www.ttlg.com/forums/ubb/Forum17/HTML/003140.html

    I tried the most of the various tricks posted and nothing appears to work.

    Anybody have any other ideas?

    Thanks!

  2. #2
    Shadowspawn
    Guest

    I just went through this, I have some ideas.

    First, can you build the AI pathfinding database? If not, you probably have a bad object somewhere. It may not be anything you did, I had an object go bad that I haven't touched in 6 months.

    To find the bad object? Make a copy of your mission. Delete the last 250 objects (find_obj 1750, then keep hitting delete). Save it (new name). Build room DB. If it crashes, open it again, delete 250 more objects, repeat. Find where (if) you have a bad object, then keep homing in on it, until you find it. You'll probably have to delete it, but you can clone it first, then kill it.
    (Once this works, go back to your real mission file and clone/delete the offending object).

    You could also have a bad room brush. Try show_bad_rooms, etc in your user.cfg file. (Search the forum for that stuff). Find room brush 1 (hilight_room_brush, or something like that), then tab through them. You may find a bad one, or you may crash. Try to remember where it was, then return and delete it, and rebuild it.

    I have 1960 objects, I had two 'bad' objects that stopped me from pathfinding and room DB building. It took 2 hours to find them, but now everything is working again. Hopefully I'll release a beta-version in 2 weeks.

    Good Luck. Come back here and post if nothing works.

    ------------------
    Darkness is always faster than light. No matter how fast light travels, it always finds the dark waiting for it.

  3. #3
    Keeper of Metal and Gold
    Guest

    I HATE unknown unexplainable computer problems, Dromed or otherwise

    ------------------

  4. #4
    Buglesoft
    Guest

    Thanks Shadowspawn!!

    All the rooms were good, but after deleting allmost all of the objects, I found the problem. Upon deleting one of the objects (a transformer), the room database built correctly. I have gone back to an old copy to see if there was something strange about the object, but it looks just like 2 other transformers I have, and it was properly aligned and didn't overlap anything. Go figure.

    Anyway, thanks again Shadownspawn. I am forever, temporarily in your debt.

  5. #5
    Shadowspawn
    Guest

    Glad to be of help! I know how frustrating this is! I'm just glad I'm almost done with this FM. (The next one will be for T2, which is another whole can of worms)


    ------------------
    Darkness is always faster than light. No matter how fast light travels, it always finds the dark waiting for it.

  6. #6
    Grings
    Guest

    I had the same problem, but after a while I just went back to a recentish backup.
    But if I get it again, I'll know what to do...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •