TTLG|Thief|Bioshock|System Shock|Deus Ex|Mobile
Results 1 to 10 of 10

Thread: Exporting .bins in Blender: Automatic Backface Culling

  1. #1
    Member
    Registered: Oct 2014
    Location: Land of two pubs

    Exporting .bins in Blender: Automatic Backface Culling

    I replaced the legs from Desk.bin and joined them to desk01.bin, then retextured desk01.bin to look like Desk.bin. I did this to get a larger version. This desk has vhots for both drawers and a middle vhot for a center drawer. In Blender, the edges for the legs are highlighted blue. When exporting with 3ds2bin, I get 282 polygons, and when I examine the .bin in Blender I need to remove doubles in Edit Mode and the surfaces look fuzzy when panning the view. 3ds2bin gives me atomic sliver warnings with "James is a wiener". If I delete the legs, the .bin will result having no legs and only has 82 polygons.

    If I export to .bin straight from Blender after deleting the legs, the legs remain on the object. The .bin surfaces don't have the fuzzy look when I pan around. Backface Culling is not selected in Blender, but it appears anyway in DromEd. I selected Ambient Occlusion, but that did not have any effect on the desk's appearance.

    Recently I posted a video including a gameboard with two moving drawers. It looks good in the video, but in Blender I'm getting lots of those blue lines, and the same fuzzy look to the surfaces when turning the view. The geometry for the gameboard is more complex than the desk. Here are two screenshots of the desk, one from Blender, the other from DromEd:



    Last edited by Derspegn; 7th Jan 2020 at 23:47.

  2. #2
    ZylonBane
    Registered: Sep 2000
    Location: ZylonBane
    That was quite the ramble. Did you have a specific question?

  3. #3
    DromEd Archmage
    Registered: Nov 2010
    Location: Returned to the eternal labor
    Alright!

    For having worked with custom objs, I think I may help you about it.

    Actually, blender will per default not show the backface culling since Blender has been thunk for recent games which can handle the backface with shaders.
    For an old engine like Dark Engine, the backface culling is the one from the object only so you have to make sure the face are oriented to the right direction before exporting.
    To see how your faces are oriented in blender (and then see how it will look in Dromed) make sure to tick in blender "Backface Culling", your screenshot even shows it unticked.
    Tick it off then select all the face which are not oriented correctly in order to "flip them". Such option can be found in edit mode > Shading.

    Also be aware that most of your blender material options won't be applied during the conversion. This is the reason I advice converting the 3DS into E first to check your materials (to make sure the texture names are not cropped, your ILLUM or TRANSP options are set right)

    As for your exportation, I must say I never used 3DStoBin, I prefer using the old-fashionned method with 3ds2e.exe, BSP.exe and the cmd which has always worked fine with me for objects :

    3DS2E yourObject.3ds yourObject.e
    BSP yourObject.e yourObject.bin -N

    The option -N reduce a lot the number of polys. I don't know how is your model complexity tho but It don't seem that complicated from your screenshots.

    I don't know about the blue lines tho, some mesh display options maybe?
    But as I can see, we don't see the drawers you mention in your screenshot, did you removed them in order to use them as separated objects, spare polys or something?

  4. #4
    Member
    Registered: Jan 2001
    Location: Pushing my luck with Dromed
    The blue lines are for edges marked 'sharp' which is to do with object shading, but only Blender (and maybe some of the import/export file formats). It has no effect on 3ds files. You can get rid of them by selecting everything, Ctrl E (if I remember the shortcut correctly) and select 'Clear Sharp'.

  5. #5
    Member
    Registered: Oct 2014
    Location: Land of two pubs
    Quote Originally Posted by FireMage View Post
    Alright!

    For having worked with custom objs, I think I may help you about it.

    Actually, blender will per default not show the backface culling since Blender has been thunk for recent games which can handle the backface with shaders.
    For an old engine like Dark Engine, the backface culling is the one from the object only so you have to make sure the face are oriented to the right direction before exporting.
    To see how your faces are oriented in blender (and then see how it will look in Dromed) make sure to tick in blender "Backface Culling", your screenshot even shows it unticked.
    Tick it off then select all the face which are not oriented correctly in order to "flip them". Such option can be found in edit mode > Shading.

    Also be aware that most of your blender material options won't be applied during the conversion. This is the reason I advice converting the 3DS into E first to check your materials (to make sure the texture names are not cropped, your ILLUM or TRANSP options are set right)

    As for your exportation, I must say I never used 3DStoBin, I prefer using the old-fashionned method with 3ds2e.exe, BSP.exe and the cmd which has always worked fine with me for objects :

    3DS2E yourObject.3ds yourObject.e
    BSP yourObject.e yourObject.bin -N

    The option -N reduce a lot the number of polys. I don't know how is your model complexity tho but It don't seem that complicated from your screenshots.

    I don't know about the blue lines tho, some mesh display options maybe?
    But as I can see, we don't see the drawers you mention in your screenshot, did you removed them in order to use them as separated objects, spare polys or something?
    Sorry, I forgot to mention this was only the base object that has separate vhots (see screenshots below). I did remove the doors and drawers to use as separate objects, so they were not imported along with the desk. The three different vhots are highlighted together. The dotted lines between vhots are links to the parent base object. The other dotted lines come from the lamps, a sun in front for display and a hemi in back. For this custom object I modified desk01.bin to have cabinet door spaces, and also added an inner central drawer compartment to the middle drawer (not shown). I have also exported the doors and drawers, and the base desk does a better job of retaining textures, whereas the others have ended up with jorge.

    Your post is very helpful. I will try the old-fashioned way as I need to reduce polys instead of removing doubles from the .bin exports.

    No, the base desk is not as complicated as the doors and drawers as it is only a parent object linked to vhots. The other objects have their own parent objects with axles. For the time being, I decided not to put vhots on cabinet door handles to have handles jitter.



    Last edited by Derspegn; 7th Jan 2020 at 23:22. Reason: Expanded import information slightly

  6. #6
    Member
    Registered: Oct 2014
    Location: Land of two pubs
    Quote Originally Posted by R Soul View Post
    The blue lines are for edges marked 'sharp' which is to do with object shading, but only Blender (and maybe some of the import/export file formats). It has no effect on 3ds files. You can get rid of them by selecting everything, Ctrl E (if I remember the shortcut correctly) and select 'Clear Sharp'.
    Very helpful information, indeed. I will take care of this and clear the marks.

  7. #7
    Member
    Registered: Oct 2014
    Location: Land of two pubs
    Quote Originally Posted by FireMage View Post
    Alright!

    For having worked with custom objs, I think I may help you about it.

    Actually, blender will per default not show the backface culling since Blender has been thunk for recent games which can handle the backface with shaders.
    For an old engine like Dark Engine, the backface culling is the one from the object only so you have to make sure the face are oriented to the right direction before exporting.
    To see how your faces are oriented in blender (and then see how it will look in Dromed) make sure to tick in blender "Backface Culling", your screenshot even shows it unticked.
    Tick it off then select all the face which are not oriented correctly in order to "flip them". Such option can be found in edit mode > Shading.

    Also be aware that most of your blender material options won't be applied during the conversion. This is the reason I advice converting the 3DS into E first to check your materials (to make sure the texture names are not cropped, your ILLUM or TRANSP options are set right)

    As for your exportation, I must say I never used 3DStoBin, I prefer using the old-fashionned method with 3ds2e.exe, BSP.exe and the cmd which has always worked fine with me for objects :

    3DS2E yourObject.3ds yourObject.e
    BSP yourObject.e yourObject.bin -N

    The option -N reduce a lot the number of polys. I don't know how is your model complexity tho but It don't seem that complicated from your screenshots.

    I don't know about the blue lines tho, some mesh display options maybe?
    But as I can see, we don't see the drawers you mention in your screenshot, did you removed them in order to use them as separated objects, spare polys or something?
    I followed your advice and R Soul's. The blue lines have been cleared. This was the first time I tried "Flip Normals" with Backface Culling and previously didn't know what that command was for. After I used the old-fashioned method, the polygons were reduced, and the origin and cursor remained in the same location. Before I converted the .3ds of the desk base to .bin, I experimented with base object with 2 vhots (without drawers) for my new gameboard.

    The difference with the gameboard is that the origin point for the base changed after the conversion. The original free object I downloaded was large, so from a distance the .bin's origin looks to be very close to the 3D Cursor and grid:



    However, the origin had changed from the center of the base to just near the grid below, with the 3D cursor at the center of the grid:



    The origin point for the base and drawers may affect object movement. Is it a good idea to change the origin in Blender after the .bin has been converted with
    Command Prompt?
    • Edit Mode: Ctrl S (Snap), Cursor to selected; Object Mode
    • Object Mode: Space, (Type) Set Origin, Origin to 3D Cursor










    Normally, after I place the 3D cursor to selected in Edit Mode, I switch to Object Mode and can set the origin at the 3D cursor. However, with this object, the origin is staying just below it and won't go to the 3D Cursor's location.

    -What is keeping the origin away from the 3D cursor after it has been positioned in the selected object?
    -What should be done differently from the other desk object that didn't have changes of object origin?

  8. #8
    DromEd Archmage
    Registered: Nov 2010
    Location: Returned to the eternal labor
    The idea was good but it sounds you mixed up "Blender object origin" and "Dromed object origin". For Dromed, it don't care about the origin of the object, it can be anywhere, it won't change a thing.
    For Dark Engine(dromed), the "origin" of the object in dromed is the "location 0 0 0".

    With the right side bar on the 3D View, set the location of your 3D cursor to "0 0 0".
    Then, on the left side bar, go to "tools Tab" then click on set origin and choose "Set Origin > 3D Cursor"
    Click on it a second and last time and select "Set Origin > Geomertry to Origin". Once the object is positionned, you'll see at the bottom-left of the left side bar the options of the command selecting Center:"median centers"
    Change it to "bounds center".

    Now you object will be centered right and have the correct origin in Dromed.

    For you vhot, do not place an empty object, you will have issues. Use cubes instead and apply to them a material you'll name "green" with no texture on it.
    (objects and their faces ofc should ALWAYS have materials in blender before exporting or else, the conversion will simply delete them.)

    If some of your converted object has Jorge, it means your texture hasn't been found by the game or the name is so long it got cropped during the conversion.
    To prevent this, once you have converted your 3DS into E file, just open it with a text file and type the whole name with the extension. Then convert into Bin file.

  9. #9
    Member
    Registered: Oct 2014
    Location: Land of two pubs
    Quote Originally Posted by FireMage View Post

    For you vhot, do not place an empty object, you will have issues. Use cubes instead and apply to them a material you'll name "green" with no texture on it.
    (objects and their faces ofc should ALWAYS have materials in blender before exporting or else, the conversion will simply delete them.)
    I tried using cubes as vhots before, but I only had results with plain axes. I'm just curious if the cubes should be named @h00, @h01, etc. like in the tutorial text in Blender, or if they should be labeled object-vhot-# like I saw in the tutorial .cow. Maybe the latter is a result of object conversion?

  10. #10
    DromEd Archmage
    Registered: Nov 2010
    Location: Returned to the eternal labor
    Quote Originally Posted by Derspegn View Post
    the cubes should be named @h00, @h01, etc.
    Sure! They must have these names kept! This is the only way to make DarkEngine understood those are vhot during the conversion!
    It's the same about TweqJoints objs and axis as the Meshes'planes/joints!

    You must respect these code at all cost!

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •