TTLG|Thief|Bioshock|System Shock|Deus Ex|Mobile
Results 1 to 9 of 9

Thread: Thief 2: Black Screen on Windows 10

  1. #1
    Member
    Registered: Mar 2015
    Location: Shawano County, Wisconsin

    Thief 2: Black Screen on Windows 10

    So I've finally upgraded to Windows 10 (or rather, Windows got fed up with waiting and scheduled the update for me).

    Everything seemed fine at first, until I found out Thief 2 wasn't working properly. When I start the game, I only get a black screen. I can hear the main menu ambience and the ticks as I move the mouse over the buttons, and I can click through the menus and even load up the first mission, but I'm stuck with the black screen.

    I've been searching through threads and checking the FAQ trying to find a solution. I've tried uninstalling and reinstalling the game, then reapplying NewDark 1.24 and TafferPatcher 2.0.17. I've tried commenting and uncommenting the "safe_texture_manager" line in the user.cfg, as well as the "multisampletype 8" line in the cam_ext.cfg. I've made sure I have Visual Studio 2008 and DirectX 9.0c installed. Nothing has worked.

    Here are some of my computer specs, if it helps:
    Processor: Intel(R) Core(TM) i5-5200U CPU @ 2.20GHz
    Video card: Intel(R) HD Graphics 5500
    Memory: 8192MB RAM

    Oddly enough, it's only Thief 2 that's been affected. Thief Gold, the Thief 2 alpha demo, Thief 3, and even T2 DromEd all work just fine.

    I've run out of ideas, so I'm hoping someone here can help me figure out what my problem is. Any help will be greatly appreciated!

  2. #2
    Zombified
    Registered: Sep 2004
    tried running windowed?

  3. #3
    Member
    Registered: Mar 2015
    Location: Shawano County, Wisconsin
    I never would've thought of that.

    Thank you, that did the trick!

  4. #4
    Member
    Registered: Dec 2005
    Location: Australia
    Quote Originally Posted by voodoo47 View Post
    tried running windowed?
    Could you please elaborate on this (?) as I'm having the exact same issue under Windows 10.

  5. #5
    Zombified
    Registered: Sep 2004
    well, running (borderless) windowed is one of those universal "do this if your game/driver/gpu freaks out for no good reason" things, not limited to just Dark. you can also try removing the semicolon from ;d3d_disp_no_rgb10_buf instead (cam_ext.cfg), win10 doesn't seem to like when it's disabled too much.

    seems like I'll have to set up a win10 test machine soon. yuck.

  6. #6
    Member
    Registered: Dec 2005
    Location: Australia
    OK, I've fixed it by doing the following.

    Right-Clicked desktop shortcut to Exe. and selected COMPATIBILITY tab. Told it to run under Windows 98/ME ( though XP works as well).

    Had to set game menu resolution to 1366x768x32 to get full in-game screen happening.

    The main menu and map screen (in-game) is severely letterboxed on either vertical side of the screen but I can live with that as long as the action is full screen.

    Thankyou Voodoo for your suggestions, regardless

  7. #7
    Zombified
    Registered: Sep 2004
    win9x compatibility on NewDark? that doesn't sound healthy, go for xp if you really must.

  8. #8
    Member
    Registered: Aug 2004
    Location: CT, USA
    I've needed to use compatibility settings for the first time ever on both my desktop since moving to Win10 on it, as well as on a new laptop that came with Win10. I chose Win8 as the next most recent version, but Win7 and earlier ones work too.

    Actually, both T2 and TG would run on the desktop with no compatibility changes, but there was an annoying 4-5 second lag with a blank/black screen when starting, quitting, or alt-tabbing which never happened with Thief before, but using the compatibility gets rid of that. On the laptop, however, there was no such delay because neither game would even start with a "game has stopped working" error, until using compatibility and now they're both fine with no delay.

    I read that Win10 had some fairly major graphics-architectural changes compared to the past few versions, perhaps even going back to XP or earlier, which has probably negatively affected many other older games, especially those without something like NewDark. I wonder if others here using Win10 are having these same problems or if some have it working normally without the compatibility.

    Incidentally, I have most or all of the new crap shut off and don't use a MS account or Cortana or Edge or sync my cellphone data, etc. I've got the desktop about identical to how it was with Win7 and the performance is at least as good plus it boots & shuts down even faster, so I'm quite okay with it now but only as long as Thief works!

  9. #9
    Member
    Registered: Nov 2003
    Location: East Coast Elite :D
    Quote Originally Posted by voodoo47 View Post
    tried running windowed?
    Sorry to necro this thread, but I had the same issue and going windowed did in fact work but I had to figure out how to do that from the config files since I didn't see it here.

    Uncomment (remove leading semicolon) force_windowed in cam_ext.cgf (requires newdark). I did NOT have to use a compatibility mode and it looks fine, so far.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •