TTLG|Jukebox|Thief|Bioshock|System Shock|Deus Ex|Mobile
Results 1 to 3 of 3

Thread: AI not able to chase player once they see them

  1. #1
    New Member
    Registered: Apr 2022

    AI not able to chase player once they see them

    EDIT: Looks like it was a big object I'd placed for stimming stuff that fell off a cliff that was somehow getting even bigger and assumeably absorbing the whole level.


    I'm having a very frustrating issue with AI in my level.

    Basically what happens is that AI is functioning (can patrol, can flee, can search), except that when they see the player they react as if the player is out of reach. Even walking up to the guards does not elicit any change in response, though leaving them alone will cause them to go into search mode like they normally would. Here is an example from a tester.

    If I do a fresh run of building pathfinding in dromed, it will work, but saving and reloading the mission in dromed after this will cause it to be broken the first time I go into game mode, BUT it will sometimes work on consecutive play modes. Most of the time the pathfinding will be broken from the start when played through the actual game, except for one version that magically worked up until a seemingly random point during play in which it breaks again (but will fix itself if you reload your save).

    Some notes:
    - This happens mission wide when it does happen
    - I have tried testing with different spaces one at a time via area brushes and this does not fix it
    - On the same pathfinding DB I have seen it both work and break
    - I swapped out my custom gamesys for one from another FM and this did not stop it from happening
    - Guards do not exit the "you're too far away" stance at all when they see the player, even when the player is in melee range
    Last edited by 1600frogs; 21st Sep 2022 at 12:37.

  2. #2
    Registered: May 2002
    Location: Texas
    The video suggests that it happens at doorways. I have seen instances in my own missions where a guard can chase me through a doorway in one direction, but can't follow me through the same doorway going in the opposite direction. When I looked at the pathfinding, I saw that the pathfinding was actually broken part way through the doorway. I was able to fix it by making the air brush in the doorway .25 taller and then re-running pathfinding. Of course I did not leave it that way, and the pathfinding in my mission eventually started calculating properly in doorways that had the issue.

    I wish that it was possible to manually edit the pathfinding.

  3. #3
    New Member
    Registered: Apr 2022
    Quote Originally Posted by john9818a View Post
    The video suggests that it happens at doorways
    Unfortunately it is happening everywhere, seemingly unrelated to doorways.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts