TTLG|Thief|Bioshock|System Shock|Deus Ex|Mobile
Page 3 of 3 FirstFirst 123
Results 51 to 69 of 69

Thread: NewDark T2 1.27/System Shock 2.48

  1. #51
    Zombified
    Registered: Sep 2004
    ah, it is a genuine bug then, most likely (no time to dig around the docs right now).

  2. #52
    From mp_release_notes.txt:

    Extracting "mp.zip" will overwrite some original OSM files with multiplayer compatible versions. These
    updated OSMs still work with the singleplayer game.
    If you're not comfortable with that, you can make
    a separate copy of your entire game directory and install multiplayer in the copy instead. That way
    you have dedicated single- and multi-player installs.
    This seems to imply that using a separate install for multiplayer is optional and that you're supposed to be able to put the multiplayer files into your regular singleplayer install and have everything work fine. So from the wording it looks like a bug to me.

    EDIT: oops, ninja'd.

  3. #53
    Member
    Registered: Mar 2015
    Unfortunately, there does not seem to be much documentation available at all for the multiplayer beta. The aforementioned release notes, the GlobalServer instructions, and the networking script documentation seem to be all that supply more than a passing mention to multiplayer.

  4. #54
    Member
    Registered: Sep 2012
    Quote Originally Posted by Niborius View Post
    Thanks sNeaksieGarrett,

    I've been trying to get it to work with Hamachi but to no avail yet. I also noticed that the other player appears to keep going offline/online. Either it's the server or the user, I'm not sure (on his screen Hamachi is always on)

    Also how will I know that ThiefMP uses the Hamachi network, or does it always use both networks anyway?
    Got it to work! I'm not sure if I had the Hamachi server online, but I also changed the Hamachi network priority in Network adapter options so that it has a higher priority than my own network.

  5. #55
    Member
    Registered: Jul 2015
    Good to know that New Dark version 1.27 is still in beta right now, so until then, I should just stick to New Dark version 1.26b for now. T2Fix 1.27 can wait. No hurry.

  6. #56
    Member
    Registered: Nov 2003
    Location: Thief fan since ca. 1999
    So, I tested A Thief's Holiday with two computers in my home and as I suspected, only the host can do certain tasks, due to the custom scripts that this FM uses.

    However, I seem to notice a slightly different behavior between this version of mp implementation and Tos'. While the client player cannot use the broom, nor the cookies, he can turn on and off the sink. I think in Tos' version, the sinks were on at all times and you could not turn them off or on.

    Maybe I should try another mission that uses NVScript or some other custom script and see if the same problem presents itself. If anyone has a suggestion on a specific FM I should use to test a client's ability to trigger objectives, etc., I'm all ears. I can't think of a specific mission off the top of my head that would be good for this.

  7. #57
    Dóttirin klęšist oft móšur möttli
    Registered: Apr 2015
    I opened multiplayer gen.osm in a hex editor. Compared to original gen.osm, it's very different (and bigger).

    However, multiplayer gen.osm works with multiplayer, but not with singleplayer
    Solution: Back up your files (original gen.osm) or just copy a T2 installation for multiplayer only (this was also suggested in the multiplayer readme).

  8. #58
    Member
    Registered: Mar 2015
    I may have found a solution that will allow both the singleplayer and multiplayer executables to peacefully coexist in the same installation until this issue is addressed in a future release.

    The multiplayer executable loads several files that the main executable ignores, one of these being "dark_net.dml". Using this file to load the multiplayer gen.osm using the "#script" directive will theoretically allow the singleplayer client to use the original scripts and the multiplayer client to load the newly-modified scripts.

    To put this into practice, install the multiplayer beta as instructed in the release notes, but do not overwrite gen.osm in your root Thief 2 directory. Instead, copy this file as "mpgen.osm" and add the following line to dark_net.dml, or download the full modified file:

    Code:
    #script "mpgen"
    From a few brief tests, this seems to behave properly, though I have not conducted an exhaustive analysis. It may be required to take a similar approach with the mission-specific scripts.
    Can anyone confirm this to be working on their own installations?
    Last edited by Jax64; 24th Jun 2019 at 17:09. Reason: modified instructions

  9. #59
    Member
    Registered: Nov 2003
    Location: Thief fan since ca. 1999
    Wow, that's quite the find Jax! This makes me wonder if I can tag on the custom script name when I install A Thief's Holiday and see how the game fairs.

    I will try the above for A Thief's Holiday and report back.

    Update:

    So, I tried it and no dice. However, come to find out, it is loading all the scripts anyway. Just to be sure, I removed the line from the DML and Thief 2 still loaded the script!

    So I happened to notice a Thief2MP.log sitting right next to the EXE and decided to review it. What do you know, it lists the modules that it loads (snippet of the log below):

    Code:
    D3DProvider: Enumeration done
    : sw framerate cap requested (10000 us)
    : D3DProvider StartMode: smode 1920x1080x32 ; mode 640x480x32 (5 9 0 2D) ; 2d_surf_mode: 0
    :    CreateDevice: res = D3D_OK ; 1920x1080 fmt=22 zfmt=75 cnt=1 ms=0 swap=1 fs=1 hz=0 pres=1 flags=2
    : Loaded script module "gen.osm" [FileModDate=2019-Jun-16]
    : Loaded script module "convict.osm" [FileModDate=2019-Jun-16]
    : Loaded script module "script.osm" [FileModDate=2003-Nov-23]
    : sw framerate cap requested (10000 us)
    So it appears that it's not that the executable is not loading the script, it's just that the client isn't able to utilize the script for some reason.
    Last edited by sNeaksieGarrett; 24th Jun 2019 at 20:55.

  10. #60
    Member
    Registered: Mar 2015
    It looks like the gen.osm module in your Thief 2 directory is the one from the multiplayer beta. What I was suggesting was to keep the original gen script module (which should have been last modified on 27/3/2000) while copying multiplayer's module as "mpgen.osm" so that the singleplayer game can load the original scripts and the multiplayer game can load the new scripts. This is to bypass the issue of multiplayer's gen.osm not functioning properly with the singleplayer game. I do appreciate you taking the time to test this, however.

  11. #61
    Member
    Registered: Nov 2003
    Location: Thief fan since ca. 1999
    I guess I didn't make myself clear, sorry for the confusion. I meant that I was going to test to see if your idea would work for a third party script in a multiplayer session, using the #script line you mentioned. I wasn't trying to test gen.osm in singleplayer.

    But now I'm wondering if maybe gen.osm is the problem here in this FM. I'm thinking I should try your suggestion and retest multiplayer.

    Update: Swapping out the gen.osm from multiplayer with the original gen had no effect whatsoever on the multiplayer client's ability to use a cookie on a plate or use the broom. I guess it is just an inherent problem with multiplayer that client players cannot do certain things, or at least with this fan mission. (But then I guess I am being daft, as the whole point of the mp patch's gen.osm was to make it mp friendly, so I should have figured swapping the osms wouldn't make any difference.)

    Update 2: So, I was doing some more testing and decided to try loading the NewDark version of A Thief's Holiday. Interestingly, the multiplayer log file does not show that "script.osm" is being loaded when launching this mission but other .osm files that were included in the FM install were listed. Why the game doesn't load that specific script is beyond me. Further to that, I had this in the dml file, "#script "script" , however that doesn't seem to actually work. Having that line didn't force the game to load the script.

    What I find puzzling is your previous post suggests that you had some success with adding that line to your dml; but for me, it failed, suggesting to me that the #script idea doesn't actually work.. and yet, how do we explain how it worked for you, then?

    Update 3:

    So, interesting development. I decided to try testing Running Interference, to see if there was any issues with the client player frobbing objects.

    I've discovered that there is something definitely off about multiplayer when it comes to interacting with objects. As the host, I could pick up a key, use it to unlock a door with no problem. As the client, I tried picking up the key and then using it on the locked door but the client player could not get the door to unlock. Furthermore, I noticed that after the client player dropped the key, the host could not re-pick it up. I had also frobbed some items on a table as the client and the host could not frob those that the client had touched.

    It sounds like it is a bug within the multiplayer patch, or an inherent design choice. This testing leads me to believe that the custom script from the FM I was playing has nothing to do with the use object issue.

    Can anyone else try testing Running Interference and see if you can replicate the same behavior? Since I used an original mission for this test, I can't imagine it would be any different with someone else, as we have the same mission, so probably a waste of time, now that I think about it.

    Another thing that occurred to me is how SS2's multiplayer functions and if this was a problem in that game as well. I can tell that whoever developed this patch for Thief 2 must have tried to mirror the code from SS2, since it was already done for that game. I can tell for example that it uses the same exact menu setup with how to join a game and whatnot, as I fired up SS2 earlier tonight and the process/menus were exactly like Thief 2's.
    Last edited by sNeaksieGarrett; 24th Jun 2019 at 23:09.

  12. #62
    Zombified
    Registered: Sep 2004
    bit of a limitation in the dml archetype creation system, hoping to have it lifted in the future - if connecting multiple dml created archetypes (using receptrons in my case), everything needs to be referenced by archetype names (as the ids may/will end up different for each gamesys) - the 1.27/2.48 dml system only allows archetype ids for Receptrons target/agent object, making it impossible to set multiple dml created archetypes up properly (as you do not know the id of the target/agent object, because you are dml creating it as well).

    basically, if your dml mod requires creation of several new archetypes that need to be connected via receptrons and you need to reference one of them in the target/agent field, you are out of luck.

  13. #63
    Dóttirin klęšist oft móšur möttli
    Registered: Apr 2015
    Create an object first, and test it. set game_mode_backup 0 and note the object ID. You can use it in the dml, since it's the same obj id next time. Creation and obj id will also be displayed in monolog.

  14. #64
    Zombified
    Registered: Sep 2004
    yeah, but this will only work for one particular gamesys of one particular version, defeating the purpose of the dml being universal. might as well just edit the gamesys and avoid the shenanigans altogether (that's what I did with the ultimate diffidently hdmod conversion).

  15. #65
    Dóttirin klęšist oft móšur möttli
    Registered: Apr 2015
    Universal? What does that mean?

  16. #66
    Zombified
    Registered: Sep 2004
    it means the dml mod can be used for any kind of gamesys* that is out there - vanilla, T2Fix, hdmod, or a fan mission of your choice without having to edit the gamesys in the editor (a good example would be the Big Droid Immortality Protocol mod, which was restricted to SCP until now, because it required edits to the gamesys - with the ability to create dml archetypes, it now can be converted to be universal, and work on any kind of game, vanilla, Secmod, whatever you fancy).


    *assuming the author was at least partially sane, and didn't construct their gamesys like a Pollock painting.
    Last edited by voodoo47; 28th Jun 2019 at 06:58.

  17. #67
    Dóttirin klęšist oft móšur möttli
    Registered: Apr 2015
    Confine it on dark.gam. FM authors already set the difficulty in their missions. Nobody wants endless discussions about broken stuff, you know.

  18. #68
    Zombified
    Registered: Sep 2004
    uhh.. what? I'm talking about universal mods here.

  19. #69
    New Member
    Registered: Sep 2011
    Location: St. Edgar's cathedral grounds
    By The Builder! 1.27! With multiplayer! 'Tis not just fine but truly great.
    Who is Le Corbeau, but the Hand of The Builder? What the Builder wills, Le Corbeau...does. What the Builder wants, Le Corbeau...makes. Praise to Le Corbeau! ...And the Builder.

Page 3 of 3 FirstFirst 123

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •