TTLG|Thief|Bioshock|System Shock|Deus Ex|Mobile
Results 1 to 11 of 11

Thread: NewDark engine animated textures not working for objects

  1. #1
    Member
    Registered: Feb 2012
    Location: Russia

    NewDark engine animated textures not working for objects

    Hello
    I noticed, that animated textures not working in NewDark for objects
    For example DWAL1 texture
    There are 6 animated frames for this texture
    DWAL1
    DWAL1_1
    DWAL1_2
    DWAL1_3
    DWAL1_4
    DWAL1_5

    But in game objects with animated textures show only first frame
    MTL file is working, I can add illumination maps, but non of the animation settings working.
    This objects can be seen on the first level of Thief Gold and on the last of Thief 2.

    It is not working not only for DWAL texture, but for any frame textures *_X.png/mtl in obj folder.

    Can anyone confirm that? Is there any workaround?

  2. #2
    Zombified
    Registered: Sep 2004
    try
    Code:
    DWAL1_
    DWAL1_1
    DWAL1_2
    DWAL1_3
    DWAL1_4
    DWAL1_5

  3. #3
    Member
    Registered: Feb 2012
    Location: Russia
    Ok. I doublechecked!
    There are two objects which use animated textures, its ELTRANSF.BIN and WATPUMP.BIN

    This is ELTRANSE in Thief 2 with just T2Fix installed


    No animation at all, just static picture. I don't know if it was animated in original Thief, but in NewDark its not working.
    Animation frames are:
    DWAL1
    DWAL1_1
    DWAL1_2
    DWAL1_3
    DWAL1_4
    DWAL1_5

    Also there is static WATPUMP.BIN with frames in obj/txt folder
    WAT_
    WAT_01
    WAT_02
    WAT_03
    WAT_04
    WAT_05

    What I did
    I renamed WAT_0X to WAT_X and wow, it's working for Water Pump



    I think it is the first time EVER this object animate in Thief!!!

    As for DWALL... I couldn't get it to work with any renaming, it's just stuck on first frame
    But I could animate it with MTL file settings:
    render_pass
    {
    texture {"obj\txt\DWAL1" "obj\txt\DWAL1_1" "obj\txt\DWAL1_2" "obj\txt\DWAL1_3" "obj\txt\DWAL1_4" "obj\txt\DWAL1_5"}
    shaded 1
    ani_mode PINGPONG
    }
    But it's limited to 6 frames only and I cannot insert illumination map

    Maybe it's some bug in BIN file which can be fixed by someone?

    As for illumination maps: they do not work in render passes cause render pass supports only 6 passes, and most animations had 6 frames. Applying map is 7th pass.
    Illumination map do work on Water Pump

    I will add this fixes to ESRGAN pack, but I prefer if they would be inserted into T2Fix (at least WAT_0X -> WAT_X conversion). For ELTRANSF.BIN maybe it's a better idea to look into BIN file and somehow fix it and include to T2Fix or something
    Last edited by Akven; 4th Jun 2020 at 15:11.

  4. #4
    Zombified
    Registered: Sep 2004
    yes, improperly set up resources definitely are a thing (remember that code flow animation in the SS2 main menu being sort of jerky every couple of seconds? that actually is supposed to be smooth, but two of the texture frames have typos in their filenames). and yeah, the resources should be fixed properly and incorporated into the T2Fix resource package - let Jax64 know.

    99% sure this is not a ND issue.

  5. #5
    Member
    Registered: Mar 2015
    As for the transformer, try using this fixed object and rename "DWAL1" to "DWAL1_" as suggested earlier. The water pump indeed does fail to animate as a result of the filenames of the other frames being incorrect. Considering these are both resource issues, integrating these with the T2Fix fixed resources would be ideal.

  6. #6
    Member
    Registered: Feb 2012
    Location: Russia
    I confirm, it's working now properly with new BIN file. With animation and possibility to add illumination maps

    So I suggest for obj files to be animated properly they need to have _ in the end of the name of their first frame?)

  7. #7
    Member
    Registered: Mar 2015
    Excellent. Yes, the underscore is required for the texture animation system to properly identify the individual frames of object textures. It must be the final character present in the filename of the first frame and the underscore should be followed by a positive integer in additional frames. The maximum total animation frames was 20 in the original engine but has been increased to 99 in NewDark.
    Last edited by Jax64; 5th Jun 2020 at 02:06.

  8. #8
    Member
    Registered: Feb 2012
    Location: Russia
    Will you include this two fixes (ELTRANSF and WATPUMP) to T2Fix?
    I already included them into ESRGAN package and will backport them to Thief Gold package (cause they used in Thief Gold too).

  9. #9
    Member
    Registered: Mar 2015
    Yes, they will be integrated into T2Fix's resource patch. I have placed a note on the T2Fix topic as well.

  10. #10
    Member
    Registered: Feb 2012
    Location: Russia
    Hey, guys!)
    I found a way/possibility to animate some static textures in fam/mech like PWALL01/PWALL01s

    If I just create additional textures
    PWALL01_1
    PWALL01_2
    PWALL01_3
    PWALL01_4
    PWALL01_5

    Texture begins to animate.

    So a big question! Should I create additional animation sequences for such static textures? And place it into ESRGAN mod?
    I found only one texture so far, so maybe it just PWALL that would be animated

    Also, second question:
    If I will create additional sequences for example for ORE2_ texture, would they work? For now it
    ORE2_
    ORE2_1
    ORE2_2
    ORE2_3
    ORE2_4

    I could interpolate them with DAIN to get 2x number of sequences for smoother animation. Should I do it?

    P.S. I so tired of improving Thief 1/2)) Wanna go for sometheng else

  11. #11
    Member
    Registered: Feb 2012
    Location: Russia
    I interpolated ORE2_ animation using DAIN from 5 sequences to 20 sequences and slightly added speed (ani_rate 150). Looks quite smooth ingame
    Also I will animate PWALL01 texture both in Thief Gold and Thief II.
    I think I don't remember any similar static texture which can be improved.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •