TTLG|Thief|Bioshock|System Shock|Deus Ex|Mobile
Results 1 to 6 of 6

Thread: No jumping/no mantling challenge for Thief 2

  1. #1
    Registered: Mar 2018

    No jumping/no mantling challenge for Thief 2

    Time to start no jumping/no mantling challenge for Thief 2. Thief 2 is a game about dealing with security, not exploring caves and other forgotten places. So how hard this challenge can be?


    BREAKS: 0

    Traditionally we are starting with easy mission. It doesn't require any jumping/mantling. The only tricky part is bonus objective. I needed to do 3 box stairs to get the rings. Also interesting thing: in Thief 2 is much easier to climb a box placed at the middle of floor and much harder to climb a box situated against a wall. Unlike Thief Gold.


    BREAKS: 1

    First break is at the very beginning. I was forced to mantle onto a box in order to get out of starting point. After that I decided to explore the level and get what I can. I finished all objectives, but decided to explore it more and get extra loot and spices. In order to do that I decided to get rope arrow.

    One of the rope arrows is hidden inside box near a starting point. But without jumping I was forced to get it from metal ramp on second floor. First I threw 3 boxes inside box with rope arrow. Then used fourth box to climb onto railing and fall into the box. After taking the rope I needed to get out from box. I made 3 box stack with 2 boxes on each other and highest box on the side barely touching middle box. Then I used rope arrow to fall onto middle box and climbed onto highest box. This helped me to get out of the secret stash. This was really awkward experience.

    Speaking about grabbing the rope arrow. It's changed. In Thief Gold I needed to crouch under it and then stand. In Thief 2 it doesn't work that good. The rope is longer and it's actually much harder to grab it from underneath. I founded that much easier to grab the rope is: approach rope while crouching and then stand. It should give you enough momentum to grab rope arrow.

    Because of this changed mechanic getting higher with rope arrow was frustrating and I used rope arrow many times (around 10 times). For example I used rope arrow to climb on top of cold room to get a key to safe in spider warehouse. Also I use it in Warehouse B. I ignored loot inside box near Hammerite talking, because it was annoying to get with 3 box stacking done twice and some rope arrow action. I ignored the secret loot in Warehouse B near stairs, because it requires mantle.

    Escape was also surprisingly easy. I used rope arrow to get onto box and then one more rope arrow to get on top of box that forced me to use the mantle at the very beginning of the mission.


    BREAKS: 2

    Mission 3 is starting very similarly like Mission 2. It starts with unfair entrance to the sewers that requires mantling and getting out of water also requires mantling. So that's 2 breaks right off the bat. By the way, I tried GentleClip technique. No idea if it works in Thief 2, but it just didn't want to work for me.

    The most of this mission is easy. Getting to the Archives is easy. It's just a case of getting behind guard. Getting to Sheriff Truart office through secret passage is just a case of well placed rope arrow and climbing it. Which still is annoying. It's much easier and faster to get by the stairs. Secret passage to the Vault requires single box climbing onto desk. And getting to the higher floor from ladder is also quite easy. Ladders is one of the improvements in Thief 2 I like.


    BREAKS: 1

    First break is at the very start of the mission. In order to get out from first part of city, you need to cross the wall. There is a box there, climbing on it helped me to climb on wall only via single mantle. Sigh, another break at the beginning of the mission. This is starting to be tradition.

    Other than that, this mission doesn't require any special technique. You just need to remember to never drop to canal. This means not getting big purse in the canal. In order to get to west part of city I doused 2 torches and KO-ed 3 guards talking with each other, then used the door near them. I broke to special arrow inventor's house via front door. I did the same with Garrett's house. KO-ing 3 guards was easy. But being stealthy and going from the back is just a case of using 1 rope arrow. Escape was also easy. I actually didn't open Shalebridge Gate. Instead I just roped up on top of nearby house. I saw the boundary of this level and finished this mission.

  2. #2
    Registered: Mar 2018

    BREAKS: 0

    I skipped secret body stash, because I didn't found a way to get out from there. This mission is easy, unless you will have bad luck and deposit key will spawn in one of the towers. I had bad luck and I was forced to get to top of west tower. Getting to top of towers is tricky, but possible. There are ladders leading to top floor and in Thief 2 they are really good. But in this particular situation they aren't good enough. I tried to drop boxes on top floor and drop onto them from ladder, but I failed.

    The solution to this problem is rope arrow stacking. Long time no see. In the transition to top floor there is a piece of wood. You shoot first rope arrow there. Second rope arrow you shoot in ceiling of top floor close to the first rope. Then climb first rope, turn your back towards the second rope and drop. You should travel to second rope. Then climb up, turn your back towards floor and drop with eventual pressing down arrow to go backward. And it's done.


    BREAKS: 0

    This is my favorite mission. It's a tough mission, but I must admit no jumping/no mantling rule doesn't complicate it too much. First it's reduce the number of possible entrances. You have option to enter bank via front door or basement. Basement is pretty obvious choice. The rest problems is just a case of using single rope arrow to climb higher. I used rope arrow to get to the room with master key and one rope arrow at central stairs to get to the highest floor. Guard room was a bit more challenging. I used 3 moss arrows to get behind bigger child of Karras and used rope arrow on the wall. Then I ran to rope and climb it. Also at highest floor of vault I had a little fight with ladder.


    BREAKS: 1

    Mission starts from climbing the box into the window. After that drop from attic onto a wall. After clearing this area I realized that I can't go through crack in the wall, because I can't get out of the river without mantling. So I went through main entrance. The rest of the mission is normal. Unfortunately getting silver gear requires mantle out of water.

    But the real challenge is completing bonus objective. Because I couldn't use river route, I needed to get back to start and then use crack in the wall to get to graveyard. The catch is if you have all objectives complete starting point will become exit point. So you can't get Moseley keys just yet. Use that route to take Sheriff's body to the graveyard. And here is another problem. You need to transport body to graveyard. In order to do that you need to make 3 box stairs. Put body close to boxes and climb onto highest box. Place body on lower box. Now you need to cross the slope. It's not easy, I got stuck on the edge. Luckily I managed to transport body on rock, so second climb on boxes was more successful. When you appear on rock, you can easily place body in grave. This complete bonus objective, but...

    This is just half of the success. You need to get out of the graveyard. You need 2 boxes and 1 rope arrow. Make 2 box stack with highest box barely touching the first. Use rope arrow on the right. Climb it and drop on boxes and beat first slope rock. For the second slope you can't use rope arrow. You need to make diagonal 2 box stack and climb on it and beat the last obstacle.

    After that get back to Moseley keys and get back to starting point to finish this mission.


    BREAKS: 0

    Damn, who would have thought that this short and flat mission can be so tough. When Mosley entered Helena Way, guards patrols forced me to change my route and cross the canal. The problem is I can't jump. I found a pipe bove canal and run on it to the other side of canal. Then I went north ahead of Mosley and met with her. Other problem was Pagan route. When he's going to Helena Way there was woman guard and unfortunately no alternate route. I hide in the corner, barely shadowed and woman guard barely first alerted on me. I was really surprised that she didn't attack me.

    Another problem was secret part of graveyard. While entering it is easy, getting out of it require 3 boxes. And boxes are rare in this mission. There are just 3 pairs of boxes (6 boxes). There is pair in the alley somewhere in Helena Way, pair behind Garrett's house and last pair of boxes behind tavern. To get out of secret part of graveyard make 3 box stairs, then take highest box and climb with it higher. Do that 3 times and you will get out of graveyard.


    BREAKS: 0

    For most part this mission plays normally. Bonus objective is also easy. In order to get out of Autumn and Winter Zone I used vine arrow on the side of railing and dropped onto it. And because vine arrow is shorter than rope arrow, I could grab it in the Thief Gold way (crouching under it and standing). Also fun fact: at the end of the mission I wasn't careful at all and right after I got objective complete, I got killed by tree beast. This never happened to me before.

  3. #3
    Registered: Mar 2018
    MISSION 10

    BREAKS: 1

    This mission is a freaking nightmare. It took me nearly 6 hours. Just like Thief Gold Lost City, this mission is like ultimate challenge. But unlike Lost City, this mission provide lots of tools. Or should I say lots of boxes. This mission is all about managing boxes. And also writing about this mission felt like writing the walkthrough. That's really amazing mission.

    Bell tower at the beginning greet me with 1 vine arrow climbing. Unfortunately few seconds later there pipes that require mantling on them to cross further. After that is house with wood part above window. I used vine arrow and KO-ed archer. To get back I leaned towards vine and grabbed it. My next only way forward was getting through Astronomer's attic. I used 1 vine arrow. I got sunburst device and more importantly 4 boxes. I used box to go through window outside. I appeared in Shemenov Estate.

    After that mission open 2 paths for me. I chose to ran into tower and then climb up. I used box to climb onto metal railing on balcony and drop to Sir Cullen Keep. I took with me 1 box. Then took 2 boxes from Sir Cullen place. I made 3 box stairs and climbed into Necromancer Tower. I skipped secret lowest torture room, because there is no way to get out without mantling. I used lower window ny climbing on box and running through gap to the other side. I climbed a box in order to get onto broken elevator. Then I looted this place and KO-ed 2 thieves (I used flashbomb on second thief). Unfortunately this was a dead end for me. I took all boxes (11) back to Sir Cullen Keep. As for climbing broken elevator shaft, it's possible to climb ladder and keep dropping on floor while slowly turning left.

    Next I used 1 box to climb onto ledge and then I ran through a gap onto tower. I transported with me 3 boxes and with 3 box stairs I ran over gap to Fieldstone Estate. Also I transported 3 other boxes with me. I ignored abandoned building, because getting out of it requires jumping and mantling. I used 1 box to climb over wall towards single guard walking lower and transported all my boxes there. In order to quietly drop them I used moss arrow. I climbed metal slope and put there 3 box stairs and ran across a gap.

    Then I watched archers fight. Tower archer survived and dropped to the lower floor of tower. Not only that, his head got stuck in ceiling!.I used vine arrow to get on top of tower and KO-ed unlucky survivor. After that I dropped from tower and went to window, get back to Astronomer's attic and finally returned to Shemenov Estate.

    I went back through tower onto balcony and took 2 boxes from there and took them to Shemenov Estate. To get out I used vine arrow. Also I found a way to grab vines more reliably - by leaning towards them while crouching. I returned to tower and ran onto wooden balcony. Then I used the second path through chimney. It's possible to ran onto it from ledge by run+strafe exploit. I looted the place. My progress was stopped by a wall. So I decided to return to Sir Cullen Keep. I took a single box with me and went north towards Carlysle Castle.

    I put 1 box on a tiny beam and climbed higher. Then I shot vine arrow in the wooden part on the right near glass house. This became my return path. I dropped down with a box and took everything from glass house. Then I used box to climb on the ledge and shot vine arrow in order to get into Carlysle Castle. I timed my climb with guard and KO-ed him. Then I used sunburst device to get into armory. Then I just returned back across the street.

    I used box to climb into window on the left. I took a box with me and dropped to bank window. From there I shot vine arrow into upper right part of wooden frame of the window I dropped from. This way the vine wasn't too close to wall, so it was possible to use it to return back to Sir Cullen Keep. I dropped down and put a box in front of window. Then KO-ed guard and a noble and looted the house. Then I took a box and climbed out of the window. I took box again and use it climb onto higher ledge. I took box again and climbed the vine. Then I went to the bank, KO-ed 2 guards and loot it. Then I left onto balcony.

    I went right and used vine arrow on upper part of window frame to climb it. Then I used another vine arrow on upper wooden part of the window and climbed on higher ledge. I took box with me and ran behind guard on white balcony. He went into search mode, so I crouched in barely shadowed corner. It worked. Then I just ran onto balcony, put box which alerted guard and KO-ed him. Then I used a box to climb onto balcony ledge and use it again to climb from wooden beam over the wall. I took a box, ignored Keeper's house and climbed with a box into 2 ladies house. Loot objective completed. Unfortunately my progress was halted by pipe machine. I took a box and returned to Sir Cullen Keep. I transported all boxes (7) from there to pipe machine, because I'm not going to return to Sir Cullen Keep anymore.

    During my return route I noticed the wooden part above white balcony. This will be my return route to Shemenov Estate. Also I entered Keeper's house by doing 6 box stairs with top boxes a bit on the side, so I could easier time to climb them. For pipe machine I did 3 box stairs. Took all boxes except one. I run+strafe on top of metal slope with light bulb. Then I did 3 box stairs ( I put 2 boxes into diagonal gap and last box a bit on the side, so it will not stand on light bulb). I KO-ed drunken guard. Then took all boxes. For lower box I needed to drop to the edge of the ledge and take it. I climbed down with boxes, then dropped all boxes except one and put 1 box on the side of ladder. This allowed me to climb the ladder, drop onto box and stop on the higher roof instead of falling down. I used a box to climb higher and then 3 box stairs to get to the entrance to Angel Watch. I dropped there all my boxes and entered Angel Watch. I will need to find more boxes to create 6 box stairs to get out of Angel Watch and a lot more boxes to pass the wall near starting point. Also in Angel Watch I can't use ventilation, because floor is on the side of ladders. And by the way my stats tells me that I play for almost 3 hours and I just entered Angel Watch. Oh, boy.

    The guard in front door was facing door. This never happened to me before. He was always facing other way. Nut sometimes he was turning. I never knew about that. Also little robots are going to maintenance machine on second floor to recharge. On the stairs to 4th floor 1 noble got stuck screaming that he saw me. How did he noticed me I don't know, but I KO-ed him easily. OK, so I found another way out of Angel Watch. On the 4th floor there is window to the outside. Use it. On the side of giant angel statue base there are metal vents. Use vine arrow on the lowest part, then run+strafe to grab it and you will appear outside Angel Watch. After discovering that I threw outside 3 boxes I dropped into ventilation shaft and 14 boxes from second floor. Also when I was going to 5th floor I met another guard stuck walking on the stairs leading to 3rd floor. 3 more boxes on 5th floor. 4 hours of playthrough and I'm leaving Angel Watch. Now I just need to return to starting point. But oh... I need to return there without jumping and without mantling. And I have so many boxes to transport.

    I brought 35 boxes to this "high wall" and it happened that normal 6 box stairs will be enough to beat it. Not only that. There is even easier way to climb it. You can shoot vine arrow into wood on the right and run+strafe to it. Now you only need to take 9 boxes with you to the beginning, because there are some side rooms that I skipped, because I had no boxes. There is dark room with sleeping guard. Getting out of it require 6 box stairs. There is another secret room with 3 water arrow and 2 coins. Just lean forward to grab these items from a window. Getting out of this secret require 3 box stairs. After that run onto bell tower. Mission completed.

    So this mission took me 5 hours 56 min 14 s. I got 2638 loot out of 2853 and found all 7 secrets. My time is that long because I was exploring this mission, because I always getting lost in the city part. But after this run I memorized the layout of this level really well. Also I wasted almost 2 hours on transporting all boxes from Angel Watch to starting area. That was a huge waste of time, but at that moment I was really paranoid about boxes. I believe it's possible to get all loot in this mission. It's just a case of transporting boxes and climbing them. If I would replay this mission, I would choose this route:

    1. Getting to Shemenov Estate, bringing 4 boxes from Astronomer's attic there and looting the house under chimney.

    2. Transporting all boxes to Sir Cullen Keep.

    3. Taking 5 boxes to Angel Watch (I believe it's possible to get there with just 5 boxes), looting all places on the road.

    4. Looting Angel Watch and taking boxes from it. I don't know how many, because I don't know how many is needed to get out from abandoned building.

    5. Transporting boxes to Sir Cullen Keep.

    6. Looting Necromancer Tower. I believe it's possible to loot secret basement. You can get out of it by making box stairs and climbing torture device. Then just use vine arrow on the side of table and climb it.

    7. Loot apartments and take all boxes back to Sir Cullen Keep.

    8. Transport boxes to Fieldstone Estate.

    9. Loot abandoned building. I think that in order to get out from crack on the floor, you will need to make stack of boxes and use vine arrow to help you. In order to return to Fieldstone Estate you will need many boxes stairs. The wall is pretty high. There is also giant pipe with ladder that leads to Sir Cullen Keep. To get inside you will need 1 box to grab ladder. I have no idea how possible is to use this route, but remember that if you choose this path you need to leave boxes necessary to going back from Sir Cullen Keep to Fieldstone Estate.

    10. After that just return to Bell Tower. Remember, you need 9 boxes or maybe even a little less to get 2 bonus rooms near starting point.

  4. #4
    Registered: Mar 2018
    MISSION 11

    BREAKS: 2

    The first problem is elevator shaft. I used elevator and dropped onto rock. Then I used vine arrow on the left of actual vine and climbed to the 2nd floor. I KO-ed Mechanist. Then I vined up to the middle part of wooden beam and turned off camera. Then I used elevator to get to 3rd floor ( I placed myself on the left side of the elevator) and KO-ed another Mechanist. I hid a body and KO-ed last Mechanist.

    The rest of Markham Isle is normal. Base is mostly normal as well. Getting into cave with pirate treasure require 1 mantle out of water. As for how to get out of water during return - at north of old pirate base is underwater cave leading to storage cave near the entrance to the base. Looting Main Cargo Storage was a bit more tricky. I couldn't enter from water, so I stood in front of storage, but behind corner. I shot vine arrow on the left side from a torch. Then jumped into water, climbed on the vine and dropped on torch. That's how I KO-ed the guard.

    I couldn't get out from the place with lost key without mantling. Thanks to that place I discovered interesting mechanic: if you push box that touch water, it doesn't lose it's physicality. But if you drop box, it lose it's physicality. If you put box on solid box, then it will also be solid. But if you put box on dropped into water box, then this box will lose it's physicality as well. To get out I tried to push 3 boxes and on them put 3 another boxes. Unfortunately exit holes are too small for these manoeuvres. So instead I pushed 1 box, climbed on it and mantled outside.

    As for Cetus Amicus - I entered from deck and went downward.

    MISSION 12

    BREAKS: 0

    I visited Station 9 and finally found out what is outside. I slowly climbed the slope by run+strafe exploit and noticed that there is black hole outside. I also destroyed camera in this station. I got drill in Station 6. For this I roped up to top of the building (speaking about rope arrow, it's weird that they behave differently than vine arrows - I can't grab them by leaning towards them). Then ran over lava and used a box to climb up to drill. Then I dropped down. Also it's weird that in previous mission I had vine arrows and in this mission they changed into rope arrows.

    MISSION 13

    BREAKS: 1

    The mission starts with another break at the very beginning of the mission. You need either jump out or mantle out of starting point. It's possible to enter house via secret passage. First there are non-frobbable 3 boxes on the grass. They are really easy to climb boxes. And there are 3 standard boxes. I just put 2 boxes stack on lower box on the front and climbed on them. I didn't climbed highest box perfectly and walked onto little roof. I opened secret passage and... got stopped by invisible wall. It confused me a lot. It took me few minutes to figure out that I got stuck on the roof. So instead I climbed to the top of highest box and run+strafe onto roof. Thanks to this I could enter Gervasius house. To get out from under the stairs on 1st floor storage room, I used a vine arrow.

    MISSION 14

    BREAKS: 1

    Just like in previous mission there is the same break at the very beginning of the mission. And surprise this time there is no boxes, so there is no way to enter Gervasius house via secret entrance. I used north entrance, because south entrance is guarded by watcher.

    To get masks I simply disabled floor traps and after grabbing the masks I just shot vine arrow into ceiling to get out. To get out from Cultivator room I simply broke into room with masks nearby (I disabled trap floor before) and shot vine arrow into ceiling.

  5. #5
    Registered: Mar 2018
    MISSION 15

    BREAKS: 2

    In first part I only had a problem in dealing with Hall D. There is no way to enter this hall, but through main entrance. I dealt with 2 big robots with few frogs threw through windows into walls. Then I needed to get to controls. I managed to shot vine arrow from east direction on the edge of metal grate on ceiling. Unfortunately vine is a little too short, so I was forced to jump and drop on higher ledge. To return to controls I could use passage in north-west part of complex, but I was too lazy. When I was high, I send elevator down. Then to return up - I stood on the elevator and shot moss arrow into upper switch.

    After that I decided to skip North Apse and do signal towers. And I must say all towers are possible to beat without breaks except cannons place. Also this is the most dangerous area in this mission and probably even in the whole game. I was also looking for some boxes, but there is nothing like that.

    The normal route to beacon room require 3 breaks. First to jump out of first ladder. To get to higher ledge you need to get down and while standing near south wall, shoot vine arrow in the edge of grate at the ceiling. After that climb up and shoot 2 more vine arrows in the grate close to first vine. This way you will create vine arrow stacking. Now run towards first vine, turn yours back towards next vine and drop. You will grab next vine. At the end drop to the higher ledge. Only to jump out another ladder. And then jump to beacon room and the last signal tower.

    But there is even better way - get the secret in Plans Room. This require 1 jump out of vine. Lever is possible to frob without jumping. After that open North Apse and open second exit. You can get up on the ladder to the office. It may be tricky, but just drop from top of the ladder while holding forward button. The rest is just exit, which should be easy.


    TIME: 23 hours 11 min 13 s (25% of it is Life of the Party)

    LOOT TOTAL: 26398




    This was very fun playthrough. The game provide very small equipment and many other tools (like boxes). Most of the missions has some really challenging spots. Unlike in Thief Gold, where last missions were quite boring. It's also very interesting that the hardest, in my opinion, missions for this run doesn't give too much challenge, but easy and normal missions have some really troublesome spots. I never thought about Life of the Party being hard, but in this no jumping/no mantling challenge it was a nightmare. The hardest mission from both games. Also I'm really happy that I learned new mechanics that I had no idea about. That was fun, but also very tiresome.

  6. #6
    Registered: May 2008
    Location: Southern,California
    good job

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts