TTLG|Thief|Bioshock|System Shock|Deus Ex|Mobile
Results 1 to 11 of 11

Thread: How to et rid of close caption ?

  1. #1
    Member
    Registered: Nov 2019

    How to et rid of close caption ?

    I'm using NewDark and FM's have close captioning at the bottom. How do i disable this on fan missions ?

  2. #2
    Member
    Registered: Nov 2001
    Location: Lille, France
    Maybe you can edit user.cfg like this :

    Code:
    ;enable_subtitles

  3. #3
    Member
    Registered: Nov 2019
    That doesn't work. From what I've read it is incorporated into the patch itself. I don't see a option to disable it.

  4. #4
    Member
    Registered: May 2017
    Location: USA
    What Stefan suggested will work. You disable them subtitles by commenting them out with a semicolon in the cfg.

  5. #5
    Member
    Registered: Nov 2019
    I don't know why but i still have subtitles. Adding ;enable_subtitles in USER.CFG doesn't change anything.

    There is a setting editor 'NewDark Graphics Settings.lnk" but I'm getting a ERROR message when i try to change the setting. The setting is stuck "On". Could be because I'm running Wine on Linux. Not sure

    2nd edit: I'm also using HDMod which includes this 'NewDark Graphics Settings.lnk". That must be what is blocking the cfg file.
    Last edited by howeird; 14th Nov 2019 at 20:26. Reason: found setting editor

  6. #6
    Member
    Registered: May 2017
    Location: USA
    Don’t add the whole line. Find the pre-existing subtitles line and add a semicolon in front of it.

  7. #7
    Member
    Registered: Nov 2019
    There is nothing in the usercfg file that has anything to do with subtitles. But, i did find a folder that was labelled "subtitles". I deleted the folder and subtitles no longer appear in the current FM. I suppose i would have to delete that folder every time i install a new mission. The HDMod interface is pretty cool. It has 4 different mods for water alone.

  8. #8
    Member
    Registered: May 2001
    Location: Boston MA
    I found this annoying as well and did exactly what this thread suggested and it worked perfectly.

    Here is the line in user.cfg - ;enable_subtitles

    I just added the semicolon.

    bbb

  9. #9
    Member
    Registered: Nov 2001
    Location: Lille, France
    Quote Originally Posted by howeird View Post
    I don't know why but i still have subtitles. Adding ;enable_subtitles in USER.CFG doesn't change anything.

    There is a setting editor 'NewDark Graphics Settings.lnk" but I'm getting a ERROR message when i try to change the setting. The setting is stuck "On". Could be because I'm running Wine on Linux. Not sure

    2nd edit: I'm also using HDMod which includes this 'NewDark Graphics Settings.lnk". That must be what is blocking the cfg file.
    An *.lnk is a shortcut extension.

    Maybe your user.cfg has a protected setting (like a read-only setting) that prevents you to make a change... Or there is a 2nd user.cfg in the HDMod folder that is prioritary. I don't know I'm not using the HDMod in Thief 2.

  10. #10
    Member
    Registered: Dec 2004
    Location: Germany
    Close captioning AKA subtitles can be enabled in several configuration files. The player can put it into user.cfg, but also into cam_ext.cfg. A mission author can put it into fm.cfg in a mission's zip file, which will only be effective in this particular mission, then.

    Settings in user.cfg have the highest priority. Then comes fm.cfg, and after that there is cam_ext.cfg. Whether there are other configuration files in which the line "enable_subtitles" works I cannot say.

    In fm.cfg, one can also put the line "enable_subtitles 0" (0 is the number zero here, not the letter "O") to switch off subtitles in just this mission. It will switch off subtitles, unless they are enabled in user.cfg (higher priority).

    I have not checked out what happens if one puts the line "enable_subtitles 0" into user.cfg, but it could possibly switch off subtitles in any cases, overriding any setting in cam_ext.cfg or any fm.cfg file.

    Unless the player uses ancient Darkloader to play missions, a folder called subtitles in the game's folder will usually contain subtitles for the conversations from the original game, but not additional subtitles for a certain mission. These subtitles are usually installed with Jax64's T2Fix. Most likely, one can erase the subtitles folder to get rid of the original game's subtitles; I did this a while ago and noticed no unusual problems back then.

  11. #11
    I had to delete the ;enable subtitles-line entirely from USER.CFG to get rid of them, so that's another way to do it.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •