TTLG|Thief|Bioshock|System Shock|Deus Ex|Mobile
Results 1 to 8 of 8

Thread: I have questions concerning the nights of nine and a quest- "when spirits lease"

  1. #1
    New Member
    Registered: Sep 2007

    I have questions concerning the nights of nine and a quest- "when spirits lease"

    I'm not sure how this forum works at all - if i'm suppose to post my questions here and others can reply to help, or if there is another place i'm suppose to go?
    Anyhow, i would really appreciate any help I could get.

    My first question is how can i join the knights of nine? In the book it says just to hang around anvil, leave for 5 seconds, and then re-enter and it should kind of take care of itself that way. However, i think i've asked rumors from every person in anvil and i cannot get the topic of the nights of nine to come about.


    My second questions is concerning the quest "when spirits lease". It seems to me that there is a glitch in the game. I am playing on Xbox 360, not on the PC version if that makes any difference? But anyhow, my problem is, i cannot get the portal to open. the family member guy that is supposed to open it says he will, and he feels around the door, but will not open it. i know it can be opened because the first time around doing this quest he opened it, but i had died and so had to go back and re-do it. the second time, i waited for him to open the portal, but he never did. i think there is a glitch and i don't know how to go on from there/fix the glitch so i can continue this quest. i have tried fighting him, leaving anvil and returning, talking to him, nothing seems to work; he just keeps feeling around the wall and the portal remains closed.

    If anyone has any sort of help for either of these problems i would be very grateful.
    Last edited by Katrina82; 16th Sep 2007 at 14:55. Reason: typo

  2. #2
    New Member
    Registered: Sep 2007

    whoops

    knights* of the nine - my bad

  3. #3
    Member
    Registered: May 2001
    Location: Stir Crazy
    For the spirits lease, you have to sleep in the house first.
    Then it triggers the apparitions.

    About the nine, you have to talk to a guy near or outside the church, a prophet of some sort and talk about them, he will send you on a quest all over the land for altars.
    Last edited by Martin Karne; 17th Sep 2007 at 19:07.

  4. #4
    Member
    Registered: Jun 2006
    Location: Gira

    KoTN

    First of all, you must have KoTN installed

    The ad-on adds an extra topic to a dialog box. About the prophet, yes. Almost anyone you talk to can reveal then the story about the prophet of Anvil. All you will have to do after that is go and talk to the guy to have "the Pilgrimage" quest activated.

    You don't actually have to talk to anyone else - just walk into Anvil, straight to where the prophet stands and begin a conversation with him.

  5. #5
    New Member
    Registered: Sep 2007

    :o/

    Unfortunately these peices of advice cannot help me.

    In relation to the 'when spirits lease' i have already slept in the house. the guy has already fled to the imperial city. i've gone to him, and he returned to the house with me. in my first attempt he opened the door/portal for me and i went in and did what i needed, but unfortunately died and had to go back and re-do it. in my second attempt after getting the guy to go to my house to open the portal, he never did. i waited for a long time, tried various way of getting him back on track(because i think there is a glitch) such as striking him and talking to him, but nothing has worked.

    Now, for knights of the nine, there is no prophet chillin anywhere.. at all. i don't know why.
    And to ~s:a:n:i:t:y~ although i thank for attempting to help, i'm not sure i understand what you're talking about; what add-ons? ...is there some sort of add on that i need or can get? or am i way off track? ..i also don't know what "KoTN" means, i'm sorry /.

  6. #6
    Member
    Registered: Jun 2006
    Location: Gira
    KoTN=Knights of the Nine.
    Sorry, I meant 'plugin', and that Knights of the Nine official plugin is what you need to be installed to have the prophet appear in Anvil... But I am sure you do have it.

  7. #7
    Member
    Registered: May 2001
    Location: Stir Crazy
    Well since you have the XBox version, there might be some bugs for "when spirits lease".
    Anyway make sure you have the severed hand from the jar in the stairwell room (main house area) before attempting to open any basement doors.
    Last edited by Martin Karne; 19th Sep 2007 at 23:54.

  8. #8
    Member
    Registered: Dec 2006
    Location: Western Australia

    same problem

    Hi ya,

    I have recently purchased knights of the nine on xbox 360 and followed all instructions. But it will not start up even though it says its loaded. Any suggestions as to how to get it to work would be appriciated.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •