TTLG|Jukebox|Thief|Bioshock|System Shock|Deus Ex|Mobile
Results 1 to 18 of 18

Thread: Bug List (contains spoilers)

  1. #1
    Registered: Dec 1999
    Location: Black Squadron

    Bug List (contains spoilers)

    Thought it might be handy to have a list of all the bugs we've come across.

    I'm going through chapter 9 at the moment, and I've just cleansed Xana from my body at the church/temple and have been given some shiny weapons for my troubles.

    A short while later when Percy tells me that I need to raise the water level Xana comments that he gives too many orders.
    But she's not around anymore, so what gives?

    Maybe I missed something obvious...

  2. #2
    Registered: May 2001
    Location: earth?
    if you missed something, so did i as it left me wondering what woman was now talking at me.

    some of the many bugs i've run into:

    * gfx detail setting does not persist through exiting the game
    * in chapter 9 or epilogue (not sure which it is in) where you get the objective to kill the pao kai, you can aggro the monster & kill him before ever entering the spot that triggers the objective. you get skill points when it dies still, it will give you the objective still when you enter the area that triggers it, but it is not marked as "done" in your objectives (it didn't prevent me from finishing the game, however, so i think it is being recognized as "done" just not printing it on the objectives screen)
    * the rope bow has an endless supply of arrows & you can easily kill everything with it (perhaps working as intended, but it felt like an exploit )

    some others like the stand-off at the boat in level 4 not ending because of a box blocking a spawn point & the (chapter 6?) bug where you cannot pick up your backpack if you carry shield & weapon are to be fixed in the upcoming patch

  3. #3
    Registered: Mar 1999
    Location: I can't find myself

    only two A highs, but whatever.

    one where if I press mouse1 at the beginning of "A Fire in the Blood" the player character will pull out the most recently used weapon, despite all my equipment being taken away, and then the game crashes when attempting to pick up another item.

    a couple of instances of jumping onto a rope arrow rope that is deployed too close to a wall before it finishes the initial swinging about physics causing me to break collision with the level and fall out of the game world.

    can't carry more than one "Ring of the Phoenix," which kind of sucks.

    Knockback for the jump attack (powerstrike+jump, level 3 melee, iirc) is occasionally ridiculous, once flinging an orc so far that it visibly collided with the skybox.

    Maybe not a bug at all, but confusing nonetheless. The poison from the magic spiders in the final portion of the Temple of Asha eventually wears off, but zombie poison and normal spider poison doesn't appear to.

  4. #4
    New Member
    Registered: Nov 2005
    Thanks for posting...
    Feel free to continue... it's really usefull. All of the bugs listed here are forwarded to the appropriate person, and Arkane team will try to fix them as soon as possible.

  5. #5
    Registered: Oct 1999
    Location: Stuck in some sticky mud, nope quicksand
    Not really a game bug, the level where you have to get on the big ship before going to the island, if you look over the side of the ship that looks out to sea its obvious that the default skybox texture that ships with the source editor has been used for the skybox, cause it doesn't match up at the edges, so where the water ends and the skybox sea begins it is obviously contained within a box.

    Some inventory items dont persist beyond the level they are found on, note found on floor in library in city just before you chase the thing with the crystal.

    Secret door in roof above same library the guard in the corridor it opens into seams to be standing in the door, as I got attacked through the door by guard before opening it.

    Later on in temple on island theres a room where some spiders are attacking a zombie, and a wooden platform sits in some water, a hole in the wall has a chain in it indicating theres a lever near by (on wall near wooden platform), first time in there the lever was missing and the game crashed to desktop, on a reload the lever was on the wall.

    sometimes when there's an automatic game save, the game hangs, and frame rate drops to 1 frame a minute, seams to hang just before the save, seams to do it a lot when the save is on a corner, like its going to draw whats round the corner or make the save and cant make its mind up which to do and loops infinity. Same with saves going from tunnels to those wooden houses attached to the high cliffs, should it save or draw whats through the windows.

  6. #6
    Registered: Dec 1999
    Location: Black Squadron
    Again in chapter 9, I have just killed the large dragon with the big gun and gone to use the winch to open the door, however I didn't make it down in time and the door was shut.

    I went back up to open it again, however the winch wouldn't do anything. It would higlight, however nothing happened when I "used" it.
    This, for some reason, affected savegames made before I used the winch the first time and persisted through a game restart and reboot.

    In the end I gave up, enabled the developer console and noclipped through the door.

    And surely this shouldn't happen: (Epilogue)



    Click for full size.

  7. #7
    Registered: May 2001
    Location: earth?
    * (minor) in the City of Flames, you can shoot a rope arrow into this wooden beam & jump onto it into the chasm & climb down to a point where it says you fell to your death (even though you're still alive) screenshot
    (i've just gone through the window to the other side of town & am standing on the bridge at the start there)

    * in the epilogue right after the load zone that occurs while jumping through the hole in the wall, if you turn the corner to the left niche in that initial room, you'll see this weird text: screenshot

  8. #8
    Registered: Mar 2000
    Location: tall bikes and tattoos
    Here's a bug: when I finally pick up my gear towards the beginning of chapter seven, the game crashes.

    Every time.

  9. #9
    Registered: Mar 1999
    Location: I can't find myself
    Unbreakable shields are also apparently breakable.
    Had the Fire shield, blocked a strike from a Vampire Knight and the shield just vanished. I'd taken a few hits before, but I wasn't keeping track of how many, so I can't estimate the HP value for an unbreakable shield.

  10. #10
    New Member
    Registered: Nov 2005
    Most of this troubles are now fixed in the upcoming 1.02 patch...
    Sorry, no release date yet... except as soon as possible

  11. #11
    Registered: Nov 2005
    Im not quite sure about the name of this level. Its right after you fall into a sewer-like system in the Temple of the Spider. When I cast fireball at one of the zombies there (doesnt matter which one), the game crashes to desktop. I have to cast the spell successively 2-3 times for the crash to occur. The bug is reproducible.

    My system:

    AMD 3400+ So 754
    Asus K8V SE Deluxe
    2 GB RAM
    X800 Pro (Catalyst 6.9)

    Windows XP SP2
    No firewall, antivirus sofware disabled

  12. #12
    Registered: Aug 1999
    Location: terrible canyons of static
    Magic effects on weapons don't properly refresh themselves and they leave laggy remains all across my screen - it looks similar to the hall of mirrors effect you usually get in games when you noclip outside level boundaries. Click for screenshot. This makes using any enchanted weapons rather impossible

    Using a Geforce 6600 GT with 84.21 drivers.

    Edit: fixed it by turning on 2x antialiasing. My framerate took a noticeable hit

    Edit 2: antialiasing makes the game horribly unstable so I had to turn it back off

    Last edited by Spitter; 6th Nov 2006 at 18:39.

  13. #13
    Registered: Mar 1999
    Location: I can't find myself
    Here's an odd one. Not an in-game bug, but an issue that does seem to have the game at it's core.

    I use ZoneAlarm for my firewall (version 6.5.737) and I have to turn it off to play Dark Messiah, despite giving it full privileges in Program Control, ZA still manages to mess up some stuff. So I turn off ZoneAlarm, play DM for a bit, exit, and turn turn ZoneAlarm back on. Every time I do this, my computer does a full reset when I turn on ZA. And it only happens when I turn on ZoneAlarm after playing Dark Messiah.

    I don't expect this will get addressed in a patch, but I figure a heads-up may be in order.

  14. #14
    Registered: Sep 2000
    Location: Hong Kong

    As mentioned in another thread, I have to disable Spydoctor when I am playing DM as it either crashes during the game or I am unable to exit the game without doing a reboot -- or if I am lucky, being able to alt-tab back to the desktop and kill off any DR Watson processes.

  15. #15
    Registered: Aug 1999
    Location: terrible canyons of static
    While I was preparing a fireball spell from a scroll, I spammed my heal spell quick key (not a scroll, although I can't remember if it even came in scrolls) and I got healed without any mana decrease.

  16. #16
    Registered: Jun 1999
    Location: Construct of the Dark Engine.
    At the part where you lose your backpack, pressing 'attack' draws your last weapon, despite the lack of any inventory.

    At that same part, lacking a backpack, if you pick up one of the weapons the orcs drop (I grabbed one's bow), the game crashes.

    (Apart from that last note, the game was rock-solid stable for me from start to finish.)

  17. #17
    Registered: May 2003
    Location: Minecraft
    I forget which chapter it's in, but the area where you're making your way through the cliffside huts before you activate a lift. There's a loading zone when you're climbing some stairs in a ruined stone building/tower, at the top I tried to rope arrow to a secret (Not an 'official' one, just a hidden magic mushroom) and missed my jump to the rope, as I plummeted through the loading zone it crashed, didn't seem to like loading another area just so I could die.

    I've also managed to plummet to my death whilst simply walking across items that I've smashed. Last time was in Menelag's cellar where you can find a ring under some barrels. Smashed barrels, grabbed ring, AAAAARRRRRRRRRGGGGGGHHHH.

    Once, when approaching a guard sitting on a stool, I was able to backstab him as I remained unnoticed. However, when I automatically tossed the body away from me it became stuck in the air above the chair. After a few moments he very slowly righted himself and ran off (), called his mates, then proceeded to punch me as he'd lost his sword when he died. I couldn't hit him back as my weapons went through him. That was in the warehouse you have to access after chasing the ghoul with the crystal, the chap was in the room where the Daggers of the Disciple are.

    Finally, on a couple of occasions Xana has pointed out something that I could do when I'd already done it. The pillar held up by planks once you've accessed the Orc Temple ('I wouldn't want to be under that pillar when it falls' I think) I'd already toppled it and was making my way across it when she said it. The other time was when you're collecting the gems for the spider statue, I'd already got them, but when I approached the statue to insert them, she told me to go find them.

    One other thing, not so much a bug as a request: Would it be possible to add an option turn off the hints & tips? I've played the game through about 5 times now and I know very well I can kick people into spikes/fire etc.


    Almost forgot.

    When using multiple Fire Trap scrolls, once the first is cast you have to wait for the spell to recharge. All well and good. However, when it's recharged, you're automatically flipped back to your last used weapon.

    When using rope arrows, if you fire two so they drop ropes within a few inches of each other, then cimb onto one of them, it's then impossible to jump off again as you automatically grab the adjacent rope. I only managed to get off because one of the ropes was attached to a higher beam, so I was able to climb above the other.

    Also had a couple of instances where I was unable to turn in one direction when climbing a rope, even though there was no obstical in my way.


    After rescuing Leanna from the spider, I accidently clouted her with the Soulreaver staff when we were travelling in the lift. She remained a pretty shade of iridescent blue for the remainder or the area. Except for her face, which remained normal. Sareth also called her a wench and Xana encouraged me to kill her, but we still carried on as normal.

    I killed a necromancer who was in the act of summoning a zombie with a dagger adrenaline attack. For the rest of the area I had a constant buzzing of flies in my ear.

    If you notch an arrow on the rope bow and them move onto a rope (You have to drop off a ledge to do this as you can't jump onto a rope without automatically shouldering your bow), you automatically de-equip the bow as you grab the rope. But when you dismount and re-equip the bow, the arrrow is still notched despite the bow being held in one hand. You can't notch another arrow till you de-equip/re-equip the bow again.

    The Fireball spell doesn't have the red recharging 'clock' in between shots despite telling you that 'The spell is not ready yet!' when you try to fire.

    Spells that have a recharge time, like Charm and Firetrap, can bypass the recharge if you flip to another weapon/spell and flip back again.


    Since the new patch, Leanna doesn't respond when you tell her to wait or follow.
    Last edited by driver; 12th Nov 2006 at 16:59. Reason: Addtional bugs and speeling

  18. #18
    Registered: Nov 2005
    Location: Aachen
    Sorry for reviving the thread but I miss a "giant" bug here. I run version 1.02 and I don't get to see the spider-boss at all anymore - although the patch description contains a fix for that. Might have something to do with my NVIDIA 8600GT, the bug didn't appear on the system when I used a 7950 GT.

    Anyway, Leanna won't move out of the pit and only tells me to "kill that thing", the normal spiders keep coming endlessly and I hear the giant one - but that's it.
    No way to get the points for the quest - and I don't know, if Leanna is "saved" or "killed" afterwards.

    I'd be p***** if she'd be dead after I leave the pit without finishing the quest for I really don't like that endless narcissistic Xana-babble all the time. I want to get rid of Miss "I'm-soooo-sexy--at-least-I-believe-in-it-Succubus" a.s.a.p. ...

    I didn't figure out how to fix it jet.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts