TTLG|Thief|Bioshock|System Shock|Deus Ex|Mobile
Page 7 of 7 FirstFirst ... 234567
Results 151 to 167 of 167

Thread: Thief Gold-campaign from Zontik: GOLDEN BOOK released May 30, 2007

  1. #151
    Registered: Oct 2012
    The key is under the counter in the main post office

  2. #152
    Registered: Apr 2002
    Location: Malmö, Sweden
    Quote Originally Posted by fortuni View Post
    The key is under the counter in the main post office

  3. #153

    mission 3 bug

    Hi there

    I need help please
    I have got over 500g but when i go back to the locksmith i cannot get the old gate key he says something about not extending credit.
    What i doing wrong please?

  4. #154
    Registered: Oct 2012
    IIRC you don't buy the key off the locksmith directly.

    You just collect the old gate key from
    the money box on the shelf opposite where you entered and then 500g will be deducted from your purse

  5. #155
    I have tried that but i cannot interact with box at all

    I have 1095 gold and goods saying 270 total says 1365 Have the piece of ice and screwdriver.

    The objectives

    get 500 to pay for the key and greediness must be punished . 500 for the key is too much even in the view of inflation

    But I still cannot get the old gate key.

    Also when i exit the Athropos house i do no get a cut scene just hear the bells cannot move till the bells have stopped.
    Last edited by bigalexjones66; 27th Aug 2017 at 00:33. Reason: more info

  6. #156
    Registered: Oct 2012
    There is no cutscene at Athropos' house, the mission sticks as you hear the clock strikes, so that is working correctly.

    But why you can't collect the old gate key is a mystery, sounds like a bug.

    What game are you playing, The Golden Book campaign or the individual mission The Eternal Candle?

    Luckily I have saves for both games, which one do you need?
    Last edited by fortuni; 27th Aug 2017 at 03:28.

  7. #157
    That would be great send me the save for The Eternal Candle

  8. #158
    Registered: Oct 2012
    Last edited by fortuni; 27th Aug 2017 at 03:27.

  9. #159
    Registered: May 2010
    the armory key disappeared from my inventory,what to do?

  10. #160
    Dóttirin klęšist oft móšur möttli
    Registered: Apr 2015
    The armory key will be destroyed when you use it on a door (on any door). This is a bug. You need to load an old savegame. Use it on the armory door only.
    Or upload a savegame and I open the door in DromEd.
    Last edited by Unna Oertdottir; 23rd Feb 2019 at 06:49.

  11. #161
    Registered: May 2010
    Quote Originally Posted by Unna Oertdottir View Post
    The armory key will be destroyed when you use it on a door (on any door). This is a bug. You need to load an old savegame. Use it on the armory door only.
    Or upload a savegame and I open the door in DromEd.
    i was afraid of that,never mind i'll load an older save thnx

  12. #162
    Registered: Oct 2012
    dml fix for armoury key to prevent it disappearing from your inventory if used on incorrect door, courtesy Unna.

    DML1//Golden Book mission 1: Bug fix for armory key//miss20.mis.dml
    -ObjProp 836 "FrobInfo"    
    +ObjProp 836 "FrobInfo"           
        "World Action" Move
        "Inv Action" None
        "Tool Action" Script, Deselect
    +ObjProp 836 "SlayResult"         
        "Effect" Destroy

  13. #163
    Registered: May 2005
    Mission: Fire And Ice
    Difficulty: Beginner
    Completed: November 17, 2019
    Game time: 1 hour, 36 minutes, 41 seconds
    Loot: 2888

    1 hint needed: Location of the armory key.

    Possible improvements: In the second floor music room, a lamp floats in the air some distance away from the wall it should be attached to. The ladder leading up to the top of the west tower extends through the hatch when it is closed. The person sitting in a chair in the garden on the third floor greeted me with a "Welcome, Garrett" but then just sat there, motionless. It felt like only one part of the interaction triggered. Two of the women in the main hall cannot be knocked out.

    Likes: I had a surprising amount of fun searching for and finding all the hidden switches. After I read the engineer's scroll in the third floor library, I figured out you can break the turbine in the basement, which makes many of the electric lights in the mansion go out. This was a great interactive element.

    Dislikes: The location of the armory key is not fair since the player cannot see the key and has to blindly frob a 2D object on a wall to find it. The intro subtitles and the readables contain broken English. The Rammstein remix in intro is copyright infringement and does not fit in with Thief. In the final area, I was forced into fighting all the guards. I would have preferred to sneak around them.

    Bugs: Keys disappear when you use them on the wrong door.

    Questions: What does the switch hidden behind a turbine in the basement do? The lights flickered when I pressed it, but I found no secret area that had opened. When I had completed all objectives except for getting back to the start, there was still a locked door on the third floor. How do I open it?

    Hidden switches I found:
    In the turbine room in the basement.
    On the outer wall, above the door of the second floor balcony. Opens a hatch on the roof.
    On the outer wall, next to first floor window of a guest room. Opens a secret door in the guest room.
    Under a vase atop a fireplace in a second floor room. Opens a secret door next to the fireplace.
    A short way up the ladder in the secret area next to the fireplace in the second floor room, opposite the ladder. Opens the ceiling hatch to the observatory.
    Next to a door in the third floor library leading to the south tower, near the floor. Opens a nearby bookshelf with a secret compartment behind it.
    Under a large bed in a third floor room. Opens a compartment with some loot in same room.

    Mission: Clockwise
    Difficulty: Beginner
    Completed: December 1, 2019
    Game time: 2 hours, 42 minutes, 10 seconds
    Loot: 3100

    10 hints needed: #1 Temple key. After I was sent back in time, I did not turn around. Whenever I passed by that particular lamp, I did not get close enough to realize it can be interacted with. #2 Clock room key. Heard something opening when I pressed the button to the secret compartment it is hidden in, but did not want to spend the time to search for yet another secret door. #3 Getting inside the clock room. I had not looked up at that particular spot. #4 Opening the door to the clock room. Missed the small lever hidden in total darkness near the edge where you rope up to the clock room. #5 Opening the door to the Keeper temple. Missed two buttons hidden in total darkness in the barracks. #6 Machine for weapon improvement in the forge. Firing a fire arrow into the machine was not the solution I expected. I thought I had to carry a weapon to the machine. #7 Getting into the casino. I found the grate but did not try to open it with a weapon. I thought I needed to find yet another hidden switch. #8 Exiting the casino. I was very surprised there is a piece of window frame you can frob. Very hard to notice. #8 Accessing the lord‘s quarters. I had tried to get into the space with the star decorations in the narrow corridor, but only on the other side. When this was not possible, I incorrectly assumed the space on the other side would be too narrow to get inside as well. #9 Inside the lord‘s quarters. I missed the switch that moves the armoire that blocks access to a corridor leading to the casino. #10 Inside the lord‘s quarters. I missed a switch hidden in complete darkness above an hourglass that opens a corridor to the library.

    Possible improvements: Fire and Ice, the first mission, has proper ambient lighting. This mission does not. It is on purpose. Later on in the mission, you get a glowing sword that lights up the spots with impenetrable darkness. Still, all those dark spots look unrealistic. Hidden levers do not make a mission more difficult. They just increase the chances of players getting stuck. JIS is an author that got a lot of flack for his propensity to place many hidden levers in his missions, but it seems Zontik gets a pass because he reads the forums and therefore nobody wants to openly criticize him for this. A chest in a side room on the ground floor of the mansion is floating in impenetrable darkness. It contains a gem, but you have to look inside the chest to get it. Just opening the chest is not enough. I had to use a walkthrough to find the gem. One time I could not drop a barrel I had picked up in the basement and had to reload. I solved the forge key puzzle, but it would have been better if the player could have used a hammer in their hands rather than awkwardly throwing the a hammer in the general direction of the forge. Broadsword of Sheol is a mission that features a wieldable hammer that could have been used here. There is an attempt to recreate the arrow-carrying archers from Thief 2, but the quiver tacked onto their backs looks weird. In the section in which you travel back in time, the cheering when you hit the bullseye startled me. The easter egg in the underwater section of the temple literally threw me for a loop. I was under the impression this was where I had to go and I tried several times to find another way through that underwater area.

    Likes: I love the "time" theming in the mansion. The conversation that triggered when I rang the bell in the kitchen was pretty cool. The room with the tower key is one of my favorite timed puzzles in all of T1. I liked that guards sometimes react to slashed banners or moved objects. Very few missions do this.

    Dislikes: I was annoyed by all the switches hidden in total darkness. I needed many hints in the sequence in which you get sent back in time to the temple from the first mission. The intro subtitles and the readables again contain broken English.

    Bugs: Keys disappear when you use them on the wrong door.

    Mission: Extinguisher
    Difficulty: Beginner
    Completed: December 18, 2019
    Game time: 3 hours, 8 minutes, 34 seconds
    Loot: 2505

    2 hints needed: #1 Getting the old gate key. There was something wrong with the cutscene at Athropos’: I did not see Max walking into his shop after I triggered it. The door to Max’ shop did get unlocked though. #2 Getting into the Ice Keeper’s tomb. Early into the mission, I found the door to the Ice Keeper’s tomb but could not fully pick it. After I got the semi-versatile key, I did not find my way back to that remote corner again. It was hours ago and I had forgotten about that door. Then I was stuck because I had no idea how to extinguish the eternal candle.

    Possible improvements: I would have appreciated a hint on how to put out the eternal candle. If the player missed the Ice Keeper’s tomb early in the mission, they are stuck. The interiors of many building are rather cramped. For example, there is one room on the second floor of the post storehouse with a chair and a table. You can only get to the chair of you climb over the table because the room is so small. It feels more like a closet. Many rooms in the mission are like this.

    Likes: A sprawling, impressively complex city district. The mission did not grab me during the first hour, but as I unlocked more and more areas, I drew me in. Breaking Athropos and The Lord of Time out of prison was cool. The model of the towering interrogator in the prison looks scary. The "Brother Renault and Brother Peugeot" joke made me laugh. That moment when you discover the location of the eternal candle below the old chapel was great. I felt like a proper thief stealing the 500 back from Max mere minutes after I gave them to him. The new floor and wall textures look nice. I also appreciated the new objects (screwdriver, water can, armoire etc.).

    Dislikes: I spent what felt like several minutes picking the door to the Ice Keeper’s tomb. Then the lock was stuck. I had wasted my time. This felt like the author was deliberately messing with the players. The intro subtitles and the readables again contain broken English.

    Bugs: Keys disappear when you use them on the wrong door. The cutscene at Athropos' did not show Max walking into his shop. I could walk through the bookshelf in the Master Builder's room.

    Questions: When I ended the mission, there was still a locked wooden door on the ground floor in the west of the Master Builder’s mansion. How do I open it? Also, is there a key to open the Master Builder’s room? I only got inside because I let him see me. He opened the door when he came after me. There is an unfrobbable Keeper door in the sewers. I jumped from a ladder to the tunnel that leads to it. Can the area behind this Keeper door be explored?

  14. #164
    Registered: May 2006
    Location: Russia
    #1. Can't remember the door; maybe I need some kind of visual impact. IIRC, you can open any door in MB mansion (except #2).
    #2. No, MB's door is staff only. Anyway, there's nothing for player within.
    #3. This door is supposed to be real starting point. When you start the mission, you have sewers behing your back. Obviously, you come to the street starting point through the door and sewers. That's why the door can't be opened.
    Thank you for the detailed review.

  15. #165
    Registered: May 2005
    Thanks for the answers, Zontik!

    Here is the location of the door I could never open:
    1. Enter Master Builder's mansion through the double doors of the main entrance.
    2. Turn left in the main hall and walk towards a statue at the end of a corridor.
    3. At the end of the corridor, a door to the right (north) leads to a small room with two beds, a chair and a shelf.
    4. In the eastern wall of this room is the looked wooden door that I mean.

  16. #166
    Registered: May 2006
    Location: Russia
    Seems I remember. It's a staff-only room with two servants (voice actors) inside. Not supposed to be opened ever.
    You can hear their conversation by moving the wall lantern above the table in the kitchen (if MB is still alive).

  17. #167
    Registered: May 2005
    I reloaded an earlier save and triggered the conversation. Didn't know the lantern was movable. Thank you again!

Page 7 of 7 FirstFirst ... 234567

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts