TTLG|Thief|Bioshock|System Shock|Deus Ex|Mobile
Results 1 to 12 of 12

Thread: Dark Engine Fix (DEF) for Dual-Core/Hyperthreading

  1. #1
    Clearinghouse
    Registered: Aug 2002
    Location: Siberia, Russia

    Dark Engine Fix (DEF) for Dual-Core/Hyperthreading

    Thief (1, 2, 3) & System Shock 2 Patch FOR DUAL-CORE / HYPERTHREADING SYSTEMS.

    Symptoms:
    Thief (1, 2), System Shock 2 The system hangs after several seconds of playing.
    Thief 3 Intro movie cycles, no menu shown.

    Dark Engine Games (Thief: The Dark Project, Thief Gold, Thief 2: The Metal Age, System Shock 2), and their level editors - DromEd & ShockEd - doesn't work correctly on dual-core system (or imitated by Intel Hyperthreading function).

    This patch is also suitable for Thief Demo, Thief 2 Demo & Silent Hill 2.

    INSTALLATION

    Install into the game installation directory. The patch installs and executes
    MS Windows NT Image Configuration Utility, which modifies game executables' header to start on one core only.

    Original executables are copied into BACKUP_DEF folder
    (in the game installation dir). The utility is deleted after use.

    UNINSTALL

    Start Uninstall DEF. bat in BACKUP_DEF folder. Modified executables will be returned to their original state.

    Choose the game installation dir:




    Download DEF (Dark Engine Fix) ver.1.7

    Built by S.Siamsky, DJ Riff (Dark Fate Team), used information from ttlg.com & darkfate.ru

  2. #2
    Zombified
    Registered: Sep 2004
    exactly what I have been looking for.and the timing is perfect-just decided to upgrade (the second machine that is used to play all thief games) to dualcore.

    thanks

  3. #3
    bikerdude
    Guest
    Nice one Clearing

    Dual core fixing is part of DDfix now also..

    biker

  4. #4
    New Member
    Registered: Aug 2003
    Location: Denmark
    It's. Still. Not. Working.

    I have no idea what to do now.
    Can it be my VCL-player that messes up things? In the log I still find faults with "lgvid.ax". That has something to do with the movies in Thief, I read in the FAQ thread, but I keep installing the codecs with iv5play.exe, and can still not play the movies from the disc.
    Have been without Thief games since February. Help or suggestions appreciated.

    EDIT: Deleting the lgvid.ax file from the /thief directory worked. Still can't play the movies no matter what I do, but at least the game is working, and that's really something to cheer about.
    Tried removing the VCL player. Still no luck getting iv5play.exe to install the right codecs. It just starts looking for Netscape files, and nothing happens.
    Last edited by Cerebus; 20th Apr 2008 at 08:57.

  5. #5
    Zombified
    Registered: Sep 2004
    finally upgraded to dualcore,fixes works freat for me..just make sure the executables are not read-only before patching (t3.exe was read-only for some weird reasons,spent 10mins b*tching before I figured it out).

    btw,this should be in the (thief3,at least) FAQ.nice and painless..
    Last edited by voodoo47; 28th Apr 2008 at 17:20.

  6. #6
    Clearinghouse
    Registered: Aug 2002
    Location: Siberia, Russia
    Quote Originally Posted by voodoo47 View Post
    this should be in the (thief3,at least) FAQ.nice and painless..
    I agree.

  7. #7
    Zombified
    Registered: Sep 2004
    watch out,catalyst 8.6 breaks compatibility with this fix (black screen+lockup upon running fixed thief3).downgraded to 8.5,everything is ok..

    edit: X2 4400/x1950pro/xpsp2
    Last edited by voodoo47; 26th Jun 2008 at 16:16.

  8. #8
    Clearinghouse
    Registered: Aug 2002
    Location: Siberia, Russia
    Thanks, I will check.

  9. #9
    Member
    Registered: Dec 2005
    Location: London, UK
    The file is in a foreign language and I cannot read it because it is all ?????????'s! Also, my XP won't launch BAT files as it won't keep an association in file types, so I will have to check that on the web too!

  10. #10
    Member
    Registered: May 2002
    Location: UK, Suffolk
    GarrettLoader 1.42 has an ad-hoc Dual Core fix built in so it will correct the affinity of Thief 1,Gold,2 and System Shock 2 as they start via GL.
    This won't be out till late August though but works well on the dozen or so PCs I have tried it on.

  11. #11
    Member
    Registered: Dec 2005
    Location: London, UK
    Cheers, will keep an eye out for it..!

  12. #12
    Gave this a test drive just to see if it worked - I don't know if it's because I'm in XP x64, but this doesn't seem to have any effect or make changes on executables here...

    Which is ok though, since I already have imagecfg in my path and created a batch file called 'makesingle.bat' containing:

    Code:
    imagecfg -a 0x2 %1
    Which pretty much does the same thing.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •