TTLG|Thief|Bioshock|System Shock|Deus Ex|Mobile
Results 1 to 5 of 5

Thread: SOOOOO Frustrated! (troll idol quest)

  1. #1
    New Member
    Registered: Apr 2010

    SOOOOO Frustrated! (troll idol quest)

    ok early in the game, the troll idol quest. I have the stolen key from the troll (under his pillow) and I'm in the room with the chest the idol is supposed to be in but I can't get it to UNLOCK. I have the key on a keyring and maybe I'm not using it correctly (but double click, pick it up and click on the chest doesn't seem too hard) I've installed the patch and have tried every thing I can think of to open it, no luck. Maybe I didn't talk to someone first? I don't know, seems more of a glitch than anything else at this point. Thanks in advance for any help.

  2. #2
    Previously Important
    Registered: Nov 1999
    Location: Caer Weasel, Uelekevu
    Did you untrap the chest as well? I think there was a scroll or something in the King's drawer. That's the only thing I can think of that wouldn't be a bug / glitch. It's been so long since I played Arx, though... I don't remember if untrapping the chest would make a bit of difference unless it was a deliberately built-in mechanic to teach the player about traps and disarming them. Which I don't think it was, not that late in the intro.

  3. #3
    New Member
    Registered: Apr 2010
    I seem to have got stuck on the previous step of this same quest - getting the goblin king to let me go to the reservation room. I've got the note about the brotherhood but I'm not able to combine it with the king while he is sitting on the toilet. I did once get a hint from the game, something about 'not yet', so I tried delaying an extra time before approaching the king, but it made no difference. I thought I might have to give him something else first, but my PC's lockpicking skills are not enough to open the chest in the throne room. I even thought that Pog the troll king might give me something besides telling me about the idol and to go with Isak to the goblin gate, but I could not get anything more out of him either.

  4. #4
    Registered: Sep 2002
    Location: Texas
    Once I find the key under the pillow I get the king to the toilet by tainting his cakes. Then I only talk to him to get him to open the store room. I never had to give him anything. Yes use the scroll to dispell the trap on the chest there. Open with the key from under the pillow and retrieve the idol and fight.

    As for the chest in the throne room, I think it takes a higher pick skill. But if you want treasure just get the note from under the kings bed and use it in the throne room to open the treasury.

    You could also download the guide for extra help.

  5. #5
    New Member
    Registered: Apr 2011

    Disarming traps

    Traps on the chests and levers also can be disarmed with lockpicks(about floor panels I am not sure), if your mechanics skill is high enough. Also to avoid trap you can pull a lever or open a chest from afar with telekinesis spell.To see traps you must have either high mechanics skill(which is better), or high intuition skill. Not all traps are deadly. Some only hurts you. Magic fire traps(shining pentagrams on the floor) can be disarmed only magically.
    Last edited by Bustrofedon; 30th Apr 2011 at 15:16.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts