TTLG|Thief|Bioshock|System Shock|Deus Ex|Mobile
Page 36 of 40 FirstFirst ... 61116212631323334353637383940 LastLast
Results 876 to 900 of 989

Thread: Thief 2 FM: King's Story (released on April, 8, 2010)

  1. #876
    d. 2014
    Registered: Oct 2011
    Location: lancashire north of england

    kins story

    i played this last year, now i forgot where the bottle was, could someone please help,playing on easy

  2. #877
    Registered: Feb 2009
    Location: Situation's changed, Tom.
    I could tell you, I could also link to today's Fen video.

  3. #878
    d. 2014
    Registered: Oct 2011
    Location: lancashire north of england
    Quote Originally Posted by PotatoGuy View Post
    I could tell you, I could also link to today's Fen video.
    thanks a lot ,will try that,its this short term memory caused by chemo,which is good for the missions when i play them again,my wife has got used to it now,,

  4. #879
    Registered: Feb 2009
    Location: Situation's changed, Tom.
    That sucks man. =/ I guess it's a nice thing to not remember your previous playthroughs all too well and can have a great Thief experience, but still. Good luck with that.

  5. #880
    Registered: Aug 2002
    Location: Siberia, Russia
    Quote Originally Posted by Sagittal View Post
    Regarding the book: Were you able to read the title? M. Scrench. "Patriot"
    Means little to me but wondered if we all see the same?
    Maybe some fellow taffer will crack it
    Sagittal, spoiler: logo

  6. #881
    Registered: Aug 2008
    Location: UK
    Quote Originally Posted by clearing View Post
    Sagittal, spoiler: logo
    Thanks Clearing - not sure what made you resurrect my old post but thanks for the thought!

    ... will have another think but your spoiler's got me beat so far.

    I've dropped by once or twice recently and I enjoyed all FenPhoenix's vids the other month - reminded me what a great FM KS is.

  7. #882
    Registered: Jun 2007
    Location: Closer than you think
    Quote Originally Posted by warriorbabe View Post
    Sxerks, I had the same problem:
    There is a book describing Valet and his blue belt with the key, you have to read it, and then the guard, doctor and valet disappear from that room, instead the Valet appears on the first floor, have to get a key from him, it's ok to knock him out

    Sorry, have tried dozens of times.The valet,doctor and guard doe not dissapear from the room after reading the book.Reading the book triggers nothing.Playing on easy.

  8. #883
    Registered: May 2006
    Location: Russia
    There are several ways of walkthrough from the point. I recommend you the following.
    Find the short boring corridor between the Aide room and the Main tower (it has no number on the map, but the rooms are marked) and explore its ceiling carefully. Find a switch. Enter the secret passage, go ahead and trigger the coversation by your presence.

    BTW, persons in the room are:
    "Guard" = Aide;
    "Valet" = King;
    "Doctor" = Doctor.
    Be sure you HAVE read the book before going to find real Valet!

  9. #884
    I've seen this asked before in this thread, but I couldn't find a response:

    Is it possible to beat the 2nd mission on largo if you steal the crown?

    I've beaten the level on largo before, but after stealing the crown, I don't see how to satisfy the loot requirment.

    I've been *fairly* thorough in all accessible areas of the mansion, I feel. I'm sure there's some stuff I've missed, but I'm almost 1000 short of the 2300 goal. I don't think I've been *that* sloppy so as to miss such a large quantity of accessible loot.

    Has anyone successfully beaten the mission in this fashion?

  10. #885
    Registered: May 2006
    Location: Russia
    Of course it IS possible (but not easy). You have to find some secrets. You don't need to enter closed areas to beat the goal even on Largo.

  11. #886
    Registered: Nov 2006
    Location: New Jersey
    This has been a very good, but frustrating game. I'm actually quitting. I'm stuck here and there doesn't seem to be a way out.

    I'm at the doctor with the stable part. I'm playing on the hardest level. I've read several pages in this thread and don't feel like spoiling anything else trying to figure out what I'm doing wrong. From what I read, the doctor is supposed to show up when you shoe polish the horse. This is not the case. As soon as I open the stable is when the doctor comes. I then have to hurry to shoe polish the horse and hide. From what I think I'm supposed to do, I'm supposed to steal the doctor's bag from him so he can't unlock himself out of the stable. Problem I'm having is the bag is not frobbable, so my time runs out. I tried spraying him, knocking him out, shooting him with a gas arrow, locking him in, and nothing works. I give up.

    Any suggestions?


  12. #887
    Registered: Aug 2003
    Location: Jafaville New Zealand
    To start off with, you need to make sure the other door is locked. He comes down one set of stairs.

    You need to get his bag. In it is a key. Use it on the door. He should now be locked in.

  13. #888
    Registered: Nov 2006
    Location: New Jersey

    My game is definitely broken. Problem I see is that this should have been broken down into several missions. Doctor's bag is not frobbable. Both the gate and the door lock when the doctor is there, whether or not I'm in the room.

    It seems my objectives came back. It's telling me make sure the wedding happens, though there is a nice bit of blood in the bride's? room. Also, I'm assuming the chick with the white gown is the bride. She's definitely not dead. She's standing at the altar AND she is also standing in the hall outside where the bishop was residing, though he's gone. The aide is standing in the room with the doctor and king outside the aide room, and also inside where the ark is.

    Also, I knocked out Anger but can't eliminate him. Tried getting the elevator to crush him, threw him off a very tall balcony, beat him to a pulp 20 times and he remains unconscious.

    This mission has become a mess. I've spent a good 6 hours playing this, but am giving up on it. I may try going back a few saves and see if stuff changes.
    Last edited by Philflound; 23rd Jun 2012 at 23:46.

  14. #889
    Registered: Nov 2006
    Location: New Jersey

    Doctor's bag is definitely not frobbable so I give up.

  15. #890
    Registered: May 2006
    Location: Russia
    Can you send me your save files? E-mail is in profile.
    (Please use ZIP format only if you wish to pack files.)

  16. #891
    New Member
    Registered: Jan 2011
    The atmosphere is great, but the gameplay is really frustating. However, i managed to find the castle, on my own. Even knocked down that tree. Passed some guards, and now i am at a big wooden door, the castles entrance? Left and right you can climb up along the "bushes"; to the right, there are two windows, open, you can look inside. I see a lever! But..but...i cannot push the lever!

    What now????

  17. #892
    Registered: Apr 2003
    Location: Wales
    Tear your hair out? It is possible to mantle onto one of the angular walls that stand along the cliff edge. Fire an arrow in an arc through the window and you’ll trigger the lever.

    Taken from Ricebug's 2010 volume walkthroughs.

  18. #893
    New Member
    Registered: Jan 2011
    Thnks! Found out another, easier way.... behind the corner, downwards, their are two wooden crates! Bring them up, throw them under the window, jump up on them and shoot the lever, very easely!

    Anyway, with the help of the youtube video report of someone i am now almost at the end, and yes, again...stuck! Right after i nailed the docter at the stables, the King's video pops up, telling he wants the killer....oke! Two secs later....message...BODY Found! Game over!

    This is it, i have enough of it. It is just too frustating! Great mission, good story, but too many nagging issue's with the gameplay. No, i will not go back, search and move all those dead bodies to other "safe" locations. Thought i moved them "safe" already.

    This mission could be ACE, a full 10! But with all the mishaps, i cant give more then a 7.5 and i will not finish the game.

    ps: Tried once more, hidden the bodies well afaik. Now, i can play some longer after i locked the docter in the stable....but....GGrrrr.... BOdy Found! after a minute or so......omg :-(
    Last edited by Jediron; 12th Jul 2012 at 14:25.

  19. #894
    New Member
    Registered: Oct 2012
    This mission was certainly a unforgettable experience in both good way and bad way. First of all, design and aesthetic was beautiful, original and breathtaking. Especially first mission was interesting throughout all the way - gameplay was fun and just suitably difficult; scenery was probably the best mountain range you can get from Dark Engine. And the fact this complexity was pulled off in both missions is impressive on its own right. Admittedly, lots of custom content was present and it was of high quality. And scripted sequences were impressive when they worked adequately.

    But what I didn't care for was the obscure plot and puzzles in the second mission which necessitated looking hints and reloading. And overall there was a large selection of forced failure moments and interruptions to gameplay by camvator sequences. And to further this, quite a few situations were just on the uncomfortable zone where it is uncertain and unreliable if the game engine does what player intended.
    For example the dumb waiter sequence, hiding bodies, ledge outside the castle and shooting arrow to open the gate in the first mission.
    Overall I got the feeling of being transported decade backward in time to some adventure game where I am supposed to read the mind of the designer and work from there. And I have to admit preference to subtle ambient sounds and soudscapes, full blown background music is just too distracting and demands too much attention.

    Initially I wanted to test this mission on the New Dark since it is one of the most complex missions and it works very well, at least for me - and on linux on top of that. (bit off topic, but on linux the internal loader works as long as you uncompress fm's before playing). Only slowdown are at the most complex sceneries, otherwise it works very fluidly. Well, thanks to whoever made this mission, fun mission but frustrating at times.

  20. #895
    Quote Originally Posted by SlyFoxx View Post
    Step 1: Start download.
    Step 2: Order pizza.
    Step 3: Pick up pizza.
    Step 4: Eat pizza.
    Step 5: Play mission.

    It's always good to have a plan.
    hehehe Good shot

  21. #896
    Registered: Apr 2002
    Location: Malmö, Sweden
    I am loving the second mission so far (so beautiful!) but now I am stuck. Don't want to search or read the thread for fear of getting spoiled, hence I ask a question that has probably been answered already:

    I solved the problem with the dumbwaiter and I have ascended it. Some unknown benefactor opened the hatch at the top so I could rope up. Now I have a rather limited area I can move around in, and I wonder what I am missing. There are many locked doors, and the only keys I have are the 'passage key' and a brown key I took from a guard with a helmet.

    On the floor with the dumbwaiter exit, I can reach the main hall, two small side room with guests west of it, the aide's room, the valet's room and two guest rooms east of these. I can go down a spiral staircase and reach a dining room and two narrow side rooms (like on the floor above). I can go up the staircase and reach a small corridor with a locked door. (There is a suspicious-looking ventilation grate but I roped up there and didn't find anything useful).

    Further down the staircase, I can reach the bottom where there are two locked doors (I was probably on the other side before going up the dumbwaiter). There is a note here that mentions a key. I have banged on the door described and the key can be seen in the door (looking through the door to the northern spiral staircase) but I can't open the door to the staircase and I can't frob the key from any direction.

    There is a locked cupboard in the room with the two guests (one guest has a hat).

    (In a desperate attempt to try anything (now that I have a new key I can't find a lock for...), I tried jumping down the dumbwaiter shaft using a guard body to keep me from going splat but the shaft is too narrow so I can't drop the body.)

  22. #897
    Registered: May 2006
    Location: Russia
    Step 1:
    Break the glass door to see the sticked key better.
    Step 2:
    Shoot the key with an arrow (broadhead or rope if you wish) - glass will not block the shoot now.
    Step 3:
    Go to the door from the back side, open it and take the key on the floor.
    About locked cupboard: one character will give you a clue some later. If you don't want to wait, read the spoler below (it will not ruin the gameplay).
    Check the chandelier in the room with the cupboard very carefully.

  23. #898
    Registered: Apr 2002
    Location: Malmö, Sweden
    Thanks! On my way now.

  24. #899
    Registered: Apr 2002
    Location: Malmö, Sweden
    Finished. Missed a whole bunch of secrets (found only 5/13!) and 988 loot (so I barely had enough for the requirement).

    I messed up the triggering of conversations twice, but thanks to well-organized and many saves, I could correct this without much extra work.

    I can imagine it will be an even more enjoyable mission when I go back to it next time.

    BTW, the endgame was 'way out there' (and I never understood what Elizabeth´s ghost meant regarding the cargo lift. I was too busy trying to survive to be able to pay much attention...)

  25. #900
    Registered: Oct 2006
    Zontik, now with New Dark available do you plan to incorporate two missions with each other?

Page 36 of 40 FirstFirst ... 61116212631323334353637383940 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts