TTLG|Jukebox|Thief|Bioshock|System Shock|Deus Ex|Mobile
Results 1 to 23 of 23

Thread: Fix: Thief2 fails to load NVScript

  1. #1
    Desperately Dodgy Moderator
    Registered: Nov 2001
    Location: Bohn Museum

    Fix: Thief2 fails to load NVScript

    I've been battling this problem off and on for months. It seemed to come and go with Windows Defender definition updates, but I recently had the problem arise again a month after disabling Defender completely, when trying to play Haplo's new mission.

    Here are some important things to know about this problem:
    • This seems to only affect players running Vista or Win7. However, most people in Vista or W7 don't see the problem.
    • With most FMs, it's hard to know if this is happening. For one thing, many FMs don't use NVScript. But those that do, rely on it for very important things such as making objects frobbable or unfrobbable at certain times, or countless other scripted things.
    • Haplo's new FM, Among Two Storms, prohibits you from leaving the starting area if NVScript is not being loaded correctly by Thief2.exe. If you start a new mission and turn left, there will be a note tacked to the gate if the script module isn't loaded. Also, frobbing the inventory item to switch to Palmer will not do anything. So, ATS is ideal for easily testing to see if you have this problem.

    If you're having this problem, there are two potential fixes.
    1. Rename Thief2.exe to anything else, such as Thief 2.exe (add a space between the f and the 2). Note that this will break being able to launch Thief 2 from Darkloader - you will have to launch the renamed .exe manually, or via a shortcut on your desktop.
    2. The more thorough solution is to solve the actual root problem. On my PC, Microsoft had enabled a "program fix" for Thief2.exe called "GameUX" (whatever that means). Because it was tied to the application name, renaming the .exe avoids the problem.

    Here is the Microsoft article on the fix:
    You can follow the steps there, or use my condensed version, below:
    • Download the Application Compatibility Toolkit from Microsoft.
    • Once installed, run the Compatibility Administrator (32-bit) from your Start Menu. Note that you should run the 32-bit version even if your system is 64-bit. This is because it describes not the CA app itself, but rather what types of programs it will discover, and Thief is 32-bit.
    • Click the + to the left of Applications. It may take a minute to enumerate the list.
    • Type "Thief2" or scroll down and find Thief2.exe.
    • If you see GameUX under Compatibility Fixes under thief2.exe, then right-click on thief2.exe and select "Disable Entry".
    • Close the Compatibility Administrator and reboot your PC (this is required, the fix won't kick in unless you reboot).
    • Now you should be able to run Thief2.exe and it will load NVScript properly. Test it by starting a fresh mission on Among Two Storms.

    This worked for me but I'd like others to post here if they were having the problem and this solved it for them, or if it didn't. If at least a few other folks have this problem and fix it this way, and no one encounters new problems, it may be worth linking to this thread from the Thief Technical FAQ.

  2. #2
    Registered: May 2002
    Location: Between dreams and shadows...
    Quote Originally Posted by Yandros View Post
    "GameUX" (whatever that means).
    GameUX is part of the "Games Explorer" system in Vista and Win 7. What exactly it does under the hood, I don't know - details are kinda scarce - but it certainly appears to have enough features to cause problems (parental controls, controlling access to different game types).

  3. #3
    Registered: Jun 2001
    Location: Moscow
    I haven't experienced this problem myself, running Vista 32 bit, but it was worrying me that more and more people stumbled upon it. If that indeed fixes it, it's a big relief. Thanks for your efforts Yandros!

  4. #4
    Registered: Mar 2005
    Location: The Inverted Manse
    Great Discovery Yandros and NV! I hope this would bury the problem once and for all.

  5. #5
    Registered: Mar 2001
    Location: Ireland
    Ah, so the application compatibility toolkit idea paid off? Excellent!

    Is the GUID always the same, or does it change from computer to computer? According to the article I linked you to, that stuff is all stored in the registry, so it should be possible to save out a registry key to automatically disable the problematic compatibility setting
    (or to implement it into TafferPatcher).

    I'd still like to know why it only affects NVScript, though.

    Might actually be an idea to report this to Microsoft.

  6. #6
    Registered: Dec 2007
    Location: beyond belief
    Thanks for this, just started playing ATS and sure enough, up popped the sign!

  7. #7
    Registered: Jan 2009
    Location: Germany
    This is a great fix. It also prevents Windows to connect to the internet, if I fire up Thief.

  8. #8
    Registered: Nov 2007
    This also fixes the Rose Cottage V2 when you try to use a certain purple light source! I only used the renaming "Thief2.exe to Thief 2.exe though. I havent tried the 2nd method. But nevertheless, it works =D

  9. #9
    Registered: May 2001
    Location: Italy
    Probably also HoC2 has this problem. Great news Yandros.

  10. #10
    New Member
    Registered: Sep 2008
    I have been having problems with NVScript not loading, most recently with the FM Of The Sinister Awakening. Reloading it in Darkloader worked to get it running once but it failed the next several times I tried to load it. I tried renaming Thief2.exe and running the AC toolkit but no go. I am running in Vista 32 bit with DDfix 1.3.11. I also tried reloading NVScripts in case they had been corrupted.
    Anyone else not having luck with the AC toolkit?

  11. #11
    New Member
    Registered: Sep 2008
    Well, I tried both Among Two Storms and Of The Sinister Awakening this morning and both worked.
    When I had used the AC toolkit I had restarted my computer but not shut it all the way down. Maybe that made a difference?

    Thanks Yandros for finding this fix.

  12. #12
    Registered: Mar 2001
    Location: Ireland
    I'm going to post this here since most people don't read The Editor's Guild.

    I've been trying to reproduce this problem in a Windows 7 x86 virtual machine, but everything just worked fine for me there, just like on my "real" 64-bit install.

    Is there anyone who can consistently reproduce the problem who's willing to act as a guinea pig? Preferably someone who uses IRC or MSN, and has DromEd installed?

  13. #13
    Registered: May 2005
    Well, I did a few tests with 3 missions on my Windows 7 x86 Ultimate with the latest updates. If the sytem config counts this is:

    AMD Phenom II X4 905e
    4 GB DDR3 Ram
    nVidia GeForce 9600 GT

    Clean Thief2 with DDFX and Widescreen patches only.
    DarkLoader 4.1

    1st run by untouched Thief (no compatibility, no renamed exe):

    1. Hammerite Deathmatch - Not working.
    2. Temple of Tides - half opened doors on both ends of the starting corridor.
    3. my early beta mission with NVkeyring in the starting inventory - crash at mission load.

    2nd run renamed thief2.exe to thief 2.exe:

    1. HD - Works perfect
    2. ToT - half opened doors on both ends of the starting corridor.
    3. my mission - crash.

    3rd run after a computer RESTART and still the renamed exe:

    1. HD - Not working.
    2. ToT - wall blades on the other end of the corridor.
    3. my mission - works perfect.

    4th run after another restart and renamed back thief 2.exe to regular thief2.exe and switched over to WindowsXP SP3 compatibility mode:

    1. HD - Not working.
    2. ToT - wall blades on the other end of the corridor.
    3. my mission - crash.

    5th run after a computer restart with WinXP compatibility:

    1. HD - Not working.
    2. ToT - wall blades on the other end of the corridor.
    3. my mission - works perfect.

  14. #14
    Registered: Mar 2001
    Location: Ireland
    Quote Originally Posted by Sensut View Post
    2. Temple of Tides - half opened doors on both ends of the starting corridor.
    I take it this means "turning square working correctly"?
    Hmm, so that can still work even if other NVScript things don't? That rather invalidates my testing, as I was using the turning square as my benchmark.

    I suspect that your varying results may mean that the problem is... somewhat random, and only occurs some of the time.

  15. #15
    Registered: Mar 2001
    Location: Ireland
    I just tried Haplo's Among Two Storms in the virtual Windows 7 x86. I ran into a user error of getting stuck at the start, but not so much because of a problem with the scripts as that I didn't bother to read the mission text as I wasn't playing it, only testing it.

    NVScript presumably worked just fine, since the message that's supposed to be on the wall if it fails to load ... wasn't.

  16. #16
    Registered: May 2005
    The load is not wrong for me, according to Telliamed's version check. NVscript (or renamed), is there and is recognized by it, but not working... or something. A strange thing: my dromed is not touched (main Thief is not renamed and not switched to XP), and in Temple of Tides (loaded in dromed), the wall bledes are not working so I can walk through there, but in the regular game... as I mentioned above (or are there, or are not) .

    Edit: renamed the Dromed use thief2.exe to thief 2. exe, and the wall blades are there (as with the utouched exe), on the other end but not working.

    I do not understand it really what's going on here but as many tests so many results. This is a Win7x86 installed freshly though and I'm playing FM's T1 and T2 even T3, and I'm working with dromed daily on it without any other problems.
    Last edited by Sensut; 11th Nov 2010 at 17:25.

  17. #17
    Registered: May 2005
    Quote Originally Posted by Nameless Voice View Post
    I take it this means "turning square working correctly"?
    Hmm, so that can still work even if other NVScript things don't? That rather invalidates my testing, as I was using the turning square as my benchmark.

    I suspect that your varying results may mean that the problem is... somewhat random, and only occurs some of the time.
    I don't really remeber what's the regular start in that mission (the 2 doors or the blades on the end). Anyway the different tests results different positions for me.

    Later: I'm trying and i'm trying but vainly. I would be the happiest one if NVScripts would work on these platforms too.
    Last edited by Sensut; 11th Nov 2010 at 17:39.

  18. #18
    Registered: Mar 2001
    Location: Ireland
    Okay, going a bit off on a tangent here, but there's only one door. With NVScript, you get silently turned around halfway down the corridor; without, you can just walk straight to the room with the blades.

  19. #19
    Registered: Aug 2014
    Location: Erie, PA, USA
    This may be weird, but I was having the problem of finding the note at the beginning of "Among Two Storms" so couldn't play it at all.

    What fixed it was downloading GayleSaver's Custom Scripts and adding them to the main thief 2 directory. The script index is at and the specific .zip I downloaded was the

    I downloaded them for another FM, but I noticed that they fixed a number of FM's, "Among Two Storms" included. Again, it may seem weird, but it worked for me.

  20. #20
    I'm running windows 10 and never had this problem until now. I tried playing Among Two Storms, but i'll just see that note about the script problem.
    I also tried Amoral Dilemma. In the beginning, when the ai should put the key on the table, she does not. The ai does the motion, but the key does not appear on the table. I can hear here voice, but not the voice of Garrett.
    I tried a lot of things, nothing works. Re-installed the game, rename the .exe, nothing works. The Compatibility Administrator does not seem to work on win 10.

  21. #21
    Dóttirin klęšist oft móšur möttli
    Registered: Apr 2015
    -Delete old NVScript the FM folder
    -Delete old renamed NVScript the FM folder. In Among two Storms, it's NVS.osm
    -Put new NVScript in the root folder. Rename the script if necessary and put it in the FM folder as well. In this case: NVS.osm

  22. #22
    Thank you very much. Works perfectly, too bad i did not test that myself in the first place. Not a permanent fix, but it works.

  23. #23
    Registered: May 2002
    Location: Texas
    I haven't had any problems loading NVScript or ant other script on my Vista machine, but I have noticed that upon loading a mission dromed tells me that a script with a two character random name didn't load. Missions in dromed and Thief work fine though. The characters in the mentioned name are not alphanumeric.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts