TTLG|Thief|Bioshock|System Shock|Deus Ex|Mobile
Page 13 of 115 FirstFirst ... 389101112131415161718232833384348535863113 ... LastLast
Results 301 to 325 of 2855

Thread: TFix: unofficial patch for Thief1/Gold

  1. #301
    New Member
    Registered: Apr 2007
    Location: France
    Quote Originally Posted by The Mike View Post
    how do you go about turning on the new features 1.19 added, like improved mantling and HDR lighting?
    Quote Originally Posted by voodoo47 View Post
    advanced visual effects are not [enabled by default], and it will stay that way
    I'm pretty sure that The Mike was well aware that they are not enabled by default; and he was not suggesting that they should be, merely asking how he could activate them on his own computer. (I am also interested by the answer, actually).

    @ The Mike: note that some features of 1.19 only come into effect after recompiling the missions. Whether they are desirable or not is up to debate. cf previous page on this thread.

  2. #302
    Member
    Registered: May 2003
    Location: Normally I'm in the batcave.
    Yeah, Gamall is correct: the fact that all the pretty system-hoggish features are turned off is the problem- I really want to try them out. I kind of thought that mantling might have been on by default but it was hard to tell. Well, now I know...and knowing is half the battle......G.I. Joe....

    Also, I tried running it without Darkloader just now and it still tends to stutter pretty hard after saving. Oddly enough, I never have this problem with Thief 2 1.19.

  3. #303
    Zombified
    Registered: Sep 2004
    open cam_ext.cfg and try playing with the advanced options (removing the semicolon from the start of the line will activate the option):
    Code:
    ; enable 16-bit floating point render buffer (for improved rendering and postprocessing quality, at the
    ; expense of video memory and performance)
    ;d3d_disp_enable_hdr
    ; enable 32-bit floating point render buffer (if you don't know what else to do with your memory and GPU time)
    ; NOTE: some driver version(s) may have a bug where running 32-bit FP also requires multisampling to be enabled
    ;       or things can break (like a black screen)
    ;d3d_disp_enable_hdr 32
    
    
    ; enable software (ie. shader) based gamma and color processing (improves quality at the expense of performance,
    ; and also enables in-game gamma to be applied in windowed mode)
    ;d3d_disp_sw_cc
    
    ; optional saturation setting when "d3d_disp_sw_cc" is enabled, 0 is black and white, 1 is normal color
    ; (does not affect menu screens)
    ;d3d_disp_sw_cc_sat 0.25
    
    ; optional color filter when "d3d_disp_sw_cc", RGB values are between 0 and 1, default is "1 1 1" (white)
    ; (does not affect menu screens)
    ;d3d_disp_sw_cc_rgbfilter 1 0.7 0.3
    
    
    ; enable postprocessing (bloom)
    ;postprocess 1
    
    ; bloom intensity factor, default is 5
    ;bloomscale 5
    
    ; bloom/"glow" radius defined as percentage of the screen's diagonal, default is 2 (the larger values
    ; require more GPU processing)
    ;bloom_range 2
    
    ; bloom saturation, 0 completely desaturated, 1 is fully colored, default is 0.7
    ;bloom_saturation 0.7
    
    ; min value required (for R, G and B) in order for a pixel to be included in bloom processing, default is 0.6
    ; (with a low value a lot of surfaces will glow, with a high value only the really bright surfaces will glow)
    ; for SS2 you might want to consider increasing this slightly, as the game is generally brighter
    ;bloom_threshold 0.7
    as for the stutter, no idea why is it happening - but make sure you are not forcing anything via your gpu control panel.

  4. #304
    I'm going through Thief Gold with the 1.12 TFix patch (on a WinXP machine) and everything is running and working smoothly.

    But I have discovered one tiny little glitch, and I'm wondering whether this is TFix-related, or a bug left over from days of yore.

    In the Cragscleft prison, the buttons on the elevator controls are invisible on the bottom level (the one with the spider) until you frob them. They work, but the panel appears to have no functional buttons. Once you've frobbed them, they magically appear and remain visible. The buttons are visible on the elevator controls on the floors above.

    Thoughts?

  5. #305
    Zombified
    Registered: Sep 2004
    missing properties on the buttons = original bug (not related to TFix). fix (copy to the root folder). the next version of TFix will include this.
    Last edited by voodoo47; 24th Nov 2012 at 16:27.

  6. #306
    Awesome! Thanks very much, I'll check how it works when I have the time tomorrow.

    BTW, I did some investigating, and the glitch also applies to the buttons on the elevator controls on the third floor.

  7. #307
    Zombified
    Registered: Sep 2004
    correct. updated the fix (do note that you will have to restart the mission to activate the fix).

  8. #308
    Member
    Registered: May 2003
    Location: Normally I'm in the batcave.
    Thanks for the help voodoo! I was expecting to break stuff when I started messing around with the new cfg. file, but oddly enough, I actually got the game working better. No more stuttering and even the mouse lag I had in Thief 2 is gone. I couldn't tell you which lines did what as I was essentially blindly erasing the semicolons next to everything that sounded cool, so I apologize to anyone having similar problems to those I was having that are expecting some insight...

  9. #309
    Quote Originally Posted by voodoo47 View Post
    correct. updated the fix (do note that you will have to restart the mission to activate the fix).
    Just checking in to let you know that it works perfectly. :-)

  10. #310
    Member
    Registered: Aug 2003
    Location: Phoenix, AZ, USA, Earth
    Quote Originally Posted by Unkillable Cat View Post
    Just checking in to let you know that it works perfectly. :-)
    Same
    Klatremus' Supreme Thief Site - Walkthroughs, Loot Lists & Ghost Reports
    Let's Supreme Ghost Thief - YouTube Channel with Thief Let's Plays

  11. #311
    voodoo47: Since you seem to be fixing glitches, might I interest you in a couple of more?

    # In "Assassins", there's a readable scroll on the kitchen wall, but it's facing the wrong way, the front is facing the wall. Otherwise it works.

    # In that same mission, there's an area round the back of Ramirez' mansion where the "sound" doesn't carry, i.e. if you're inside this area, you can't hear noises coming from around you. It's the open area in the northeast of Ramirez' estate, the area where the guards walk around in a circle before heading back west. In the southwesten corner of this open area, the sound "sputters".

    EDIT: # In the "Thieves' Guild" mission, the scroll right outside the Overlord's Fancy (at the start) is also facing the wrong way as above.
    Last edited by Unkillable Cat; 25th Nov 2012 at 19:49.

  12. #312
    Zombified
    Registered: Sep 2004
    yeah, keep them coming. most of those are easy to fix (excluding that sound thing, that would require some advanced dromeding), but I just don't have the time to swoop around all the missions trying to find them.

    just drop me a zip with a screenshot of the issue with a (quick)save, and I'll fix it if I can.

  13. #313
    New Member
    Registered: Dec 2009
    I think the trees at the start of the LBW in The Sword have too large collision area (or are the trees too small?).
    And now I remember it, the textures of the tunnel leading to the spider cave in Lord Bafford's Manor seemed a bit odd - or was there supposed to be some kind of wooden reinforcements in them?

  14. #314
    voodoo47: Alright, but since I've found more issues since the last post, I'll just collect them all together as I play through the game, and then send the screenshots and info to you.

  15. #315
    New Member
    Registered: Nov 2012
    Still having a couple problems getting this game to run... I applied that patch and am now able to see the cutscenes but instead now am unable to see anything once it gets to the gameplay. This is with the exception of a tiny sliver in the upper right hand corner and whenever I press tab, I can still see my inventory. Also, Thief 2 is running perfectly with the patch installed. Any suggestions? Any help would be appreciated.

  16. #316
    Zombified
    Registered: Sep 2004
    ahh, intel drivers strike again. open cam_ext.cfg and change
    Code:
    multisampletype 8
    into
    Code:
    ;multisampletype 8
    Last edited by voodoo47; 26th Nov 2012 at 10:02.

  17. #317
    New Member
    Registered: Nov 2012
    Quote Originally Posted by voodoo47 View Post
    ahh, intel drivers strikes again. open cam_ext.cfg and change
    Code:
    multisampletype 8
    into
    Code:
    ;multisampletype 8
    Wow, thanks a ton! Never would have thought it would have been so simple.

  18. #318
    Member
    Registered: Apr 2003
    Location: Chula Vista, CA
    This patch is working well on 4 systems I have. Two are Pentium 4 based. See my post at top of page here:

    http://www.ttlg.com/forums/showthrea...140085&page=30

  19. #319
    Member
    Registered: Nov 2002
    Location: Central Texas
    Quote Originally Posted by Gamall View Post
    Hello,

    a friend of mine (Kafou) went to the trouble of recompiling all Thief Gold missions (TFix'ed version) to take full advantage of 1.19's 32-bit lightmaps. This significantly enhances the visual quality of shadows.

    I would suggest that the updated .mis files be included into TFix. For now, they are available at the following URL:

    http://thief.gamall-ida.com/

    Similar recompiled .mis files may follow for Thief 2.

    edit: I seem to have DNS problems with this sub-domain, for some reason; extra-temporary link to another location:
    http://gamall-ida.com/thief/Kafou_TG...bit_smooth.rar

    edit2: MD5:
    17263ee68e0e3fab4297951ad0b852ff Kafou_TG_Relighted_Missions_32-bit_smooth.rar
    Ran into a problem here. There are areas where the new lighting removes shadows that you can use. From what I've seen the shadws are still "there" you just cannot see them any more. A Prime example is in "Assassins". The 2 assassins go into a room on the first floor (cannot really follow them there, but once you get in they are there,) There is also a guard (with a key,) standing in the room turning semi-randomly. In the old lighting the four lights in the ceiling make a pattern on the floor showing you hints to a path you can take to get to the key in the next room over, and to get close enough to pick the key off of the guard's belt. With the re-light, those shadow patterns are now gone. If you happen to have memorized the patter, and are careful, you can still do it, but the visual aid is no longer present.

  20. #320
    New Member
    Registered: Dec 2009
    Another issue: Shouldn't you be able to disarm mines with lockpicks? It seems to be impossible now, I tried it a few times last night.

  21. #321
    Member
    Registered: Apr 2011
    Location: Montpellier, France
    You can't disable mines in T1.

  22. #322
    One other thing, earlier in this thread there was discussion about some lines and/or conversations not taking place. I would like to know more about this.

    In Lord Bafford's Manor, there are three servants who just stand there and do nothing, at least on Expert. On lower difficulty levels they seem to say something, correct?

    Garrett also says fewer things on higher difficulty levels, gives out fewer hints and such.

    Now my memory may be failing me, but I remember Garrett saying the line "You know you really can't take it with you... but I can" somewhere in the "Down in the Bonehoard" level while looting. I played through it, and never heard him speak that line. Am I mistaken? Does he speak it somewhere else?

    Someone must have compiled a list of Garrett's lines and where and when he speaks them. Wouldn't surprise me if it can be found on this forum in dusty threads. Can anyone help me?

  23. #323
    Member
    Registered: Nov 2003
    Location: Thief fan since ca. 1999
    Unless memory fails me, I've played Bafford's so many times that the only conversation that I think you may be referring to is the two servants in the basement. (Three servants? I don't recall there being three having a conversation.) I think it's a matter of getting there in time to hear it, as that conversation always worked. Then again, I don't know if it plays in all three difficulties, but I don't see why not. The only issue it did have was that the male servant would sort of cut off the female servant with his next line: "wouldn't New Market love that."

  24. #324
    jtr7
    Guest
    1. The servants are in the upstairs servants' quarters on the level with the kitchen and servant. The servant walking on the street enters through the front gate and proceeds upstairs to join the two standing there, unless his path is interrupted, of course, so there may be two or three once the player gets there. The servants don't seem to have their conversation unless the player takes a specific path first, and yeah, their lines overlap oddly, rather than play out fully one after the other. I'm not versed enough in DromEd to trace the variables, like control object 211. I started the mission in the nearby quarters with the sleeping servant on the bed, and walked over to the other two, and they didn't speak. I went through the kitchen and back and then they spoke, so I'm not sure where I triggered it.

    I have all the conversations per mission in general listed out, and all of Garrett's comments, but I never finished pinning Garrett's comments down to location and difficulty level and what triggers them, and I only have determined which conversations are used or not. Garrett has a lot of comments he never says, and there are a total of 70 conversations (including a lot of two-liners) never used in the Dark Engine Thiefs. TMA has broken conversations and a lot of unused readables. There's one mission that relocates conversations according to difficulty, while most are unaffected by difficulty entirely, and some are switched on or off per difficulty.

    TDP/Gold has a few conversations that are only triggered according to the player's path, and all the games have conversations and comments that can be switched off or on according to player actions.


    2. There is, indeed, a comment whose filename denotes use in the Bonehoard, mission 4, garm0405: "Whoa! You know you can't take it with you... But I can."

    I'll see if I can find out where it plays, if it does, but yeah, it exists in the game files and it was meant for the Bonehoard. The way he says it, somewhat surprised, I wonder if it follows after he's done something impressive or something impressive has happened, like being teleported after getting the Mystic's Heart and escaping behind the pedestal, or upon leaving the Bonehoard with the Horn of Quintus on Expert, but I can't find it, yet. I can confidently state that he can't say it without preceding player action, since there is no trigger connected to just being somewhere.


    Oh, and I've checked both TDP and Gold versions.
    Last edited by jtr7; 28th Nov 2012 at 22:52.

  25. #325
    Member
    Registered: Oct 2003
    Location: Finland
    I think that's the line Garrett speaks in Bonehoard after acquiring the Bow Upgrade.. - which is not an easy thing to do. Also explains why those words have been heard by only a few taffers..

Page 13 of 115 FirstFirst ... 389101112131415161718232833384348535863113 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •