TTLG|Thief|Bioshock|System Shock|Deus Ex|Mobile
Results 1 to 10 of 10

Thread: Modding question, source code.

  1. #1
    Registered: Jul 2002

    Modding question, source code.

    Found "ARX_Inventory.cpp" in DANAE/ if I'm reading this correctly is it possible to edit the number of Inventory spaces or possibly increasing the limit of 3 bags?

    It was a bit easier when I was modding Dark Messiah, not even sure where this file would go once edited since there is no mention of DANAE folder.

    Thanks for any help.

  2. #2
    Registered: Feb 2002
    You would have to recompile the game exec. Files with the .cpp extension are C++ source code.

    You would also have to change graph\obj3d\interactive\Items\Provisions\backpack\backpack.asl using ArxPak. I haven't tried just changing the limit in that script, no idea what would happen.

  3. #3
    Registered: Jul 2002
    Ouch that's alot just to add some spaces or bag totals, guess I'm glad they used the Source on DM. Seems I even remember there is a 4th bag (guess in case you miss one) would have been nice to at least try to change the total bags to 4.

    Thanks Ziusudra for your help with both my posts.

  4. #4
    Registered: Jul 2002
    Damn looks like they nuked Lord Inut's Bow in patch 1.21. In 1.18 it still had an AoE and didn't use up Arrows, now it's lost both of those effects.

    Any idea what how I could fix this or the name of the file to edit, other than reinstalling 1.18?

    Thanks for any tips.

  5. #5
    Registered: Feb 2002
    If it was changed in the script, the file is GRAPH\obj3d\interactive\Items\Weapons\Bow_Mx\Bow_Mx.asl.

    If it was changed in the source, I would guess somewhere in danae, maybe arx_equipment.

    Either way, I don't know what exactly changed.

  6. #6
    Registered: Jul 2002
    Thanks very much Ziusudra.

    I might be wrong about the Inut's bow not using arrows, but I'm about 90% there used to be an Area of Effect from the Fireball arrows. Now the Fireball arrows do no AoE, I shot at least 4 arrows (mere inches, no more than a foot) near a normal rat Crypt level 1. The rat just kept coming until had a direct hit. Tried this on at least two different Rats.

    Second problem I noticed with 1.21 when you start the Temple of Illusions the first two Snake women statues used to come alive when you tried to go down the first steps, now they did not.

    There was also another place something didn't spawn correctly, though I'm too tired to remember atm. The last game I played was with patch 1.18 a year or two ago, had 1.19 patch but heard about lots of problems so never installed it.

    They seemed to have made it impossible to kill the Invisible man the first time you see him near the start. Right after you get the first Golden idle by shooting the arrow, then you cast Revel to find the correct switch. Before you could sneak up to the corner and peak around to see the Invisible Man without him walking away. Usually it would take about 100 arrows to kill him but you got about 100,000 xp. I shot him at least 150 times with the Inut Bow, unless the nuke iis causing it not to do as much damage as a normal arrow now, maybe I will check it.

    Remembered wrong, the Snake women didn't come alive till the end of the trial, not the beginning.
    Last edited by Acleacius; 7th Mar 2011 at 11:29.

  7. #7
    New Member
    Registered: Apr 2011
    Hello, my friends! Can somebody help me to obtain a DANAE editor? Please post a link to download it, or send a link to me by e-mail. I want to try to mod this great game, but all what I have is ArxPack 508, which doesn't allow to add to the game not only customary, but even already existing items in the new places.
    Plaease forgive me my poor English.
    My e-mail:
    Last edited by Bustrofedon; 2nd Apr 2011 at 16:01.

  8. #8

  9. #9
    New Member
    Registered: Apr 2011
    I downloaded ArxFatalis_1.21_Sources, but I don't know what to do with it! There are no Danae.exe in archive! Maybe somebody can give me advise, please?

  10. #10
    It's source code; it needs to be compiled into an executable. If that's not something you have any experience with, then you might be better off searching to see if anyone is hosting pre-compiled versions.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts