TTLG|Thief|Bioshock|System Shock|Deus Ex|Mobile
Results 1 to 12 of 12

Thread: Thief II too dark at max gamma

  1. #1
    Member
    Registered: Oct 2013

    Thief II too dark at max gamma

    I am playing a thief game for the first time in two and a half years - TMA - but even at max gamma the game is way too dark.

    I have played thief 1 or 2 about 5 times since 2002 across a few different PCs and monitors, and I never had to play with max gamma before - is this something to do with the tafferpatch or t2tool, which I am using for the first time? I have tried both and taffer is slightly brighter at max gamma, but still not enough.

    Also NVidia's own brightness and gamma options do not seem to work in games.

    Any ideas?

    TIA.

  2. #2
    Member
    Registered: May 2008
    I used to have this problem, Cam.cgf has a gamma option which you can increase beyond the ingame limits.

    However New dark (1.19, 1.20, 1.21) has greater gamma range if I remember correctly.
    New Dark thread is here http://www.ttlg.com/forums/showthread.php?t=140085

  3. #3
    Zombified
    Registered: Sep 2004
    edit cam_ext.cfg and remove ; from the beginning of the line with d3d_disp_no_rgb10_buf. see whether that helps.


    optimus laptop maybe?

  4. #4
    Member
    Registered: Oct 2013
    Thanks for the suggestions, both worked.

    Editing the gamma value in cam.cfg does the trick although oddly the lower the value the brighter the game is. At max in-game gamma the value in the file is 0.5 and changing it to 0.46 provided adequate brightness. Problem with this method is that if you attempt to change gamma in-game, or perhaps even just by opening the video tab in the options screen, the gamma is reset so that it is at least 0.5 once more. Meaning that the file has to be re-edited to re-enable the brightness.

    Altering the suggested line in cam_ext.cfg also did the trick and allows you to change in-game gamma and visit the video options without losing anything, so I'll use this method. Not sure what other graphical effects I am losing by changing this option, but it is simpler.

    Now if only there was a line somewhere in a cfg file for Alan Wake, which was also too dark at max in-game brightness.

  5. #5
    Member
    Registered: Oct 2013
    Quote Originally Posted by voodoo47 View Post
    optimus laptop maybe?
    No, new desktop PC with a Nvidia card.

  6. #6
    Zombified
    Registered: Sep 2004
    Quote Originally Posted by Cigam View Post
    Not sure what other graphical effects I am losing by changing this option, but it is simpler.
    you are losing sky smoothing.

  7. #7
    Member
    Registered: Nov 2003
    Location: Thief fan since ca. 1999
    Thief 2 too dark in the shadows - can't really see anything

    Sorry to revive such an old thread but I can't seem to find a solution to my problem. I've looked around and most of the suggestions I see revolve around NewDark and modifying "cam_ext.cfg", which I don't have. I know people will suggest using NewDark but I am intentionally NOT using NewDark for this specific case because the Thief 2 multiplayer patch is not compatible with NewDark. (I also have NewDark as a separate install but I am also trying to play Thief 2 multiplayer on this machine.)

    So, I'm using Windows 10 Pro, Thief 1.18 (with t2mp installed), ddfix applied with screen res at 1280 x 1024.

    In-game gamma slider does not work. Suggestion I see online is to change gamma from within cam.cfg. Changing "gamma" in cam.cfg to "gamma 0.2" from "gamma 0.5" seems to have no effect whatsoever.

    I have an Nvidia Geforce GTX 960 graphics card, CPU i5-6600k 3.5GHZ
    My Thief FM Website
    "Those pies had enough grease to drop a Burrick!"

  8. #8
    Dóttirin klęšist oft móšur möttli
    Registered: Apr 2015
    Try +/- keys (not keypad)
    Isn't there also a setting in ddfix.ini to enable gamma?

  9. #9
    Member
    Registered: Nov 2003
    Location: Thief fan since ca. 1999
    There is but that didn't seem to actually change anything. This:
    Code:
    ;Enable gamma correction. Boolean. (Default 1.)
    EnableGamma=1
    I know Thief has a gamma "increase" and "decrease" button, which it looks like you are suggesting above but mine are set to "[" and "]" I believe. I seem to recall trying that too with no result.

  10. #10
    Member
    Registered: Mar 2015
    The reason the gamma is not working is due to how Windows 10 handles DirectDraw and incompatibility with some modern graphics card drivers.

    If you are running the game with ddfix, one solution would be to add the line "ModulateShift=1" in ddfix.ini or modify the existing value, which is usually zero.
    While it doesn't necessarily enable gamma, it should make the game bright enough to see everything and is an easy solution that does not involve downloading any additional software.

    There is also another solution that should allow you to change gamma in-game. You would need to download a wrapper that could translate many of the API calls to work properly on a modern operating system.
    One that comes to mind is DDrawCompat. Downloading version 0.2.1 from the releases page and placing the downloaded "ddraw.dll" into your Thief 2 installation directory should allow gamma to work as intended.

  11. #11
    ZylonBane
    Registered: Sep 2000
    Location: ZylonBane
    Quote Originally Posted by sNeaksieGarrett View Post
    I know Thief has a gamma "increase" and "decrease" button, which it looks like you are suggesting above but mine are set to "[" and "]" I believe.
    Those are the mechanical eye zoom keys.

  12. #12
    Member
    Registered: Nov 2003
    Location: Thief fan since ca. 1999
    Thanks Jax! I'll have to look into those options.

    Zylon: I'm not sure why I even mentioned "[" and "]" as I just double checked the key config in thief 2 and nothing is set to use those keys. The zoom in/zoom out of Garrett's eye is actually set to "," and "."


    Update:

    That did the trick with the ddraw.dll download. Thanks so much Jax. Maybe this will help some other folks who are in the same boat. By the way, adding ModulateShift=1 to my ddfix.ini had no effect.
    Last edited by sNeaksieGarrett; 5th Jan 2019 at 01:57. Reason: update after initial post

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •