TTLG|Thief|Bioshock|System Shock|Deus Ex|Mobile
Page 15 of 15 FirstFirst ... 5101112131415
Results 351 to 363 of 363

Thread: T2 FM: Death's Turbid Veil (2nd September 2014)

  1. #351
    Member
    Registered: Dec 2004
    Location: Germany
    According to my notes, that button opens the gate into the mine. This is not the way you came in, but another way out.

  2. #352
    Member
    Registered: Jan 2006
    Location: On the tip of your tongue.
    Yeah, you should see another white stone door open when that button is pushed.

  3. #353
    Member
    Registered: Jan 2014
    Quote Originally Posted by nicked View Post
    Yeah, you should see another white stone door open when that button is pushed.
    That's the problem, if you're referring to the door from the "South" in the compass, it doesn't open.

  4. #354
    Member
    Registered: Jan 2006
    Location: On the tip of your tongue.
    I thought it was north but I could be wrong. Edit: I am wrong, it is South.

    I've never heard of this breaking at this point before - it's just a bog-standard controldevice link. Did you drop anything on the ground that might have blocked the door? Edit: Don't think that can be it - I just tried that in editor and it didn't permanently block the door.

    If you want to PM me a save, I can have a look.
    Last edited by nicked; 12th Dec 2019 at 09:20.

  5. #355
    Member
    Registered: Jan 2014
    The button is on the top, south-east, right? This should open the decorated 'door' to the south, but it doesn't. I'm only repeating that to be more concise.

    I have no idea either as to why it wouldn't work, I loaded another save making sure there's not another object anywhere near it, just in case it is problem #2 even though you mentioned it's not possible.

    I'll sent you the saves, I like this Fm, really wanna continue it, not get trapped by some strange bug.

  6. #356
    Member
    Registered: Jan 2006
    Location: On the tip of your tongue.
    OK I got your saves but the button works perfectly fine for me when loading your saves.

    This suggests that something is wrong with either your game or mission install. You said piano sounds weren't working either - just checked and those are also just standard ControlDevice -> Sound Trap.

    I would suggest double checking your versions of the script osms, as this seems like something fundamental has broken.

    Apart from that, without seeing your install folder itself, I can only suggest try redownloading the mission file, or reinstalling the game.

  7. #357
    Member
    Registered: Jan 2014
    Quote Originally Posted by nicked View Post
    OK I got your saves but the button works perfectly fine for me when loading your saves.

    This suggests that something is wrong with either your game or mission install. You said piano sounds weren't working either - just checked and those are also just standard ControlDevice -> Sound Trap.

    I would suggest double checking your versions of the script osms, as this seems like something fundamental has broken.

    Apart from that, without seeing your install folder itself, I can only suggest try redownloading the mission file, or reinstalling the game.
    Considering this, how can I know that the button works? It moves the door from the South slowly by sliding, makes a noise/sound?

    How can I check my "script osms"?

    Also, could it be that I'm using T2Patch instead of Tafferpatcher? Don't both come with custom scripts, anyway?

  8. #358
    Member
    Registered: Jan 2006
    Location: On the tip of your tongue.
    Yeah if everything was installed right, you should have the right base scripts, and the mission is packaged with NVScript and tnhscript. I can't remember what date the right version of gen.osm should be, but there are some old ones with some versions of the game iirc.

    Tafferpatcher is out of date - I believe this is the latest install you want for T2Fix: https://www.ttlg.com/forums/showthread.php?t=149669

    If the door works, it should end in this position (with audible stone grinding sound):
    https://drive.google.com/file/d/1rCE...tzCj4dGQF/view

  9. #359
    New Member
    Registered: Nov 2015
    I am currently replaying this mission, and i have the same problem as Necrohowl. Pressing the button does nothing. i am using latest t2fix 1.27a,

  10. #360
    Member
    Registered: Mar 2015
    If either of you is playing with Thief 2 Multiplayer installed, I would advise you to either uninstall that component to play this mission or follow the directions in this post. As is detailed there, the multiplayer OSMs break the StdButton script. Because this mission loads miss12.osm, this script does not function with multiplayer installed. Unfortunately, this is out of my control as I did not develop the NewDark multiplayer release.

  11. #361
    Member
    Registered: Jan 2006
    Location: On the tip of your tongue.
    Oh interesting - that might explain why the piano broke as well...

  12. #362
    New Member
    Registered: Nov 2015
    Quote Originally Posted by Jax64 View Post
    If either of you is playing with Thief 2 Multiplayer installed, I would advise you to either uninstall that component to play this mission or follow the directions in this post. As is detailed there, the multiplayer OSMs break the StdButton script. Because this mission loads miss12.osm, this script does not function with multiplayer installed. Unfortunately, this is out of my control as I did not develop the NewDark multiplayer release.
    Thanks jax64, it worked.

  13. #363
    Member
    Registered: Jan 2014
    Quote Originally Posted by Jax64 View Post
    If either of you is playing with Thief 2 Multiplayer installed, I would advise you to either uninstall that component to play this mission or follow the directions in this post. As is detailed there, the multiplayer OSMs break the StdButton script. Because this mission loads miss12.osm, this script does not function with multiplayer installed. Unfortunately, this is out of my control as I did not develop the NewDark multiplayer release.
    I did install T2M to try it out, never got the chance. Tried the fix you mentioned in the thread, didn't work.

    I just went and reinstalled my T2Fix to the latest 1.27a (used to be just 1.27), this time without the Thief MP feature.

    It works, including the piano not emitting sounds.

Page 15 of 15 FirstFirst ... 5101112131415

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •