TTLG|Jukebox|Thief|Bioshock|System Shock|Deus Ex|Mobile
Results 1 to 13 of 13

Thread: LootHunter: A basic tool for finding loot and keys

  1. #1
    Sneaky Upgrader
    Registered: May 2007

    LootHunter: A basic tool for finding loot and keys

    LootHunter is a crude tool made for a purpose - fortuni's walkthrough project. But now that it's done, it may as well be public. I don't consider it part of the SU, and it will only be updated occasionally (apart from bug fixes).

    Version 1.1.8 added an arrow-finding mode, and keys now toggle the modes on/off. Version 1.1.10 fixes an issue where creating desktop icons could fail.

    It's based on the SU Editor Edition version of T3MainOptVersion.exe. Because that version doesn't have support for FMSel, the LootHunter plays it safe by making a copy of your game installation and copying in an in-progress FM on top of that. (There are installer options for T3 Gold and the original game too, for completeness.)

    The most needed console commands have been renamed for convenience: Type 'loot' to toggle loot/keys display, 'fly' and 'land' to move through geometry, like in the video example here.
    Last edited by snobel; 11th Jun 2019 at 03:38.
    Widescreen and tweaks patches: The Sneaky Upgrade for Thief 3, the Visible Upgrade for Deus Ex 2

  2. #2
    Registered: May 2005
    LootHunter saved me from having to replay a mission when I couldn't find a key that had dropped from the belt of an AI I had knocked out earlier. Thank you for creating the tool!

  3. #3
    Registered: Jul 2022
    Doesn't seem to be compatible with the Sneaky Upgrade though, or am I doing something wrong?

  4. #4
    Sneaky Upgrader
    Registered: May 2007
    It's not compatible. (But you can copy savegames made with LootHunter into your game install)

  5. #5
    Registered: Jul 2022
    Any way to make my savegames from the Sneaky Patch compatible with the original Thief 3?

  6. #6
    Sneaky Upgrader
    Registered: May 2007
    If you made a save while the gameplay part of the Minimalist Project and/or Thief 3 Gold were enabled, then it's not compatible. All other saves are compatible.

  7. #7
    Registered: May 2005
    I must be missing something really obvious: How do I run LootHunter? I recently re-installed the tool because I am playing a unfinished mission for which there is no walkthrough. It ran fine immediately after the installation. But when I wanted to load the same mission through LootHunter a second time, I could not find an .exe for LootHunter anywhere on my system. The ReadMe.pdf says "Launch the game from the installer". What am I missing?

  8. #8
    Sneaky Upgrader
    Registered: May 2007
    There should be an icon on your desktop - unless you de-selected that option while installing. It's a dark blue version of the Thief 3 glyph icon. Failing that, look in the System subfolder of where you installed it. The LootHunter install is basically a special Thief 3 install, so the exe is named T3Main.exe - not LootHunter.exe or similar, and not Thief3.exe, which is the patched game exe that comes with the Sneaky Upgrade.

    The ReadMe.pdf says "Launch the game from the installer". What am I missing?
    I don't have the readme here, so I can't tell you what I meant by that. You should be able to launch it like any other executable.

  9. #9
    Registered: May 2005
    Thank for your the reply. It seems I have a problem with the app.

    1. I am on Windows 11.
    2. LootHunter is installed in C:\Users\[myusername]\T3LootHunter\.
    3. When I run C:\Users\[myusername]\T3LootHunter\System\T3Main.exe, it seems to load the fan mission I last loaded through FMsel. I can tell by the custom loading screen of the mission.
    4. From the custom loading screen of the mission, the game switches to the main menu.
    5. When I start a new game from the main menu or load either one of my existing hard saves or a quick saves, the program immediately crashes back to the desktop.
    6. On the desktop, FMsel is open, even if I did not previously open it.
    7. When I load the mission from here through FMsel, it starts normally, but I don't get the LootHunter functionality.

    Do you have an idea what else I could try?

  10. #10
    Sneaky Upgrader
    Registered: May 2007
    It sounds like something is wrong. What did you select when you installed it? If you selected an FM, then that's what will run. But a custom loading screen followed by the main menu doesn't sound right. And the saves should work, of course.

    FMSel shouldn't be involved at all. If you pick an FM, the installation is set up more like GarrettLoader/DarkLoader used to do - copying a bunch of files into a game install. Except with the LootHunter it's a copy of your game install, to avoid messing up the real install. FMSel runs through the patched game exe from the real SU, Thief3.exe. It doesn't work with the LootHunter version of T3Main.exe. So if you see FMSel, then Thief3.exe got run somehow.

    Try running the LH installer again. Pick that FM again, see if you get the same weirdness. If you do, please post which FM it is.

  11. #11
    Registered: May 2005
    When I install LootHunter, I choose the option to run an FM. Directly after the installation, LootHunter successfully loads into that FM. Loading my savegames also works. But if I exit the game and then try to run LootHunter again via T3Main.exe, what I described in my last post happens: LootHunter crashes to the desktop, where FMsel is open.

    Uninstalling and reinstalling Loothunter does not change the described behavior. (Same FM selected during both installations.)

    Since the FM I have problems with has not been officially published, I will send you the name of the FM via personal message.

  12. #12
    New Member
    Registered: Apr 2023
    Does Loothunter give options like unlimited items and ammo?

  13. #13
    Sneaky Upgrader
    Registered: May 2007
    Some of the console commands may be usable for your 'training' purposes...

    • "god player" - makes you invulnerable
    • "all weapons" - gives you a lot of arrows etc but only up to the carry limit. Repeat to replenish
    • "enable all upgrades" - gives you upgrades like the climbing gloves

    The key to enable the console is the one to the right of L on my keyboard. For others it's the one below Esc.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts