TTLG|Thief|Bioshock|System Shock|Deus Ex|Mobile
Page 7 of 7 FirstFirst ... 234567
Results 151 to 158 of 158

Thread: Visible Upgrade: Unofficial patch for Deus Ex 2

  1. #151
    Sneaky Upgrader
    Registered: May 2007
    Here's a beta with borderless windowed mode. Because the 'direct load' option has not been ported, the desktop will be visible during level changes. The installer is an Update Edition, so keep the texture pack from 1.2.0.

    Now that I'm at it, I'll try to get a bit more done on the VU over the holidays, and hopefully get at least an official beta out.

    The screenshot - can you do one in detail view, sorted by name, for a case where you have more than two DX2-related processes?

  2. #152
    Registered: May 2010
    Wow, that's awesome, thanks a lot for that!

    Regarding the screenshot: I'll do one when I played a bit and then exit the game, that's usually the occasion where the several processes turn up.

  3. #153
    Registered: May 2010
    The borderless window mode works nicely. I haven't run into the multiple processes thing yet, but, I can't exit the game without the game not responding anymore.

    Edit: Just had a crash when I wanted to travel to the WTO terminal. It showed 2x the DX2Main.exe process not responding in the task manager, see the screenshot.

    Edit 2: Dang... looks like it ALWAYS crashes when I try to travel to the WTO air terminal... it crashes while loading the new area.
    Last edited by chk772; 23rd Dec 2019 at 13:58.

  4. #154
    Sneaky Upgrader
    Registered: May 2007
    If you haven't already, definitely try disabling AV, then do a proper reboot. (AV and unknown issues from long-running Windows are the main things that can interfere with the game relaunching itself at level transitions.)

    Is that crash limited to one specific save, or is it a general thing?

    Edit: I'm going over the thread to note down old bug reports, and here is someone having an issue similar to yours. Except that the solution - disabling shadowplay - didn't work for you. But I wonder if there's some other overlay-type thing interfering? Have you tried disabling the Windows 'game bar'?
    Last edited by snobel; 24th Dec 2019 at 06:55.

  5. #155
    Registered: May 2010
    I just tried: disabling Windows Defender, no change, the game still crashes every time I try to travel to the WTO air terminal; disabling the game bar, no change, still crashing; disabling Shadowplay again, still crashing; disabled both the game bar and Shadowplay, and deactivated Windows Defender, no change, still crashing.

    If that helps: The crash is on the loading screen of the new area, at about 2/3 to 3/4 of the loading bar. I can't really tell whether or not it's savegame specific, as it's the only savegame I have. If you want, I can upload the savegame.

  6. #156
    Sneaky Upgrader
    Registered: May 2007
    If you can start a new game, then it's probably that one save which is corrupt - not likely fixable, unfortunately.

    Edit: Please do upload it to confirm.

    Disabling all the stuff could help with fullscreen, and/or the crash or hang on exit - please try that too.

    Edit 2: Disable Logitech Gaming Software too, if you have it.
    Last edited by snobel; 24th Dec 2019 at 07:56.

  7. #157
    Registered: May 2010
    Here is the link to the savegame: I uploaded the whole SaveGames folder, because I wasn't sure which one is the quicksave.

    Oh, and, I already tried it after disabling the Logitech Gaming Software, which, at least for the fullscreen issue, didn't solve. I'll try again with the crash issue though, thanks for the tip.

  8. #158
    Sneaky Upgrader
    Registered: May 2007
    That save is working fine for me. I tried it with the GOG version and the European DVD version of the game (I don't have the Steam version). Also, my Win10 is two feature updates behind, as I'm unable to upgrade past 1809 because 0xc190012e... So if it's Windows messing things up, then I probably can't reproduce it.

    You can try uploading your options files (Options.ini and VisibleOptions.ini) so that I can try it again with your settings.

    Also, if you have the in-game multisampling option set at anything other than 1, then be sure to set it to 1 until you've resolved these issues. (That setting has caused lots of weird behaviour for T3 on Win10, may well be the case here too.)

Page 7 of 7 FirstFirst ... 234567

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts