TTLG|Thief|Bioshock|System Shock|Deus Ex|Mobile
Results 1 to 3 of 3

Thread: Combo lock only works if you haven't loaded a save...?

  1. #1
    Member
    Registered: May 2017
    Location: USA

    Combo lock only works if you haven't loaded a save...?

    I'm having a heckuvalotta trouble rigging up a [rather complicated, I'll admit] combo lock.

    The gist is that there are a bunch of switches that light up when frobbed. You have to have the correct ones lit. I ran into an issue where the first frob was toggling the light, but wasn't actually toggling the state for the control device. In response, I set up an NVRelayTrap that toggles each switch twice at the start (does it also do this after each load?) Then I inverted the required combo, since technically now all the unlit switches are sending the 'on' signal.

    It works beautifully if I fire it up in DromEd, and it works just as well if I load it through FMSelect and ironman my way there. But if I load a save game even once, the lock becomes unresponsive. The lights still behave as they should, but they won't perform their control device job. This is true regardless of how many times I load (i.e., not an even vs. odd thing). Any thoughts why this might be and what I can do about it?

    It's curious, because I have another lock set up similarly, but without the AnimLight stuff, and that one's never given me trouble.

  2. #2
    Member
    Registered: May 2017
    Location: USA
    To make sure that it really is the loading of a save that gums it up, I ran the following test: I opened the mission in FM select and ironmanned my way to the switches. Entered the right combo, and saved as the gate was going up. When I load that save, the gate starts to fall immediately.

    For reference, here's my design note. The first argument is for the self-frobbing light toggle, the rest is to flip the switch twice at the start:

    NVFrobToggleTDest="[Me]";NVRelayTrapOn="Sim"; NVRelayTrapOff="Null"; NVRelayTrapCount=1; NVRelayTrapTOn="FrobWorldEnd"; NVRelayTrapRepeat=2; NVRelayTrapTDest="[me]"; NVRelayTrapDelay=500;
    Last edited by trefoilknot; 9th Sep 2017 at 10:42.

  3. #3
    Member
    Registered: Aug 2007
    Location: LosAngeles: Between Amusements
    Try putting NVSpy on the object and then see what messages get sent on loading the save.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •