TTLG|Jukebox|Thief|Bioshock|System Shock|Deus Ex|Mobile
Page 1 of 2 12 LastLast
Results 1 to 25 of 28

Thread: Rambling about Arx

  1. #1

    Rambling about Arx

    First off, new around these parts, so hello everyone!

    So anyway, like the title says, I'm playing Arx Fatalis (GoG version 1.21) for the first time and have couple questions:

    1st - I notice detail textures only become visible when I get close to the textures(wall, floor, ceiling, etc.) - is there a way to force them 'on' no matter how far away I am, or at least double the distance that they become noticeable?

    2nd - I found a shield, how do I block? lol... Seriously, I don't know how...

    That's all for now!

    Edit: Forget about the detail texture question. I did some experimenting and certain objects look really bad when the detail tex kicks in(like the two small statues in the left-hand corridor in the Arx castle)...
    Last edited by curseofnight; 22nd Oct 2017 at 17:15.

  2. #2

    Regarding the first question, I would highly recommend using which I think is almost certainly the preferred way to play Arx nowadays on any platform, due to the sheer number of bug fixes and compatibility improvements.

    I'll have to leave question 2 to someone else, as I simply don't have the game installed right now :)

  3. #3
    New Member
    Registered: Jan 2014
    Quote Originally Posted by curseofnight View Post
    2nd - I found a shield, how do I block?
    You can't block, there is no button for that. I guess shields add to your defense, maybe they do block some damage but it's automatic.

  4. #4
    @ losing myself - thx for the answer, even if it's one I don't like.

    @ Shadowcat - thx for the greets! I've already tried Arx Libertatis. It doesn't support detail textures at all so to my eyes it looked worse than the regular game. I just walked around the cell in the beginning, however. I didn't explore so I can't comment on lighting, shadows, etc. I still have it on my harddrive though, plus I'm keeping back-ups of all my saves so if I do come across a major glitch I can fire it up and continue on.

    The only glitch/bug I've seen so far was the first time I used a bow; all the NPCs started playing their animations at lightspeed, lol. I believe I read that it only happens with a certain bow type though and reloading my save fixed it.

    Edit: Oh, there's the walking glitch too I guess. But TBH, without a sprint button those random bursts of speed come in handy, hehe.
    Last edited by curseofnight; 24th Oct 2017 at 11:19. Reason: Remembered another glitch...

  5. #5
    New Member
    Registered: Oct 2017
    Shield automatically adds to your defense.
    As to high resolution textures, try to install some mods, i.e. Arx Insanity mod.

  6. #6
    Quote Originally Posted by curseofnight View Post
    I've already tried Arx Libertatis. It doesn't support detail textures at all so to my eyes it looked worse than the regular game.
    Oh, I misunderstood. I thought you'd run into the old bug where some things were untextured.

  7. #7
    @ WhiskeyBob - Thx for confirmation about the shields. Hopefully Insanity will be released by the time I get to my next playthrough. I went with a (mostly) melee build for my first charcter. I'm at the part where you investigate the Akbaa Cult in the Tavern's basement. Just laid waste to a Golem! That wraith or whatever in the other room laid waste to me, unfortunately, hehe.

    @ Shadowcat - I read about that bug, but I haven't seen it, or any other graphics related bug(so far). I tend to do a little research before I play old games and once I saw that Arx doesn't like newer hardware/OSs, I choose to transfer the game to my old rig and do my first run through on a vintage 2002 32bit dell precision 450 with win xp and an AGP nVidia 6200, lol. I wanted get 'real' first time experience!

    I'll probability switch PCs and play exclusively on Libertatis on my second playthrough.

    Edit: I just wanted to add that most of the info I found when I was looking up potential compatibly issues beforehand came from right here at TTLG forums. I wanted to say thanks to the members and whoever runs this place for providing support/info for so many great games!
    Last edited by curseofnight; 26th Oct 2017 at 14:16. Reason: Wanted say Thx...

  8. #8
    Installing that 6200 wasn't the best idea... I'm 90% certain it killed that rig. It seems it was to much for the PSU and bricked everything(motherboard, cards, etc.) when it finally died. I read horror stories about that before but I honestly thought it was bs.

    On the brightside, I was taking off the trash a week or so ago and I noticed an old Gateway PC sitting on a table off to the side. I asked the guy working there about it and he said someone left it there. He said it supposedly worked but whoever left it didn't want it.

    So, long story short I nabbed it; Installed XP SP3, took some ram from an old Gateway tower, grabbed a HDD from a Dell XPS, brought a ATI x1300 128mb for cheap and installed Arx. I'm about to go meet the king. Here's hoping I can actually finish it this time!

  9. #9
    I loaded up my save last night after taking a break from this game for a month or two and ran into what I assume is glitch...


    I went to level 4 and met Alia and the rebels, saved, then explored the rebel camp. Then everyone started attacking me for no reason, heh. So, Loaded save, left the camp, saved troll, decided to leave the water/earth goblins be for now and continued to the next level and heres where I ran into trouble...

    I hid behind the snake pillar. Killed the cultists then, after spending an hour clearing out the level and trying (and failing) to find Shany, I finaly alt-tabed, opened-up the guide and read how to unlock the door to the room where Shany is held. There's just one problem, I already found the torch, and whenever I try to turn it, it plays a lock sound!

    After spending another hour or so running around I find myself back in Arx and realized I hadn't overheard the 2 cultist talking in the room across the way from Shany's house yet! So, after the cut-scene I grab the stuff from the chest, read the book and head back to save Shany but the torch still won't turn!

    So my question is, did I glitch my game by doing the events out of order? Is there a way to salvage this situation?

  10. #10
    Registered: Sep 2000
    Location: Hong Kong
    While the game is reasonably non-linear, the are a number of quests that get buggered up if they're done out of order. Not sure about that one in particular but in most cases you can still finish the game.

  11. #11
    Registered: Nov 2003
    Location: The Plateaux Of Mirror
    AFAIK you need to follow the cultists until after they open the door to the room Shany is in before killing them or you can't complete the quest. At least that was my experience on my most recent playthrough.

  12. #12
    Registered: Sep 2002
    Location: Texas
    What Jason Moyer said is correct. You must follow them to the room and save Shany then.

  13. #13
    Well, I guess I have something to look forward to on my next play through. =)

    I haven't played in a couple days but I'm in the crypts now, a few levels down. I just got the PC version of Dark Souls 2 so I got distracted... I think I'm going to fire this baby up in an hour or so.

  14. #14
    Right. So I finished the Crypts, aquired Krahoz and Zohark, and now I'm back where I was before my old PC kicked the bucket - getting butchered by the Jetpack-Knights in the Temple of Akbaa.

    Do these guys have any weakness? Any tips for fighting them?

    Also, I used all my potions fighting the Lich boss in the Crypts and only have enough gold to buy 4 or maybe 5. But I think I've already found - and used - all the water lilys in the areas I've explored ( levels 1-7 ), although some places I haven't searched throughly - Arx City, Rebel Camp, Snake Women hangout, etc.

    So do the water lillys grow back? Is there a secret cache of them or some potions hidden somewhere?
    Last edited by curseofnight; 13th Sep 2018 at 18:08. Reason: I no good english!

  15. #15
    Registered: Sep 2002
    Location: Texas
    Did you make the special weapon in the dwarfs area level 8? I bet you didn't.

  16. #16
    No, I haven't met any dwarfs and I haven't been to level 8 yet. I guess I'll head that way next time I play. I think I'm going to search every nook-and-cranny on my way down. Hopefully I'll find some potions or water lillys I missed.

    Actually, I just remembered there are a couple places blocked off by barriers I haven't checked out yet either. Although, I think one leads to more jetpack-knights - I think I dispelled that one once before... and died. =(

    Anyway, wish me luck!

  17. #17
    It seems I didn't explore level 7 after all. I must have went there awhile back and simply activated the portal and left, heh. I just defeated the worm there and went back to Arx to sell all the loot from the ratmen and now I have a ton of gold. Also, on my way down to level 7 I found a bunch of water lillys/potions that I missed so that's good.

    Something is bugging me though... I don't recall my level atm, but I have 16 strength and 93 close combat skill and my weapon is a bejeweled longsword but it still takes 2-3 hits to kill a damn rat - just as in the begining of the game. It took me 2-3 hits to kill a rat with a bone-club. That just feels wrong to me. It's like I'm not getting any stronger...

    Edit: Holy Crap! The Dwarven level is dangerous! I made it to the Forge but some crazy powerful beast is stalking me! I thought I lost it, but after I found a dead dwarf with a power stone and a journal it came back! I screamed like a girl and ran away, climbed a ladder but now I'm stuck. It's below me, waiting. I already shot all my arrows at it but I think that just pissed it off.

    I don't know what to do. I found some meat on the dead dwarf and I was thinking maybe I could bait somehow... but I don't go down there, lol...

    Edit #2: Baiting didn't work but I figured it out. I just hope he doesn't get back up, heh... I got lucky though - he got stuck trying to navigate around the crusher which gave me time to explore the room a bit a figure things out. =D
    Last edited by curseofnight; 14th Sep 2018 at 20:58.

  18. #18
    Registered: Sep 2002
    Location: Texas
    Good job. Yeah don't take the forcefield down yet. That's the last place you want to visit. I had to follow a walkthrough to kill that level 8 creature.

    Make sure you read the plaque in the tavern as it gets you on a treasure hunt that would lead you to level 8 as well. Dang I want to play again

  19. #19
    Thanks! I do have that RPGDot .pdf guide but my rule of thumb went it comes to walkthroughs is if I get stuck, I try to figure it out on my own for an hour or three - or until frustration kicks in, heh. I had to use it to get through the Snake ladies' test. =/

    I suppose I'll go back to the tavern in a bit and check it out. I figured there was some treasure hunt side-quest because I keep finding dead adventurers with notes about clues.... Actually, I think I've seen it mentioned somewhere now that I think about it. Probably in that guide.

    Also, I found the real Forge. It sucks that I can't use golden ingots - I wanted Jamie Lannister's sword! =(

    Btw, you should go play Arx right now! =) I wish I would have found this game years ago.

  20. #20
    So I went back to Tizzy's, found the note from Oliver, then decided to take another crack at the knights down below. I managed to kill the first one with 2 fireballs and a firewall (plus a LOT of smacks with my sword) and to my suprise I didn't use a single health potion! I got lucky again however - when I cast the firewall spell we where fighting on stairs near the entrance, he was on the stairs, I was on the landing above, and his ai sorta wigged-out so he stood in the flames until he died.

    Never-the-less, I was filling cocky so I saved, went forward, and proceeded to get killed by the second knight you encounter over and over(and over).

    It's now three hours later and I don't know which I should do; start a new game(again!) and put every freaking point into strength or take a break for a day or two or throw in the towel and admit that I just can't beat this game.

    I really really like this game but I'm strarting to really really hate it too. Is that weird? =D

    Sweet! Did it! I discovered their weakness; Sword-through-bowels! I guess I just have to accept the fact that it's going to take 4-5 health potions for me to survive an encounter with one of these guys. I just hope I never have to face more than one at a time.

    Anyway, I'm standing around the destroyed outpost now waiting for my health to recharge, then it's off to see the king, I guess.

    Update #2:

    Update #3:
    Alright. Honest question: Is there a mod that cuts the Ylisides health in half?

    This is getting ridiculous.... I've only got three health potions left after going through the cultist temple for the second time, and that's not enough for me to even kill one those assholes.... I'm about to head back to the Rebel Camp and then the brother traders to buy all their potions, but I know I'll be out of potions again soon, and then what am I going to do? As far as I know, vendors don't restock their goods - or do they? I suppose I'll find out....

    Last Update:
    So I arrived back in Arx with 20 health potions and after killing the 2 Ylisides nearest the portal, I only have 3 left. 17 potions to kill 2 guys.... I guess I'm just not playing this game right. I just want to smack things with my sword and throw a fireball every now and then.

    I feel like I should just start over but I really don't to. I wasted a bunch of points early on so I could use a bow only to find out your hand blocks the center of the screen with you aim. Lame. :/

    I suppose I will take that break now and pick this game back up in a couple weeks. Maybe I'll find a good build FAQ by then and just start fresh. Or maybe I'll just load up the game up and try again... I mean, if I yell loud enough at the TV maybe it'll scare all the baddies away. Then I can just walk on over to the castle and save the day....
    Last edited by curseofnight; 16th Sep 2018 at 20:51. Reason: This F'in Game!

  21. #21
    Registered: Sep 2002
    Location: Texas
    I make the dwarf sword the big one. I have ilsid(spelling) armor that your friend gives you when escaping the castle, 100 sword skill and never go through that many health potions. Usually takes like 3 or 4 whacks of the sword and then I run away as they explode.

  22. #22
    I did find a big mold but I only made the smaller one. I assume there is special type of ore I'm supposed to use? When I tried the smaller mold I got a saber, which was weaker than my current weapon.

    Anyway, I spent a hour or two digging around online last night and decided that when I decide to pick this game up again, to start over and try a mage build. I read that they can take out Yilsides, and everything else, very quick.

  23. #23
    New Member
    Registered: Sep 2018
    Quote Originally Posted by curseofnight View Post
    I did find a big mold but I only made the smaller one. I assume there is special type of ore I'm supposed to use? When I tried the smaller mold I got a saber, which was weaker than my current weapon. why instant knockout is good

    Anyway, I spent a hour or two digging around online last night and decided that when I decide to pick this game up again, to start over and try a mage build. I read that they can take out Yilsides, and everything else, very quick.
    I agree with you, it's like an instant knockout here
    Last edited by Joshua020; 28th Sep 2018 at 16:10.

  24. #24
    Well, thanks for being an agreeable sort Joshua!

    Honestly, I should have looked that stuff up a while back but I *hate* reading up too much on games I haven't beaten cuz of spoilers and stuff.

    I just got Two Worlds 2 yesterday(kool so far...) but I'm thinking about picking up a six pack tonight, loading up Arx, and beating it into the dirt. Actually looking forward to a pure mage build. It's not my perfered style, so it might be interesting. I just gotta be careful when I level up. I have a tendency to go for a 'jack of all trades who likes swords, shields, and fireballs' characters in everything I play. Need to stop that and focus.

    Also, downloaded the Arx source code and I honestly can't figure out what - is - where, lol. (weird/confusing names) I'm not fishing for advice, btw, just an observation. Besides, I'm still reading 'C++ for stupid' guides. I made a 'Hello World' program a couple weeks ago. It has a few buttons now that don't anything and it crashes when you click them.

    I have dream of one day modding Arx and adding a sprint button, additional spell precast buttons, allowing leaning with weapons out, leaning while crouched, leaning while crouched with weapons out, lowering the bow when drawn and adding a crosshair and something else that seemed really important but I can't recall it just now... maybe in a year or three....

    Also, I wish I could change the name of this thread to Journeys through Arx or maybe Rambling about Arx. Definately, Rambling :P
    Last edited by curseofnight; 3rd Oct 2018 at 17:33. Reason: I no spell gud

  25. #25
    I was so impressed with Libertatis that after properly installing and setting up the correct values, I compressed it into a single archive for later use. I would strongly recommend Libertatis as Shadowcat mentioned above, so this is another +1 for that mod.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts