TTLG|Thief|Bioshock|System Shock|Deus Ex|Mobile
Page 1 of 2 12 LastLast
Results 1 to 25 of 29

Thread: This key binding bug really starts to get annoying

  1. #1

    This key binding bug really starts to get annoying

    Ive moved my complete steam folder now to Primary drive C: (since ive been told that it could be a bug through thief being installed in program files).



    But its still the same crap, Thief 2 does not apply my costum key bindings. It applies a weird messy key binding everytime when i try to Change it.


    I can only use the Default key bindings but even if i Change them it automatically goes back to these messy weird key bindings (moving left with D???)


    What can i do? I was so happy finding a german language pack so that i finally can play the game while understanding the conversations and books

    (Thief uses a very archaic Version of english, so its even more harder to understand it as someone who's main language isnt english)

    Ive even reinstalled it with the tafferpatch and language pack, but Nothing changes...

  2. #2
    Member
    Registered: Jul 2005
    Location: Bulgaria
    Quote Originally Posted by The Keeper's Acolyte View Post

    (Thief uses a very archaic Version of english, so its even more harder to understand it as someone who's main language isnt english)
    Heathen! Thou shalt not revile the holy scriptures of the Master Builder!

  3. #3
    Dóttirin klęšist oft móšur möttli
    Registered: Apr 2015
    Run as administrator.
    Set the bindings. Save it.
    You should have "user.bnd" in the main folder then.

  4. #4
    Zombified
    Registered: Sep 2004
    make sure the file is not set to read only (no file should be read only, btw).

  5. #5
    What do you mean with read only? Ive already tried to run it as Administrator, and i already tried to Change the key bindings trough bnd but Nothing works

  6. #6
    Desperately Dodgy Moderator
    Registered: Nov 2001
    Location: Fields of bluegrass
    In Windows Explorer, right-click on the user.bnd file and click Properties. At the bottom see if Read-only is checked, and if so uncheck it and click OK or Apply. You might also just want to do that by selecting all (Ctrl-A) in your Thief install folder and doing the same thing.

  7. #7
    Ive did now really anything, but it still doesnt work……..


    Can someone help me via TeamViewer?

  8. #8
    Dóttirin klęšist oft móšur möttli
    Registered: Apr 2015
    Post the content of user.bnd
    in #code and tell us the bindings you need. We'll be able to edit it.

  9. #9
    Zombified
    Registered: Sep 2004
    delete user.bnd, start the game and set the controls, a new, proper user.bnd should get created.

  10. #10
    Ive deleted EVERYTHING in the bnd file to Setup a new key binding in the ingame menu, but even after all that IT WONT WORK.

    It Always applies the same non-configurable weird key binding.



    I think its an absolute bug

  11. #11
    Zombified
    Registered: Sep 2004
    yes, that's why you are the only person in the universe having the problem. also, you might want to start listening to what people say - nobody asked you to delete the contents of the file (that will indeed mess the game up). not starting random new topics about the same problem would be nice as well.

    so again, DELETE the user.bnd file, start the game, set the controls, done.
    Last edited by voodoo47; 28th Jun 2018 at 04:58.

  12. #12
    Desperately Dodgy Moderator
    Registered: Nov 2001
    Location: Fields of bluegrass
    And make sure you also verified that the entire folder and all files are not set to Read Only, as was also suggested earlier, since you didn't say if you had tried that.

  13. #13
    Member
    Registered: Dec 2011
    Location: Ferrol - Spain
    Quote Originally Posted by The Keeper's Acolyte View Post
    Ive deleted EVERYTHING in the bnd file to Setup a new key binding in the ingame menu, but even after all that IT WONT WORK.

    It Always applies the same non-configurable weird key binding.



    I think its an absolute bug
    This is my user.bnd in Thief2. The one I´m currently using.
    Hope it won´t take you long to download.

    https://drive.google.com/file/d/1Mu9...ew?usp=sharing

  14. #14
    ZylonBane
    Registered: Sep 2000
    Location: ZylonBane
    RAR? Seriously?

  15. #15
    Member
    Registered: Dec 2011
    Location: Ferrol - Spain
    Quote Originally Posted by ZylonBane View Post
    RAR? Seriously?
    Just in case his download speed is very low.
    Strong compression.

  16. #16
    Desperately Dodgy Moderator
    Registered: Nov 2001
    Location: Fields of bluegrass
    I'm pretty sure ZB was asking why you bothered to compress a file of that size (my user.bnd is 5kb).

  17. #17
    Ok ive did now ALL what you said but it still doesnt work.

    Are there any Options left???

  18. #18
    Zombified
    Registered: Sep 2004
    so, you have deleted your user.bnd (the file), started the game, set your binds, a new user.bnd has been created, and it's not the binds you have set?

  19. #19
    Member
    Registered: Dec 2011
    Location: Ferrol - Spain
    Quote Originally Posted by Yandros View Post
    I'm pretty sure ZB was asking why you bothered to compress a file of that size (my user.bnd is 5kb).
    Because I didn´t realize until ZylonBane said so.
    I´m so used to upload files of some hundred MB so often, delete them, etc for friends and a few to keep mostly for me that it was inertia and only that.
    Yes, looks really weird a file of that size in a compressed format.

  20. #20
    Member
    Registered: Aug 2009
    Location: thiefgold.com
    Keeper's Acolyte, please post a couple screenshots of the bindings menu so we get a better idea, in case you're missing something.

    As another workaround, you can try editing the BND files manually with your preferred keys (make a backup of dark.bnd, then edit it with Notepad) and see if that fixes it. It's laborious, but at this point is the next option you have

  21. #21
    ZylonBane
    Registered: Sep 2000
    Location: ZylonBane
    Quote Originally Posted by Yandros View Post
    I'm pretty sure ZB was asking why you bothered to compress a file of that size (my user.bnd is 5kb).
    Well that and, seriously, who uses WinRAR anymore? It's like the Windows 95 of archivers.

  22. #22

  23. #23
    https://imgur.com/a/Q4BtOno Here are some screenshots

  24. #24
    Zombified
    Registered: Sep 2004
    yep, something is very, very wrong with your install (the user.bnd file from the screenshots looks like it has been created by oldDark T1). delete the game completely, create a fresh, clean install, patch it with TafferPatcher (and nothing else. also make sure to select the NewDark patch) and see whether it works.

    make sure you are not doing something insane like patching T1 with TaferPatcher.

  25. #25
    Southquarter.com/fms
    Registered: Apr 2000
    Location: The Akkala Highlands
    Yes, the 4th screenshot says "This file was generated by Thief The Dark Project." I'm guessing anything patched with New Dark (manually or via Tafferpatcher) would not say that.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •