TTLG|Thief|Bioshock|System Shock|Deus Ex|Mobile
Results 1 to 14 of 14

Thread: Bullet DromEd 1.27

  1. #1
    Dóttirin klęšist oft móšur möttli
    Registered: Apr 2015

    Bullet DromEd 1.27

    This is a easy upgrade to NewDark 1.27 for players and DromEd users. It will run out of the box for playing and editing.
    It has everything you need
    1. Thief 2 and DromEd NewDark 1.27 already patched with Large Address Aware
    2. Scripts for Thief2
    3. DromEd Toolkit 1.14 cmds and menu


    https://www.mediafire.com/file/1kaar...D1.27.zip/file
    (No multiplayer included)
    Old ND1.26
    http://www.mediafire.com/file/0kgf9o...D1.26.zip/file

    Installation: open the zip and just drop everything into the T2 main folder. Overwrite the files

    For advanced users: you might want keep your custom ini/cfg files, so backup it or don't replace it.



    This also works for T1/TG, just rename Thief2.exe-->Thief.exe
    but you must not replace convict.osm or gen.osm.

    This is not a replacement for Tafferpatcher/T2fix/Tfix, as there are no improved resources.

    Want to play Fan Missions? Always use FMSel, NewDarkloader or AngelLoader. Don't use Darkloader any more, it's outdated and troublesome.
    Edit cam_mod.ini like this
    Code:
    ; always start the FM Selector (if one is present)
    Fm
    Start Thief2.exe and set the FM path.

    For advanced DromEd users, I recommend to download DromEd Toolkit, too.
    Last edited by Unna Oertdottir; 8th Aug 2019 at 03:13.

  2. #2
    Thank you. This makes it very convenient since I have a habit of reinstalling these games multiple times.
    Last edited by Goethe's Ghost; 5th Dec 2018 at 13:09.

  3. #3
    Southquarter.com/fms
    Registered: Apr 2000
    Location: The Akkala Highlands
    Thanks Unna. I thought this might be helpful since Tafferpatcher has not been updated to the latest version of New Dark, and DJ Riff has gone AWOL.

  4. #4
    ZylonBane
    Registered: Sep 2000
    Location: ZylonBane
    I'm assuming from the name "Bullet DromEd" that this is a new version of DromEd, written by someone named Bullet.

  5. #5
    Dóttirin klęšist oft móšur möttli
    Registered: Apr 2015
    Updated the package to NewDark 1.27.
    Note that I didn't include multiplayer.
    It can be found in NewDark 1.27.
    http://www.mediafire.com/file/yrbopr..._v127.zip/file

  6. #6
    Member
    Registered: Nov 2003
    Location: Thief fan since ca. 1999
    Well played, Zylon. Even though you're still being an asshole.

    Yeah, why is it called bullet?

  7. #7
    Member
    Registered: Apr 2011
    Thanks Unna, this package is great, and the 1.27 update is appreciated!

    (Mediafire is a bit awful though… it automatically downloaded an additional file 'PlayerSetup.dmg' which looks suspiciously like malware to me.)

  8. #8
    Dóttirin klęšist oft móšur möttli
    Registered: Apr 2015
    I always disable scripts in Firefox there. You also don't need to allow 3rd party stuff or advertising on mediafire. Block everything. Then you get a clean and working download page. It will work.


    Bullet Dromed is bullet-proof. It's also a unique name for the search engine, which is the most important part. Easy to find.

  9. #9
    Member
    Registered: Jan 2011
    Location: Wild and Wooly West of Ireland
    I need an Idiot Proof DromEd, if I'm ever to finally finish a blasted mission!

  10. #10
    Member
    Registered: Apr 2011
    Quote Originally Posted by Purgator View Post
    I need an Idiot Proof DromEd, if I'm ever to finally finish a blasted mission!
    Then it’s not Bullet Dromed you need, but Benny Dromed.

  11. #11
    Member
    Registered: Sep 1999
    Location: Austin, TX
    Why are the commands still in the root directory? Aren't they only supposed to be in the ./Cmds/? Or are you just including both incase you're dragging over a install that already has the Dromed Toolkit.

    On that topic, what do you recommend, overwriting toolkit install first, or dragging over toolkit after this bullet? Thanks for putting this together! I still hadn't updated to 1.27.

  12. #12
    Dóttirin klęšist oft móšur möttli
    Registered: Apr 2015
    1. I included cmds in the root folder, too because I don't know the config path path and I don't want too much useless discussions
    Default is /cmds, that's correct, but some users might have other settings.
    2. The important parts of DromEd toolkit for a basic working installation are already included. But some parts are not, such as the tools, schemas, dlls, etc. Useful stuff for advanced DromEd work. You can copy it sooner or later, it doesn't matter.
    Last edited by Unna Oertdottir; 23rd Jul 2019 at 02:38.

  13. #13
    Member
    Registered: Sep 1999
    Location: Austin, TX
    Quote Originally Posted by Unna Oertdottir View Post
    1. I included cmds in the root folder, too because I don't know the config path path and I don't want too much useless discussions
    Default is /cmds, that's correct, but some users might have other settings.
    2. The important parts of DromEd toolkit for a basic working installation are already included. But some parts are not, such as the tools, schemas, dlls, etc. Useful stuff for advanced DromEd work. You can copy it sooner or later, it doesn't matter.
    Hey thanks for answering and your work! Cheers.

  14. #14
    Member
    Registered: Aug 2012
    Location: Nova Scotia, Canada
    Thanks for this, very useful and convenient

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •