TTLG|Thief|Bioshock|System Shock|Deus Ex|Mobile
Results 1 to 4 of 4

Thread: Fresh GOG install + setup for FMs

  1. #1
    New Member
    Registered: Feb 2017

    Fresh GOG install + setup for FMs

    Hello,

    Sorry for asking this for probably the millionth time here. A lot of the links/threads covering this seem to be old or out of date. That and a new version of NewDark just came it out seems...

    I've just installed a fresh install of Thief 2 from GOG. I note it already has NewDark 1.26. Does this mean I don't need TafferPatcher then? The latest version of that (2.0.18) seems to include NewDark 1.25 (earlier version)? Should I install it without ticking 'patch 1.25? Or not bother?

    Also, a lot of the FMs say things like 'don't play with other mods installed, etc' because they can break things. Does this include the HD mod?

    Also, is there any easy way to tell what patches have been installed already and what the game is using (NewDark, TafferPatcher, etc)?

    Basically, what do people recommend?

    Thanks!

    EDIT: meant to say I posted in the Fan Missions section because I mostly play FMs

  2. #2
    Dóttirin klęšist oft móšur möttli
    Registered: Apr 2015
    Backup the installation and install this. Everything you need to play FMs is there.

  3. #3
    New Member
    Registered: Feb 2017
    Quote Originally Posted by Unna Oertdottir View Post
    Backup the installation and install this. Everything you need to play FMs is there.
    Cool thanks :-). But looking at that I guess what I'm getting out of it is the scripts for FMs? I don't do any DromEd so not worried about the rest of it.

    What's the deal with TafferPatcher then? Is is not needed anymore? Does the GOG version already include all the other stuff it provides?

    EDIT: Nevermind, just saw this: 'This is not a replacement for Tafferpatcher/Tfix, as there are no improved resources.`

  4. #4
    Dóttirin klęšist oft móšur möttli
    Registered: Apr 2015
    Tafferpatcher has not been updated for some time. If you want custom mods, you can install Tafferpatcher and Bullet DromEd after that.
    The DromEd cmds/files won't hurt Just delete them if you don't want it.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •