TTLG|Thief|Bioshock|System Shock|Deus Ex|Mobile
Results 1 to 9 of 9

Thread: [Thief Gold] Sleeping AI works... but

  1. #1

    [Thief Gold] Sleeping AI works... but

    I use custom metaproperty,

    And with Alert response set like this,

    Ai wakes up instantly on even the smallest noise (lockpicking, 1 loud step etc.)

    When I change alert level to 2 moderate, he doesn't stand up but still kinda wakes up, (while laying down) talks like he's awake but actually doesn't respond to ANYTHING anymore, you can jump and dance around him, he just lays down and talks to himself as regular guard.

    What I look for is when the AI wouldn't react on lockpicking and other small noises like water/rope arrow shots, but would react and not glitch on louder ones.

  2. #2
    Registered: May 2002
    Location: Texas
    Try setting the guard's hearing to below average.

  3. #3
    yeah, I put him well below average and hes only responding on a serious racket. when put on just below average he still reacted instantly on lockpicking etc.

    I see other problem tho, first, when he's on bed, wakes up and stands on bed, he doesnt react to seeing me, only when I attack him with a sword.
    but even when I attack him, he seems like he wants to retaliate, but the animation isnt there, he just jumps around me making noises, and stands still when he "attacks"

    I would simply want him to act like a regular guard when awaken.

  4. #4
    Dóttirin klęšist oft móšur möttli
    Registered: Apr 2015
    You need to find out what's wrong with him

    type into the console
    set game_mode_backup 0
    go in game mode, alert him
    go back to DromEd again and investigate his settings/metaproperties
    Don't save after this, better quit DromEd.

  5. #5
    Registered: Aug 2006
    Location: France (Saint-Gobain)
    In that case i make always the ai creature neutral, i set his visibility and hearing to null/zero.

  6. #6
    Registered: May 2002
    Location: Texas
    It might be a buggy AI. Try deleting the AI and create it again.

  7. #7
    Desperately Dodgy Moderator
    Registered: Nov 2001
    Location: Fields of bluegrass
    I discovered when making DCE that the T2 stock sleeping metaprops were broken between NewDark 1.19 and 1.20 (I think... it was two of the earlier versions). I will go back and look at things tonight if I have time and post the problem and workaround here. I think it involves just adding one additional property to the metaprop.

  8. #8
    Thanks all for help.
    I think I managed to fix it. Ill post what was wrong and how I fixed it.
    first problem was the ai acted like I'm not around.
    The problem was... the room was too short I think, I increased the height of the ceiling and the ai started to react normally again, lol.

    Second problem was the lack of animation during the attack, I just changed Motions>ActorTagList from hammer 0 to Hammer 0, WithSword 0 (a ham novice, now he attacks just with his hands [intended])

    I'll still do some testings later on, but I think it works

  9. #9
    Registered: May 2002
    Location: Texas
    Yeah without the WithSword 0 rider you're basically elliminating all of the attack motions. I had the same problem with the unarmed thief and I fixed it with the same solution.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts