TTLG|Thief|Bioshock|System Shock|Deus Ex|Mobile
Page 20 of 20 FirstFirst ... 510151617181920
Results 476 to 500 of 500

Thread: T2Fix: An Unofficial Comprehensive Patch for Thief 2

  1. #476
    Member
    Registered: May 2016
    Not sure what it causing this. At one point in time, the switch in the statue for one of the secrets in Life Of The Party was a lot of more visible that it is now.

    http://www.thief-thecircle.com/guide...rtystatsec.JPG

    https://imgur.com/a/6BFO0MC

    I've used the latest installer, only forgoing subtitles, EP and interactive candles.

  2. #477
    Member
    Registered: Mar 2015
    Thank you for the report.

    This appears to only occur with the fixed missions installed. The resources included with them contain a new version of the standard elevator button model used for that secret, which corrects the direction it bumps when pressed but is otherwise identical. However, this change seems to alter the object's visible position when its dimensions are decreased to the extent of the case of that secret button, though these circumstances are not especially common. This occurs because the translation joint of the model was simply inverted. Fixing this is trivially easy and will be addressed in future releases. If you would prefer to have it now, extracting this archive to usermods or another mod directory should suffice.

    Quote Originally Posted by klatremus View Post
    Not sure if this is the place to post about it, but there have been no posts to the EP thread since 2013. Anyway, all the office doors in Shoalsgate Station (Framed) with letter slots in them have the texture mirrored on the other side of the door, so they spell 'LETTERS' backwards/mirrored. Not sure if anyone else reacts to those sort of things, but for me it's an immersion breaker.
    I believe the texture of that particular door is touched only by EP2 as opposed to the older EP release included with T2Fix, though discussing this here is fine regardless. I can see how that visual inconsistency would be bothersome. Fortunately, it can be addressed fairly easily by having the rear side of the door use an alternate texture that mirrors the text to correct for this, though perhaps a more clever solution could be employed.

    While the original EP thread has been quiet for a while now, the EP2 thread is still receiving posts. Mentioning this there as well may help, though I suppose I could share a small fix for this myself if desired.

  3. #478
    Member
    Registered: Aug 2020
    After finishing the game with a netbook config on the famous SGX545 gpu, I still am trying to run the Dx9 renderer that seems to not run on this gpu and Win 8.1 at least starting from the menu problems.I finished the game with the Dx6 renderer in windowed mode, not the best fastest gaming experience anyway.
    I can't understand why the TFix for the Thief Demo with the "same" (?) Directx9 renderer the game start and plays smooth and well. In Thief 2 (double cd version) with the T2Fix I get this result as soon the video/menu starts both in windowed or fullscreen mode I get this but the menu is running with sound and mouse interactions..



    These tiled menu seems to change colors alone or with the mouse movements.
    I tried most tweaks, even taking files from the Thief 1 Demo game, even Dx to GL wrappers.. no way.. the only ones that seems to works was the WineD3D wrapper but is slower than the Directx6 Windowed mode so no way.
    The strange thing happens until the game start when it seems to start ok if I can get to start it randomly with the mouse and when the game start it works but after a while it also seems to freeze randomly in the rendering... it's really strange cause the TFix in Thief Demo doesn't have any problems at all. Any ideas?

    Here's the thief2 log:

    :
    : CPU: arch=x86-64 , fam=586 , cpus=2
    : SIMD: SSE=3 , 3DNow=0 , MMX=1
    : OS Version: 6.2.9200
    : Desktop resolution: 1024 x 768
    : Virtual desktop resolution: 1024 x 768
    : -----------------------------------------------------------
    : Command line: "C:\Games\Thief2\Thief2.exe"
    : -----------------------------------------------------------
    : CWD: C:\Games\Thief2
    : -----------------------------------------------------------
    : App Version: Thief 2 Final 1.27
    : --------------------- misc config -------------------------
    : resname_base .\RES\RESPATCH+.\RES
    : load_path .\
    : script_module_path .\
    : movie_path .\MOVIES
    : install_path .\
    : language english
    : game_screen_size 640 480
    : game_screen_depth 32
    : game_screen_flags 47
    : game_full_screen 1
    : game_hardware 1
    : vsync_mode 1
    : force_windowed
    : single_display_mode 2
    : ui_scale_mode 0
    : use_d3d_display
    : d3d_disp_scaled_2d_overlay 640 480
    : SlowFrame 4
    : SlowFrameUI 10
    : force_32bit
    : force_32bit_textures
    : mipmap_mode 1
    : lm_mipmap_mode 0
    : lm_init_texmem 2
    : lm_filter_margin 1
    : tex_edge_padding 2
    : alpha_test_as_opaque
    : multisampletype 0
    : sfx_device 2
    : sfx_channels 16
    : sfx_vol_music 0
    : sfx_vol_2d 0
    : sfx_vol_3d 0
    : snd_speaker_config 2
    : game dark
    : obj_min -8192
    : obj_max 2400
    : max_refs 14000
    : gui_font intrface\smalfont
    : use_hi_res_timer
    : enhanced_sky 1
    : skip_intro
    : new_mantle
    : z_far 128
    : render_weapon_particles
    : legacy_force_match_unrefs 0
    : dark_zcomp_arm
    : -----------------------------------------------------------
    : Enumerating D3D9 adapters (1)...
    : Adapter 0
    : device name: \\.\DISPLAY1
    : driver : igdumd32.dll
    : descr : Intel(R) Graphics Media Accelerator 3600 Series
    : driver ver :
    : vendor id :
    : device id :
    : subsys id :
    : device guid:
    : desktop res: 1024 x 768
    : Modes
    : 320 x 200 x 32
    : 320 x 240 x 32
    : 400 x 300 x 32
    : 512 x 384 x 32
    : 640 x 400 x 32
    : 640 x 480 x 32
    : 800 x 600 x 32
    : 1024 x 768 x 32
    : Device Validation
    : validated ok, device added (0, E310000)
    : Enumeration done
    : D3DProvider: Enumerating adapter 0 modes
    : 320 x 200 x 32
    : 320 x 240 x 32
    : 400 x 300 x 32
    : 512 x 384 x 32
    : 640 x 400 x 32
    : 640 x 480 x 32
    : 800 x 600 x 32
    : 1024 x 768 x 32
    : D3DProvider: Enumeration done
    : D3DProvider: D3D device only supports limited non-POW2 textures
    : D3DProvider StartMode: smode 640x480x32 ; mode 640x480x32 (5 5 0 2D) ; 2d_surf_mode: 0
    : CreateDevice: res = D3D_OK ; 640x480 fmt=22 zfmt=75 cnt=1 ms=0 swap=1 fs=0 hz=0 pres=-2147483648 flags=2


    EDIT: I found later that I was launching the original thiefd.exe game file and it runs ok with ddraw.dll patch/wrapper into the directory with the origina Dx6 engine. The Tfix thief.exe Dx9 engine has the same gfx error of Thief2.
    Last edited by 386SX; 19th Dec 2020 at 13:48.

  4. #479
    Zombified
    Registered: Sep 2004
    link to that demo that works?

  5. #480
    Member
    Registered: Aug 2020
    Quote Originally Posted by voodoo47 View Post
    link to that demo that works?
    I found that the Thief Demo test wasn't done correctly; the Tfix doesn't work on Thief Demo too cause I was launching the thiefd.exe file and not the thief.exe of the patch that shows the same menu error even in Thief Demo..

    But it's interesting anyway cause launching the original exe it actually start ok without errors and @ fullscreen, thanks to a ddraw.dll I found somewhere in some patches for running old games into new operating systems (the patch was called DDrawCompat found in Github I probably read about somewhere a sort of wrapper) and in fact both the two different demos that existed for the Thief game does run and the dll leaves this log before starting:

    3680 13:29:28.065 Process path: C:\Games\thiefdemo\thiefd.exe
    3680 13:29:28.065 Loading DDrawCompat from C:\Games\thiefdemo\ddraw.dll
    3680 13:29:28.080 DDrawCompat loaded successfully
    3680 13:29:28.080 Installing DirectDraw hooks
    3680 13:29:28.112 Installing GDI hooks
    3680 13:29:28.127 Installing registry hooks
    3680 13:29:28.127 Finished installing hooks
    3680 13:29:30.756 GDI used DC cache size: 1
    3680 13:30:32.631 Detaching DDrawCompat
    3680 13:30:32.772 DDrawCompat detached successfully


    I tried the original first game demo of the 1998 and the first game second demo of the 1999; one with only the ddraw.dll, the other with also the TFix installer installed and ddraw.dl, both using the original executables not the patched exe.
    Both start ok in the menu and game with same log above but the second one with the patch+ddraw (still original thiefd.exe) even seems to run at higher frame rate. Maybe just the beginning inside that sort of shop into the game.

    If I try the same config in Thief2 with the original exe and no T2Fix it crash before start.

    EDIT and BIG improvement!:
    I tried this... Thief2 original 2CD installation plus T2Fix Lite plus DDrawCompat that incredibly was updated lately on Github after many years and with both patches unfortunately the game still doesn't run on Directx9 renderer with the same gfx problems both video intro and menu, BUT now the Directx6 old renderer in the cam_ext file can run the game @ real fullscreen with a bit better frame rate I guess even if some polygons/light errors but not a fake windowed fullscreen mode, a real one. Strange these polygons that seems to become black and go away depending on the point of view and the light into the rooms. This didn't happen before in the windowed T2Fix only Dx6 config.
    Anyway still not using the GMA3600 Directx9 hw but... an improvement after all!
    A photo of the problem(sorry for the camera quality); they appears and disappears depending on the movements, lights etc...

    T2+T2Fix+DDrawCompat latest release + Directx6 renderer fullscreen:



    Here's the log of ddraw.dll:

    0c38 14:13:35.731 Process path: C:\Games\Thief2\thief2.exe
    0c38 14:13:35.731 Environment variable __COMPAT_LAYER = ""
    0c38 14:13:35.731 Loading DDrawCompat dynamically from C:\Games\Thief2\ddraw.dll
    0c38 14:13:35.737 DDrawCompat loaded successfully
    0c38 14:13:35.738 Installing display mode hooks
    0c38 14:13:35.740 Installing registry hooks
    0c38 14:13:35.740 Installing Direct3D driver hooks
    0c38 14:13:35.741 Installing Win32 hooks
    0c38 14:13:35.763 Hooking user mode display driver: igdumd32.dll
    0c38 14:13:35.777 Dynamic vertex buffers are not available
    0c38 14:13:35.777 Dynamic index buffers are not available
    0c38 14:13:35.779 Checking source color key support: passed
    0c38 14:13:35.784 Installing DirectDraw hooks
    0c38 14:13:35.789 Installing Direct3D hooks
    0c38 14:13:35.817 Installing GDI hooks
    0c38 14:13:35.850 Warning: Failed to hook the following user32 window procedures: [buttonWndProcA,buttonWndProcW,comboBoxWndProcA,comboBoxWndProcW,editWndProcA,editWndProcW,listBoxWnd ProcA,listBoxWndProcW,mdiClientWndProcA,mdiClientWndProcW,staticWndProcA,staticWndProcW,comboListBox WndProcA,comboListBoxWndProcW,scrollBarWndProcW,menuWndProcW]
    0c38 14:13:35.861 Finished installing hooks
    0c38 14:13:35.917 Incorrect z-buffer bit depth capabilities detected for "Intel(R) Graphics Media Accelerator 3600 Series" / Direct3D HAL; changed from "16, 24" to "16"
    0c38 14:15:48.714 Detaching DDrawCompat due to process termination
    0c38 14:15:48.714 DDrawCompat detached successfully


    Interesting that line. I also tried the same config but with the Directx9 renderer in the cam_ext file and it seems the ddraw.dll wrapper isn't called here, it probably isn't needed in this configuration and I get the identical problems of the previous times.. menu unreadables both full or windowed mode also videos and IF I get to enter the game those problems go aways but and render at double the frame rate but very soon it hang in the 3D movements until it unlock itself and then again and again.. the game is running, if I press esc I get to the unreadables menu and if I come back to the game after a while it render the 3D game again but again it seems to hang after seconds depending on the scene for unknown reasons..
    Here's the log:

    : Enumerating D3D9 adapters (1)...
    : Adapter 0
    : device name: \\.\DISPLAY1
    : driver : igdumd32.dll
    : descr : Intel(R) Graphics Media Accelerator 3600 Series
    : driver ver : 0x0008000E-00080448
    : vendor id :
    : device id :
    : subsys id :
    : device guid:
    : desktop res: 1024 x 768
    : Modes
    : 320 x 200 x 32
    : 320 x 240 x 32
    : 400 x 300 x 32
    : 512 x 384 x 32
    : 640 x 400 x 32
    : 640 x 480 x 32
    : 800 x 600 x 32
    : 1024 x 768 x 32
    : Device Validation
    : validated ok, device added (0, E310000)
    : Enumeration done
    : D3DProvider: Enumerating adapter 0 modes
    : 320 x 200 x 32
    : 320 x 240 x 32
    : 400 x 300 x 32
    : 512 x 384 x 32
    : 640 x 400 x 32
    : 640 x 480 x 32
    : 800 x 600 x 32
    : 1024 x 768 x 32
    : D3DProvider: Enumeration done
    : D3DProvider: D3D device only supports limited non-POW2 textures
    : sw framerate cap requested (10000 us)
    : D3DProvider StartMode: smode 1024x768x32 ; mode 640x480x32 (5 9 0 2D) ; 2d_surf_mode: 0
    : CreateDevice: res = D3D_OK ; 1024x768 fmt=22 zfmt=75 cnt=1 ms=0 swap=1 fs=1 hz=0 pres=1 flags=2
    : Loaded script module "miss1.osm" [FileModDate=2000-Mar-27]
    : Loaded script module "gen.osm" [FileModDate=2000-Mar-27]
    : Loaded script module "convict.osm" [FileModDate=2000-Mar-27]
    : sw framerate cap requested (10000 us)
    : D3DProvider StartMode: smode 1024x768x32 ; mode 1024x768x32 (7 9 1 3D) ; 2d_surf_mode: 3
    : sw framerate cap requested (10000 us)
    : D3DProvider StartMode: smode 1024x768x32 ; mode 640x480x32 (5 9 1 2D) ; 2d_surf_mode: 0
    : sw framerate cap requested (10000 us)
    : D3DProvider StartMode: smode 1024x768x32 ; mode 1024x768x32 (7 9 1 3D) ; 2d_surf_mode: 3
    : sw framerate cap requested (10000 us)
    : D3DProvider StartMode: smode 1024x768x32 ; mode 640x480x32 (5 9 1 2D) ; 2d_surf_mode: 0
    : sw framerate cap requested (10000 us)
    : D3DProvider StartMode: smode 1024x768x32 ; mode 1024x768x32 (7 9 1 3D) ; 2d_surf_mode: 3
    : sw framerate cap requested (10000 us)
    : D3DProvider StartMode: smode 1024x768x32 ; mode 640x480x32 (5 9 1 2D) ; 2d_surf_mode: 0
    : sw framerate cap requested (10000 us)
    : D3DProvider StartMode: smode 1024x768x32 ; mode 1024x768x32 (7 9 1 3D) ; 2d_surf_mode: 3
    : sw framerate cap requested (10000 us)
    : D3DProvider StartMode: smode 1024x768x32 ; mode 640x480x32 (5 9 1 2D) ; 2d_surf_mode: 0
    : sw framerate cap requested (10000 us)
    : D3DProvider StartMode: smode 1024x768x32 ; mode 1024x768x32 (7 9 1 3D) ; 2d_surf_mode: 3
    : sw framerate cap requested (10000 us)
    : D3DProvider StartMode: smode 1024x768x32 ; mode 640x480x32 (5 9 1 2D) ; 2d_surf_mode: 0
    : sw framerate cap requested (10000 us)
    : D3DProvider StartMode: smode 1024x768x32 ; mode 1024x768x32 (7 9 1 3D) ; 2d_surf_mode: 3
    : sw framerate cap requested (10000 us)
    : D3DProvider StartMode: smode 1024x768x32 ; mode 640x480x32 (5 9 1 2D) ; 2d_surf_mode: 0
    : sw framerate cap requested (10000 us)
    : D3DProvider StartMode: smode 1024x768x32 ; mode 1024x768x32 (7 9 1 3D) ; 2d_surf_mode: 3
    : sw framerate cap requested (10000 us)
    : D3DProvider StartMode: smode 1024x768x32 ; mode 640x480x32 (5 9 1 2D) ; 2d_surf_mode: 0
    Last edited by 386SX; 19th Dec 2020 at 13:50.

  6. #481
    Member
    Registered: Aug 2020
    New updates:

    I'm still doing various tests on Thief2, some would probably ask himself why I just don't use any other GPU of the world..
    But at this point it's interesting to see if actually can or not. I tried the legacy ddfix executables and more or less seems to act like the T2Fix legacy windowed mode and without the polygons errors and light errors above but still at much lower frame rate as always.
    Directx9 renderer is still far from any improvements...
    One thing interesting is that in the ddfix ini file there's a line that seems to refer to load the menu into the system memory to solve menu gfx problems but this doesn't work with Dx9 I suppose, ddfix I think works on Dx6 legacy engine. Also I can't see any line to force fullscreen on ddfix.

    So at this point DDrawCompat patch seems to be the fastest way to run the game with the legacy Dx6 renderer cause probably can run it in a REAL full screen mode and the difference is quite a lot in Win 8.1 but still far from what it could be with the Dx9 one anyway. Anyway the DDrawCompat along with the T2Fix thief.exe engine gives that polygons/lights errors on the floors and walls and I tried most cam_ext options and no solutions found for now.
    So to explain the situation:

    Win8.1 and GMA3600 gpu latest drivers:

    1) Thief2 original exe crash at exe file launch.
    2) Thief2 original exe with DDrawCompat the thief exe still crash before even loading the ddraw dll
    3) Thief2 with T2Fix exe only, start and works with legacy Directx6 D3D and only in windowed fake full screen mode = slow fps but no gfx errors; if fullscreen is forced in cam_ext it tries different resolutions mode before the menu and than gives a 640x480 video unsupportet window error; if I use the Directx9 renderer I've both menu and video unreadables screen (see above) and if the game get to start it works ok at fastest frame rate ever (like three times the windowed Dx6 mode) but it hangs during movements with no gfx errors into the game but still into the menu.. those hangs of the character doesn't crash the game but make it unplayable cause it stops for like some seconds depending on the scene
    4) Thief2 with T2Fix exe and with DDrawCompat: this ddraw patch seems to be used only in legacy Directx6 renderer mode and it solves definetely the unsupported fullscreen problem and it's the fastest legacy renderer solution with this GPU but this combination results in few polygons becoming dark and lights bleeding in different scenes on the floors and walls (see above)
    5) Thief2 with ddfix: similar to T2Fix legacy windowed solution.. not forcing fullscreen option on the ini and no video starting but similar low frame rates.

    I'll update...

  7. #482
    Level 10,000 achieved
    Registered: Mar 2001
    Location: Finland
    Hey, question: I got Thief 2 (Steam version) and T2Fix 1.27d installed and the game keeps forgetting my bindings! Every time I start it up I gotta go into Customize Controls and load my bindings file. How do I fix this?

    Haven't played Thief 2 in ages but I just reinstalled it and started playing the Death's Cold Embrace FM. It's great!

  8. #483
    Zombified
    Registered: Sep 2004
    user.bnd in root read only?

  9. #484
    Level 10,000 achieved
    Registered: Mar 2001
    Location: Finland
    That was it! Thanks.

  10. #485
    Member
    Registered: Aug 2020
    Update on the Thief2 and PowerVR SGX545 T2Fix problem:

    Not any improvements done with the T2 game but I'm trying to understand if at least the DDrawCompat will be updated to solve the polygons/light bleeding problems that it seems to show with this GPU and the combination of both T2Fix patch and its ddraw.dll that seems to be at least the best Directx6 way to play the T2 game. Until I'll find a solution I bought the Thief Gold game and tried the TFix patch and also again the DDrawCompat patch. With the legacy cam_ext Directx6 renderer it run @fullscreen as well with even higher frame rate but incredibly it does NOT have any polygons or "important light bleeding" problems! The older game runs smooth and not any important gfx problems seen until now (I already am @ the fourth level). So at the end something is different in Thief2 3D engine from the Gold version cause no polygons are rendered black or appearing and disappearing.
    I only noticed some light bleeding coming under closed doors that I suppose should not be rendered into dark rooms in Thief Gold, but it's indeed the fastest way with only few fps slowdowns @1024x768 4X anisotropic, no AA, legacy renderer as said.

    Anyway the Directx9 d3d_display line still impossible to use and shows the usual above unreadable menus, no way. I suppose that the Thief engine render the menu using 2D DirectDraw or whatever it might not be supported by the GPU using Directx9 driver that might try to render the menu with the 3D acceleration using some techniques that is not probably supported on this driver or something like that. The legacy fullscreen problems instead was probably related to the Win 8.1 GUI and 16bit resolutions lack of this gpu drivers that at least the ddraw.dll seems to solve with a good fps boost comparing to the windowed before.

    I suppose probably only a T2Fix patch update would solve this issue trying some alternative way to render the menu and also to understand those strange game hangs I was talking above.
    I'm probably one of the last person in the world playing this game with this GPU.. or probably even using this GPU.
    Last edited by 386SX; 26th Dec 2020 at 12:04.

  11. #486
    Member
    Registered: Aug 2020
    Update: I'm hoping and giving detail of the problem to the developer of the only ddraw patch that got to enter into a real fullscreen legacy mode solving both the speed problems of the SGX545 gpu and the old fake fullscreen windowed mode the game could run before, but for now shows some new polygons texturing/lighting problems that probably need some tweak or on the Directdraw patch side or on the cam_ext settings.
    Meanwhile I'd like to ask expert here some opinion of where I can try tweaking cam_ext file for this problem...



    EDIT: I edit just to say that the legacy renderer thank to the DDrawCompat ddraw now works without errors even with the GMA3600 integrated gpu cause it was debugged a problem specifically happenning with this gpu/drivers (related to some calls and how the drivers worked). Anyway even if the DX9 renderer can't still work as it could, the legacy one now works as fast as it can.. not perfect for the netbook/configs that have this gpu but at least at playable frame rates. I'd like to test and help in debugging the DX9 problems, but it'd need a sort of GitHub discussions on issue with developers of the DarkEngine for the DX9 calls, that shows quite some problems in T1 and T2 and this specific uncommon gpu.
    Some opinions of more skilled people than me, might be that some of the DX9 calls pick wrong part of the video (system) memory corrupting rendering in 2D menu through 3D rendering, instead of the old ddraw, but also might be something related to how the main menu pcx format files and maybe not supported by the gpu drivers (example the 8bit textures palette).
    Last edited by 386SX; 15th Jan 2021 at 08:28.

  12. #487
    Member
    Registered: Mar 2014
    Location: Istanbul, Turkey
    Hello,

    Do you think you can add a feature to the installer which performs a clean-up of obsolete and/or unnecessary files? I did a clean installation of Thief II: The Metal Age by using the GOG installer, but the files inside the folder are a total mess.

  13. #488
    Member
    Registered: Mar 2015
    Certainly. I can see the utility of an optional cleanup feature. Specifically, which extraneous files persist in your installation directory?

    Quote Originally Posted by 386SX View Post
    I edit just to say that the legacy renderer thank to the DDrawCompat ddraw now works without errors even with the GMA3600 integrated gpu cause it was debugged a problem specifically happenning with this gpu/drivers (related to some calls and how the drivers worked). Anyway even if the DX9 renderer can't still work as it could, the legacy one now works as fast as it can.. not perfect for the netbook/configs that have this gpu but at least at playable frame rates. I'd like to test and help in debugging the DX9 problems, but it'd need a sort of GitHub discussions on issue with developers of the DarkEngine for the DX9 calls, that shows quite some problems in T1 and T2 and this specific uncommon gpu.
    Regarding this, it is fortunate that you were able to help get DDrawCompat working with the legacy renderer and your machine. While perhaps not ideal, even this seems to be a feat for that particular chipset. Unfortunately, the manner in which NewDark is developed will probably make it difficult to have a fruitful discussion with its developers regarding your issues with the new renderer.

  14. #489
    Member
    Registered: Aug 2020
    Quote Originally Posted by Jax64 View Post
    Regarding this, it is fortunate that you were able to help get DDrawCompat working with the legacy renderer and your machine. While perhaps not ideal, even this seems to be a feat for that particular chipset. Unfortunately, the manner in which NewDark is developed will probably make it difficult to have a fruitful discussion with its developers regarding your issues with the new renderer.
    Yes in fact I am already happy that with the legacy renderer this specific gpu can at least work in real D3D HAL legacy mode and fullscreen without the whole speed brake that windowed mode together probably with the win GUI had. I finished this game before with that config with really really low frame rates.
    But now the legacy renderer in Thief 1 is perfect cause simpler geometry and frame rate seems to be around 25-50fps I'd say approximately but Thief 2 is heavier and suffer more on wide areas and I'd say from 20fps to 30fps at best more or less. While in the DX9 renderer tests the game probably'd run @ more than 60fps from the few time I got to load the real game with that enabled.

    Still I could build a time correct Directx6 machine or a faster modern machine but this became a sort of quest to see a gpu that could be optimized probably more than it was running as fast as it could have. Obviously we're talking about a smartphone oriented gpu that's probably an evolution of the core used into an iphone 4/4s I suppose adapted for a x86 machine and Directx usage so it can't be expected to have who knows which modern performances, but the problem I imagine was more about its drivers than the specifications that still were not bad after all.
    Could I use another gpu? Of course, the mini-itx board has a PCI old version onto it and I already tried a Geforce FX 5200 and a Geforce GT 210 and they both work with the DX9 renderer but using another case would make obvious to use a full micro atx mainboard with much better PCI-EX gpu. For old games the igpu should be more than enough and in fact it works with unexepected games like Quake2/3, Doom3, Far Cry, GTA IV, Thief Deadly Shadow (without the wrapper)... the oldest run faster, the more modern slower but the problem with the DX9 renderer feels like very simple to solve on a driver or game engine side but from the user one I just can have ideas or opinions but I can't solve it myself.
    Last edited by 386SX; 16th Jan 2021 at 09:05.

  15. #490
    Member
    Registered: Mar 2014
    Location: Istanbul, Turkey
    Quote Originally Posted by Jax64 View Post
    Certainly. I can see the utility of an optional cleanup feature. Specifically, which extraneous files persist in your installation directory?
    Well, I don't know which files are unnecessary after a clean installation and T2Fix, so any file that the patched game does not require to run, basically.

  16. #491
    Is it possible to have New Dark v1.27 (installed via T2Fix), but also have HD Mod 1.0 at the same time?

    I only ask because T2Fix installs New Dark v1.27, but then HDMod1.0 installs New Dark v1.26. It's like an endless loop since HDMod1.0 requires T2Fix to be installed first. When T2Fix and HDMod were both installing 1.26, all was well. Now that T2Fix gives 1.27 and HDMod1.0 give 1.26, though, it's not clear how to get to 1.27 and stay there, if you want HDMod, too.

    I know these patches/installs are probably developed by different people, and the root of the issue is probably HDMod1.0 since it requires T2Fix to be installed first, but thought I'd pose the question here. Sometime soon I may try to post similar question in an HDMod1.0 forum.

    Here are the files I'm trying to work with...

    T2Fix 1.27d - https://www.ttlg.com/forums/showthread.php?t=149669
    HD Mod 1.0 - https://www.moddb.com/mods/thief-2-h...sion-installer

    PS: When I installed T2Fix 1.27d today, I was really hoping its install wizard would identify and tell me what version of New Dark I was currently on (since I wasn't exactly sure where to look at first), and have it ask me what I wanted to do; possibly with some guidance. For example, something like this:

    * "You're on T2Fix and New Dark v1.26. If you proceed, 1.27 will be installed. No need to uninstall your earlier version of T2Fix or New Dark. Note: Any earlier custom T2Fix settings for water, sky, and New Dark (including captions/subtitles and blood decals) may be reset to defaults, so make a note of what you have and/or maybe make back-up copies of _these_files_(e.g., user.cfg)_. Want to proceed?" (or whatever guidance you feel is realistic to provide)
    * Ideally, also saying to uninstall the HDMod first and re-install it afterward would be helpful, as that seemed to be necessary for me. (I had some HD graphics anomalies when I didn't uninstall it first (I had a black doorway leading out to where the pirate ship is in "Shipping & Receiving", and a very bright gamma main menu, for example.)) I'd understand if that's not feasible or desirable to add this note, though, given the number/types of mods people might have installed. Plus, I'm just one example. Maybe it works fine for everyone else to not uninstall it first.

    I happened to take note of my Thief2.exe file's "product version" and saw that it went from 1.26 to 1.27 after installing T2Fix 1.27d. That's how I knew it was showing me the New Dark version. So when I uninstalled HDMod1.0 and reinstalled it, my version went back down to 1.26

    PPS: Sorry I can't format my post very well. All of the icons for formatting are invisible.
    Last edited by Darkness_Falls; 24th Jan 2021 at 15:50.

  17. #492
    Member
    Registered: Sep 2007
    Location: Leipzig (Germany)

    After installing T2fix_1.27d

    My intention for installing the fix was to face a texture problem - since 2 months were some textures complete black and the sounds of all door openings were absent - complete silence. Today I recognize, that I could not draw an arrow for the bow, no sword to fight. Strange! I thought "install the Fix and everything will be ok".
    While the installation I noticed, that the directory "C:\programs" are not to choose. So I move the whole subdirectory to "C:\T2".
    Now I ran the installation, without errors or stops (choosing all options ).
    After starting thief2.exe the long not seen start video played - I skipped it and an empty start menu faced me, 1 second later I landed on desktop.
    Also the modification of the cam_mod.ini to start with the FM-Selector brought no better results.
    Also removing the "HDMOD"-Folder to another place to deinstall this, could not help.
    Can somebody help me??





  18. #493
    Zombified
    Registered: Sep 2004
    I'd repatch the install one more time and reboot the computer.

  19. #494
    Member
    Registered: Sep 2007
    Location: Leipzig (Germany)
    Quote Originally Posted by voodoo47 View Post
    I'd repatch the install one more time and reboot the computer.
    The whole thief install or only TFix ?

  20. #495
    That looks eerily similar to this post over on ModDB, and the same black plane I was seeing in a 'Shipping & Receiving' mission doorway:
    https://www.moddb.com/mods/thief-2-h...rs-and-hatches

    As I mentioned there, what 'seemed to' work for me was uninstalling HD Mod. (Probably do a reboot after this.) Then re-install T2Fix. Then re-install HD Mod. But... as I indicated a few posts above here at TTLG (right before your post), installing the HD Mod will, unfortunately, then make your Thief2.exe be New Dark 1.26 instead of 1.27, since v1.26 is embedded with the HD Mod installation.

    If you find a way to install both and still have your Thief2.exe be at Product Version v1.27, I'm all ears.

    What I'm seeing is that with mods/patches, it might be good for developers to somehow de-couple the New Dark installation from their mods; or have HD Mod be the primary way of getting the latest New Dark and keep it updated. Just want both mods to peacefully co-exist and make it easy for me/us to install both mods while being able to be on the latest New Dark... which at present is v1.27 Or have New Dark be a completely separate install to do after T2Fix and HD Mod are installed, so no mod/patch gets out-of-date or behind-the-times with New Dark versioning.
    Last edited by Darkness_Falls; 24th Jan 2021 at 15:57.

  21. #496
    Zombified
    Registered: Sep 2004
    yes, including NewDark executable files with your mod is very, very bad practice. nobody should be doing this, ever.

  22. #497
    Member
    Registered: Sep 2007
    Location: Leipzig (Germany)
    Quote Originally Posted by Darkness_Falls View Post
    That looks eerily similar to this post over on ModDB, and the same black plane I was seeing in a 'Shipping & Receiving' mission doorway:
    https://www.moddb.com/mods/thief-2-h...rs-and-hatches
    . . . .
    Thanks for your idea and effort but I think, before I could not find the reason for this start crash, I could not fix the texture problem. Do you think, there is a connection between?

  23. #498
    Oh, I'm afraid I'm not sure, Dr.Sahnebacke I don't frequent the forum enough to know a lot of the bugs, issues, and solutions that I'm sure other taffers have seen or are aware of. From my basic knowledge/observations, I thought your issues were quite possibly being caused by the HD MOD; so uninstalling the HDMod (via "Add or Remove Programs" in Windows 10), then Start > Power > Restart, and then re-installing T2Fix and then HD Mod seemed like a somewhat painless thing to try. But I'm definitely no expert in this

    Quote Originally Posted by voodoo47 View Post
    yes, including NewDark executable files with your mod is very, very bad practice. nobody should be doing this, ever.
    Yes, I think the idea was nice, in theory -- to help simplify for users (since patching T2 was more confusing in past years). But, unfortunately, over time such nice packages can easily get outdated or in the way of progress

  24. #499
    Member
    Registered: Sep 2007
    Location: Leipzig (Germany)
    Quote Originally Posted by Darkness_Falls View Post
    Oh, I'm afraid I'm not sure, Dr.Sahnebacke I don't frequent the forum enough to know a lot of the bugs, issues, and solutions that I'm sure other taffers have seen or are aware of. From my basic knowledge/observations, I thought your issues were quite possibly being caused by the HD MOD; so uninstalling the HDMod (via "Add or Remove Programs" in Windows 10), then Start > Power > Restart, and then re-installing T2Fix and then HD Mod seemed like a somewhat painless thing to try. But I'm definitely no expert in this
    I'm sorry, but I did it today afternoon yet. I move at first the folder "HDMOD" and 3 files with name "hdmod.xxx" from the T2-root-directory to another place on disk. Then, quite unusual, tried to remove it to late over the windows control center (error message, but then disappeared the entry "HD-Mod" in the list).

    It had no effect. Always the same crash to desktop.

    Also , with the help from german friend, I modified some "MOD"-entries in the cam_mod.ini. No effect

  25. #500
    Zombified
    Registered: Sep 2004
    does your freshly T2Fix patched Thief2 install work properly without hdmod? if it does, then you don't have a problem with T2Fix, but with hdmod.

    I'd probably just use NecroAge or EP2 for hd textures if you can't get hdmod working.

Page 20 of 20 FirstFirst ... 510151617181920

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •