TTLG|Thief|Bioshock|System Shock|Deus Ex|Mobile
Results 1 to 4 of 4

Thread: Weird glitches in "Trail of Blood" mission of Thief 2

  1. #1
    New Member
    Registered: Nov 2018

    Weird glitches in "Trail of Blood" mission of Thief 2

    Hi, I've been enjoying replaying Thief 2 with the HD Mod, which Beatrixx (?) did an absolutely amazing job with by the way, and haven't experienced any problems so far other than maybe some weird clipping with the animated vegetation here and there. However, when I got to the Trail of Blood mission (the one where you are following the wounded pagan's blood trail) it seems to all break apart...

    My installation is: GOG version of Thief 2; installed TafferPatcher; installed HDMod; I run Thief 2 using the FM launcher, but only played around with 1 FM so far as I was wanting to replay through the original first. I'm playing through Wineskin on Mac, which I have never had any problems with before (just completed a playthrough of Thief Gold with HD Mod before without any technical difficulties whatsoever, and it was glorious : ) Every mission I've played so far in Thief 2 has worked perfectly and it was very surprising to suddenly have the game completely freaking out...

    The problems I'm experiencing in the mission are:

    - the first mechanist encountered in the mission, across the river by the large stone face sculpture is invisible much of the time, except in some small segments of his patrol; he still makes walking sounds and can still be knocked out even when invisible (unconscious body continues being invisible)

    -cannot attach to ladders at all no matter what I try. This includes the ladder to the treehouse and the ladder in the granary...I've tried both "attach on touch" and "attach on jump" to no avail. Garrett just flies through the granary ladder, which isn't against a wall as if it didn't exist. Something with the collision detection seems to not be working.

    -further and further the hit collision gets even weirder: the mechanist patrols by the Gathering Place aren't able to hit Garrett when they get alerted. Crossbow bolts just seem to fly through Garrett without hurting him and he just shrugs off the mace blows from the other one. I think they also can't be hit by the blackjack, though I forget for sure. Again, hit detection is failing I guess...

    -The portal doesn't show up in the mouth when I place the two rubies in the eyes, so it seems like I am stuck at this point. I was hoping maybe it would only be this mission that was broken and I could just get through it, but I can't seem to make any progress at this point...

    Anyway, no idea if this might be caused by HD Mod, I frankly doubt it, as I'm sure other people have played through the game with it, but thought I'd mention what all the things I have installed are and see if anyone has experienced any similar problems or have any idea what they might be caused by. I suppose I should try to backup my save file and just reinstalling at this point.

    Thanks and taff on

  2. #2
    Zombified
    Registered: Sep 2004
    physics stuff tends to be v-sync sensitive, so I'd try enabling that (or rather, make sure it's not getting disabled). and yes, trying the game without hdmod and seeing whether that makes the issues go away would be a good start, and only should take a couple of minutes (make another clean new install, patch up with the latest T2Fix, and use the ctrl+alt+shift+del combo to skip levels until you get to the problematic mission).

  3. #3
    Member
    Registered: Nov 2004
    Location: Germany
    I think it's the same problem like in this thread:
    https://steamcommunity.com/app/21174...0458825893662/

    As i said there:
    The HD mod changes the 'higher object count' already in the last step of the installation. If you skip that last step, you will get problems.

  4. #4
    New Member
    Registered: Nov 2018

    Awesome Gecko, thanks, that thread does indeed provide an explanation of the problem and a solution. I'll paste it here too in case it ends up being useful for anyone else in the future:

    Check inside the dark.cfg file (in the main Thief 2 folder) to see what the object count numbers are. It should look like this.

    ; object counts
    obj_min -8192
    obj_max 2400
    max_refs 14000

    If the HD mod does what I think it does, you may want the numbers to be like just to be safe.

    obj_min -18192
    obj_max 7900
    max_refs 50000

    Adjusting those 3 lines completely fixed the problem for me; I suppose all the previous missions had a low enough object count that this problem didn't come up at all, it might be that all the 3d grass or something is being counted toward certain limits. I have no idea about the technical details but this fixes things. Apparently there is a part of the installation of the HD Mod that I just skipped \ missed somehow that is supposed to adjust these configs.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •