TTLG|Thief|Bioshock|System Shock|Deus Ex|Mobile
Results 1 to 14 of 14

Thread: Thief 2 crashes by spiders

  1. #1
    Member
    Registered: May 2004
    Location: Germany

    Thief 2 crashes by spiders

    Dear TTLG veterans,

    after years I reinstalled Thief 2 to witness the story of this game. I also tried some FMs. I installed it using TFix 1.27 that comes along with NewDark 1.27.
    But whenever I encounter spiders and they see me, the game crashes. The sound gets stuck in a small loop with the spiders "alert noise" and closes. I must restart the computer to make the noise begone. This happens in the original missions (like when you enter the butcher's room "who makes the best steaks" in mission 2) as well as in FMs (like Bafford's Manor, where you dive after the well house to the spider's lair).
    As soon as they see me, the game crashes.

    Did no one else notice this? Can someone replicate this with 1.27? I am using Windows 10 on an AMD Ryzen CPU with NVIDIA GPU. Please test and confirm or decline.

  2. #2
    Member
    Registered: Jan 2001
    Location: Pushing my luck with Dromed
    No problems for me. Different graphics card though (ATI Radeon R9280).

    If you have any mods installed, try disabling them in case one of them contains a spider model/texture which is corrupted.

  3. #3
    Zombified
    Registered: Sep 2004
    I'd try a clean install, and no FMs, see whether that helps. then the FM. if it still crashes, post the log, the crashdump, the FM name, and maybe a save right before a place where it crashes, we'll see.

  4. #4
    Member
    Registered: May 2004
    Location: Germany
    Thank you so much for your answer. Regarding the spider crashes, this also appears on the original campaign (e.g. in the docks on mission 2 in the spider's cage house). I tried opening the crashdump file but its only cryptic signs in Notepad++ mostly - how am I able to read this file correctly? Please help me a little more

  5. #5
    Zombified
    Registered: Sep 2004
    zip it up and upload somewhere (gdrive, ideally), post the link and we'll see. include a save and logs, if possible.

  6. #6
    Member
    Registered: May 2004
    Location: Germany
    I've packed the crashdump and the save from Mission 2. If you load the save game, just go into the garage with the spiders, as soon as you startle them it crashes. Maybe someone could take a look at it? This would be really helpful and means a lot to me! Thank you

    Password: thief
    ZIP Download: https://easyupload.io/tlkv76

  7. #7
    Member
    Registered: Jan 2001
    Location: Pushing my luck with Dromed
    I don't know if there's any significance to this, but when loading the savegame the player has gravel footsteps in the immediate area (especially going south).

  8. #8
    Zombified
    Registered: Sep 2004
    can't make it crash though - can you share the thief2.log as well?

  9. #9
    Member
    Registered: May 2004
    Location: Germany
    I just tested again with the quicksafe I've provided. As soon as I enter the hall and the spider gets annoyed, it instantly crashes repeating the last 0.2 seconds of the game sound all over in a loop until I restart my computer...
    The "gravel ground sound" I cannot confirm. Tis normal stone sound for me.

    Here also the other log file:
    https://easyupload.io/6d9s03

    I have really no idea what could be the issue

  10. #10
    Member
    Registered: May 2004
    Location: Germany
    Wow.. I just SHUT DOWN my PC and booted it up 10 minutes later again. The sound STILL appears!! WTF how can this be possible? How can I get rid of this OMG ((((

    EDIT: I went to Hardware Manager and deactivated my Asus Xonar external Sound Device. After reactivating it, the sound is finally gone... Man I just got a heart attack in fear of having to re-install my Windows all over
    Last edited by SeriousToni; 15th Mar 2020 at 12:31.

  11. #11
    Zombified
    Registered: Sep 2004
    aha, a standalone sound card - that would explain a lot, as those are known to be more trouble than worth nowadays (with other games as well, not just Dark). see whether there is a hw acceleration option in the Audio menu that will make the problem go away. you can also try to set openal to soft in cam_ext, see snd_oal_device Generic Software.

  12. #12
    Member
    Registered: May 2004
    Location: Germany
    You were absolutely correct. Thank you so much for helping me!

    The fix was: Disable the "GX Mode" in the Asus Xonar Settings Software. With this I was able to load the savegame and even kill the spider without crash.
    Thank you again, I hope this can help others too!

  13. #13
    New Member
    Registered: Jan 2016
    Maybe your computer is just arachnophobic.

  14. #14
    Member
    Registered: May 2004
    Location: Germany
    Hahaha that would have been the best explanation indeed

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •