TTLG|Thief|Bioshock|System Shock|Deus Ex|Mobile
Results 1 to 6 of 6

Thread: turbine ambients - please help

  1. #1
    Registered: Sep 2002
    Location: swirling in the night wind

    turbine ambients - please help


    I know this is a tired subject because I have read and tried every thread and solution I found in the forum. Tried them all. Nothing worked.

    Not a single one of the turbine ambients will play when I test them in game. They only play under 'play schema'.

    The sounds are all in my SND folder (crf). The schemata are all there, too. I reloaded the schemata in case that was the problem. Still no result.

    Can anyone help me with this?

  2. #2
    Registered: Jan 2001
    Location: Pushing my luck with Dromed
    It always helps to say what you've tried, although if you've been banging your head against a wall for a couple of hours that can be the last thing you want to do.

    A couple of suggestions:
    For a permanent sound, i.e. when the turbine is always on and cannot be turned off,
    AmbientHacked property: turbine_lp

    To be turned on/off by a lever:
    Don't use the above.
    Instead add two scripts: TweqOnOff and OnOffSounds
    Last edited by R Soul; 31st Mar 2020 at 09:26.

  3. #3
    Registered: Sep 2002
    Location: swirling in the night wind
    Hello Mr. Soul

    I have tried that. And yes, I did try many "fixes" that I found here - for hours. A hint to the problem might be the fact that in folders with previous versions of NewDark, the sounds all work perfectly, as do the fixes. The problem seems to be either with NewDark or the way tfix overwrote the older files in the folder? I am thinking to test this out by starting with a clean copy of Thief2, updating that with Tfix, then adding my files and folders for my mission.

    I will go back and review and write every solution I tried and paste it here. It will take some time, though.

    EDIT: I just added a schema called NEWturbine to My_Schemas and used the turbine_lp sound with a mono_loop 0 0. That is working perfectly. But It feels Rube Goldbergish. I will probably still try a clean installation to see if it fixes the problem.
    Last edited by redleaf; 1st Apr 2020 at 04:45.

  4. #4
    Registered: May 2002
    Location: Texas
    If a new schema works with the same wav file as a default schema, but the default doesn't work, then maybe it has something to do with how you added the schema to the turbine. Some things that could have prevented the default schema to play in game... No room brush where the turbine exists or no room brushes placed where the player could hear the schema, misspelling the schema name, and making the AmbientHacked property as an Environmental ambient and can't be triggered. What was the radius of the ambient?

  5. #5
    Registered: Sep 2004
    if you want a turbine to play the machinery sound when turned on, and stop when turned off, check TFixed TG miss3 turbine 1207 and its dml fixup code;
    +ObjProp 1207 "Scripts"
    	"Script 0" TweqOnOff
    	"Script 1" ActivateAmbient
    +ObjProp 1207 "AmbientHacked"
    	"Radius" 25
    	"Flags" TurnedOff
    	"Schema Name" m05turbine
    activated by switch 93. //completed the dml code, so this can now be loaded onto any turbine (just change the obj id from 1207 to whatever your turbine is), and it will work (as long as a proper switch is connected to the turbine).
    Last edited by voodoo47; 3rd Apr 2020 at 07:37.

  6. #6
    Registered: Sep 2002
    Location: swirling in the night wind
    First, I want to thank everyone for their help. This is hard to say, because it's so dumb, but the trouble was indeed the room brush. My "insert" key doesn't work any more. But I still sometimes hit "shift-insert to create a room brush. It doesn't get created. So I drew the room brush myself, but forgot to check that it covered the whole room. It fell just short of the location of the turbine.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts