TTLG|Thief|Bioshock|System Shock|Deus Ex|Mobile
Results 1 to 6 of 6

Thread: Thief 2 on Linux issue - flashing textures

  1. #1
    Registered: Nov 2003
    Location: Sheffield, UK

    Thief 2 on Linux issue - flashing textures

    Hi gang

    I'm running a Zorin system which is a fork of ubuntu & I've been happily playing Thief missions using Wine on it for ages

    However I've now hit a mission which is giving me problems in that various textures flash depending on where I'm looking and when they flash the game stutters & becomes unplayable

    The mission is Kingsbridge v1 & this is the only mission I've hit a problem with, pretty sure the mission isn't corrupted, I downloaded a copy from a different source & the zips are the same, absolutely gorgeous mission btw, play it if you get a chance

    Thief is version 1.27

    I've tried a few of the wine tweaks to try & improve performance, none of which had any noticeable effect

    My best result so far has been to drop the resolution to 640x480 & disable distortion effects by commenting out d3d_disp_enable_distortionfx in cam_ext.cfg but even than if I look at the wrong part of the screen it stutters, usually it's something at rooftop level but some areas flash like a bad acid trip in a disco when I walk into them no matter where I look

    Any suggestions would be gratefully received

    System specs are Zorin OS 15.3 (64 bit), Intel® Core™ i7-4770 CPU @ 3.40GHz × 8, 8Gb Ram, NVIDIA Quadro K600/PCIe/SSE2 using NVIDIA binary driver 340.108

  2. #2
    Registered: Nov 2019
    Location: Restaurant at end of universe
    Are you running redshift or compiz ? If you are try disabling them. I run Linux Mint but have had problems with some games when those are enabled. I can try running that FM on my system if that is not your problem.

    Edit: I downloaded it (played this one before with no problems then). No problems running it this time except with Necroage install - everything went black after i picked up the note at the beginning. I ran it with the non-mod version and see no problems out to the street. Using patch 1.27c. I'm running Wine version 5.0.3 and have it set for Windows 7.
    Last edited by howeird; 13th Nov 2020 at 17:53.

  3. #3
    Registered: Nov 2003
    Location: Sheffield, UK
    compiz sounds familiar, I'll have a dig round, thanks for the advice

  4. #4
    Registered: Nov 2019
    Location: Restaurant at end of universe

    If the problem is still not solved.

    - Excluding patch varieties, Thief has always been the most reliable game I've had for working properly with different Wine versions. I was having stuttering problems with all my other games recently and it took me 2 weeks to figure out the problem. I have a Windows 10 computer and Linux computer. On the Windows computer, the 2H20 Windows 10 update turned on "Game Mode" which caused stuttering and lag in all my games. Turning it off fixed all my games except my Tomb Raider steam installs. I looked at my TV settings and found there was a "Game Mode" on it as well which was 'on' so i turned that 'off' and now stuttering is gone on all my games. I wish Microsoft would get its act together and quit messing with my OS settings. But regardless, check your monitor settings because it may effect Linux as well.

    - Make sure your video drivers are up to date.

  5. #5
    Registered: Nov 1999
    Location: Deck 4 Cargo Bays
    Just my 2 cents, but could you try a different video card maybe? You list a Quadro, and that card family wasn't really game oriented. While it's practically the same thing as a GT 640 (with a few shading units disabled), the Nvidia driver may have different firmware/settings applied to optimize it for a more "professional" workload.

  6. #6
    Registered: Nov 2003
    Location: Sheffield, UK
    I cracked it

    My video driver was out of date in my defence I'm relatively new to Linux, I think the last version I used was Solaris back when I was an sysadmin many, many moons ago & I didn't use the GUI much

    Anyway I just figured out how to install the latest driver & it's running as smooth as a very smooth thing at the highest resolution

    You guys rock , thank you for the suggestions

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts