TTLG|Thief|Bioshock|System Shock|Deus Ex|Mobile
Results 1 to 4 of 4

Thread: cam_ext.cfg modifications question

  1. #1
    Registered: Aug 2020

    cam_ext.cfg modifications question


    after many tests I think to see a clearer picture of why Thief 2 with the modern engine give me problems my igpu.

    First a question: is the cam_ext.cfg supposed to be modified with some special low level editor or with some formatting rules? Or is it connected to other files that once the game start for the first time it can't be simply modified later?

    Because what seems to happen with my genuine Thief2 installation on Win 8.1 is that if I modify with notepad the latest patch's cam_ext file (for ex. commenting d3d_display line I need to make it work) BEFORE the first run, everythings works/render fine (using an external ddraw dll thanks to DDrawCompat from GitHub, to make real-fullscreen to work on this complicated config that would not run fullscreen without it) but what I noticed is that if I modify this file AFTER having launched already the patched game, when I start again the game something get broken in the rendering and even copying the original cam_ext doesn't solve the problems. I suppose it might be related to my iGPU but I don't get the logic.

    For example.. clean full installation of the genuine (I think it's the premium version) v1.07 double cd game, then I install T2Fix Basic setting, then I modify/comment the d3d_display line (cause the iGPU/D3D9 renderer has problems with the way DirectDraw menu would be rendered, I'll explain later) for the D3D HAL legacy renderer and save it BEFORE launching the game, then I install ddraw.dll and then I start the FIRST run of the patched game: in this way everything works fine even if I load the savegame in a second time.
    But if I modify later again the cam_ext file in some not important area multisampling for example, something get broken like shutting down a torch doesn't shut down the lightmapped area (first level torch/guards) or the sofas/vases in the mansion salon fireplace disappear completely (I think that in the v1.07 those objects weren't there this might say something). Or gfx errors like black rooms once the door is opened.

    Does it make some sense? I suppose this might happen only with my config but I don't see the logic. If I reinstall everything from zero as above described, it works again.

    Any hints or opinions?

    An example of the problem just simple modification (multisample to 1) after already launched the game a previous time:

    Torch off, area remains lighted, guards see the player. This happened after modifying that multisample value. Even restoring the previous cam_ext it remain broken. Sofa and vases on the mansion salon disappeared.
    Meanwhile if I find some logic or fix to understand it I'll update the thread.


  2. #2
    Registered: Aug 2020
    Anyway beside the above problem that can be solved for now not modifying the cam_ext.cfg and I am doing tests on to understand, would any update on the modern DX9 engine be possible or is nowdays the latest version?
    Cause I'd like to understand more than the problem above, the bigger and more complex problems I got if I enable the d3d_display line with unreadable menu (frame buffer get tiled random pixels until the 3D game start) and strange pause/hangs the game has from the early seconds of the rendering; same or similar problems happens in Thief game too with the DX9 engine. This is a very specific problem probably only happens on the GMA3600 integrated gpu with this specific game cause I tried different cards of far generations and they both works perfectly with DX9 engine. So it's probably more a gpu driver problem than a game engine one, but I can't expect driver update of such old gpu discontinued much time ago.
    The only way would be to understand how to fix both the unreadable menu (D3D9 I suppose render the 2D old DirectDraw menu as a texture or whatever) and the 3D hangs (not crash, the game still run until it wake up and continue the rendering) on the engine/tweaks more than the drivers/lacks of this gpu.
    This problem I have tested many times, doesn't happen with the legacy renderer (that had other problems, now solved) but it is obviously slower than the DX9 one, like probably half or less of its frame rate.
    Last edited by 386SX; 13th Jan 2021 at 10:06.

  3. #3
    Registered: Mar 2001
    Location: Ireland
    Windows Notepad is notorious for messing up the formatting of text files, especially ones which use Linux-style line endings.

    You could try using a proper editor like Notepad++

    That would only explain your losing cam_ext settings, though, not your other strange problems.

  4. #4
    Registered: Aug 2020
    Quote Originally Posted by Nameless Voice View Post
    Windows Notepad is notorious for messing up the formatting of text files, especially ones which use Linux-style line endings.

    You could try using a proper editor like Notepad++

    That would only explain your losing cam_ext settings, though, not your other strange problems.
    Thanks, I'll try that.

    For the other problems there'd be hope for the newer Directx9 renderer to run because the problems feels like "solvable" and there'd be tools to understand/trace the problems but I couldn't understand by myself where exactly things get wrong for each single frame/calls/api/texture/etc... Most video cards out there has many released drivers for decades of Win drivers development experience while this gpu lasted only few years in Win enviroment. Probably other gpu drivers has better support for situation like the menu one, where an old DirectDraw menu might be rendered with the D3D9 calls to work without DirectDraw at all.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts